Skip To Content

ArcGIS Pro 1.4 system requirements

New or changed requirements at ArcGIS Pro 1.4

This section is for existing ArcGIS Pro 1.3 users who want to read only the system requirements that changed between the 1.3 and 1.4 releases. The rest of the topic describes the complete set of requirements.

  • Windows 8 is no longer supported by Microsoft; therefore, it is no longer supported by ArcGIS Pro. Please update to Windows 8.1 or later.

  • Citrix XenDesktop 7.5 is no longer supported, but XenDesktop 7.6 and 7.11 are.

  • Windows Server 2016 Hyper-V is now supported.

  • The following table shows the changes to the hardware requirements:

Hardware requirementArcGIS Pro 1.3 requirementArcGIS Pro 1.4 requirement

Minimum video/graphics adapter

DirectX 9 (OpenGL 2.0) compatible card with 512 MB RAM

DirectX 11 feature level 10.1, Shader Model 4.1, OpenGL 3.3, and the EXT_texture_filter_anisotropic and EXT_texture_compression_s3tc extensions

Recommended video/graphic adapter

DirectX 11 (OpenGL 3.2) compatible card with 2 GB RAM

DirectX 11 feature level 11.0; Shader Model 5.0; OpenGL 4.5; 2 GB RAM; and the EXT_texture_filter_anisotropic, EXT_texture_compression_s3tc, EXT_swap_control, and ARB_shader_draw_parameters extensions

Minimum pixel shader

3.0

4.1

Minimum vertex shader

3.0

4.1

Supported platforms

Check your computer's ability to run ArcGIS Pro 1.4.

Note:

Microsoft .NET Framework 4.6.1 or later must be installed prior to installing ArcGIS Pro 1.4.

Operating systemsLatest update or service pack tested

Windows 10 Home, Pro, and Enterprise (64 bit)

Anniversary Update

Windows 8.1 Pro and Enterprise (64 bit)

Update: September 2016

Windows 7 Ultimate, Professional, and Enterprise (64 bit)

SP1 and KB2533623

Windows Server 2012 R2 Standard and Datacenter (64 bit)

Update: September 2016

Windows Server 2012 Standard and Datacenter (64 bit)

Update: September 2016

Windows Server 2008 R2 Standard, Enterprise, and Datacenter (64 bit)

SP1 and KB2533623

Note:

Windows 8 is no longer supported by Microsoft. Please upgrade to Windows 8.1 or later.

Prior and future updates or service packs on these operating systems are supported unless otherwise stated. The operating system version and updates must also be supported by the operating system provider.

ArcGIS Pro is supported as a hosted application running on the following virtualized environments

Virtual Desktop Infrastructure (VDI)Certification

Citrix XenDesktop 7.6

Citrix VDI certified with NVIDIA GRID driver 361.45.09/362.56

Citrix XenDesktop 7.11

Windows Server 2012 R2 Hyper-V

Microsoft VDI certified with RemoteFX vGPU Windows Device Driver Model (WDDM) 1.2

Windows Server 2016 Hyper-V

Microsoft VDI certified with RemoteFX vGPU Windows Device Driver Model (WDDM) 1.2

VMWare vSphere 6.0 Horizon View

VMWare VDI certified with NVIDIA GRID driver 361.45.09/362.56

Note:

Using ArcGIS Pro with Citrix XenApp is strongly discouraged because XenApp is unable to support more than two or three sessions of ArcGIS Pro per server. This has been verified through testing with Windows Server 2012 R2 and 2016.

Citrix XenApp*

Version

Hosted OS

Minimum OS version

Citrix XenApp 7.6

Windows Server 2008 R2

SP1

Windows Server 2012 R2

Update: September 2016

Citrix XenApp 7.11

Windows Server 2016

*A GPU compatible with your virtualization platform is recommended for the best user experience.

Note:

Cloud Environments: ArcGIS Pro will provide adequate performance and usability in many of the cloud environments. The cloud VM must support Windows Server 2012 or 2016 and have an adequate number of virtual cores, memory, and storage.

Application streaming and virtualization

ArcGIS Pro provides a nominal level of functionality and performance in the following environments:

  • Azure RemoteApp
  • Microsoft App-V
  • VMware App Volumes

Hardware requirements

CPU speed

Minimum: Hyperthreaded dual core*

Recommended: Quad core*

Optimal: 2x hyperthreaded hexa-core*

Platform

x64 with SSE2 extensions

Memory/RAM

Minimum: 4 GB

Recommended: 8 GB

Optimal: 16+ GB

Display properties

24-bit color depth

Also see Video/Graphics adapter requirements below.

Screen resolution

1024x768 or higher at normal size (96 dpi)

Visualization cache

The temporary visualization cache for ArcGIS Pro can consume up to 32 GB of space, if available, in the user-selected location. By default, the visualization cache is written to the user profile.**

Disk space

Minimum: 4 GB

Recommended: 6 GB or higher

*Hyperthreaded CPUs typically feature two threads per core. A hyperthreaded dual-core CPU will have four threads available for processing, while a hyperthreaded hexa-core CPU will have 12 threads available for processing.

**The cache is written by default to the user profile’s \Local subfolder, so it does not roam with the user profile if roaming profiles are enabled by your system administrator.

Video/Graphics adapter requirements

Refer to the video/graphics adapter requirements below for information on how to achieve the best graphics performance.

Video/Graphics adapter

Minimum: DirectX 11 feature level 10.1, Shader Model 4.1, OpenGL 3.3, and the EXT_texture_filter_anisotropic and EXT_texture_compression_s3tc extensions.*

Recommended: DirectX 11 feature level 11.0; Shader Model 5.0; OpenGL 4.5; 2 GB RAM; and the EXT_texture_filter_anisotropic, EXT_texture_compression_s3tc, EXT_swap_control, and ARB_shader_draw_parameters extensions.*

Note:

  • DirectX 9 and OpenGL2 are not supported in ArcGIS Pro 1.4.

  • Be sure to use the latest available driver.

Pixel shader version

Minimum: 4.0

Recommended: 5.0

Vertex shader version

Minimum: 4.0

Recommended: 5.0

*A physical GPU is not required to run the system, but it is preferred.

Software requirements

Microsoft .NET Framework 4.6.1 or later must be installed prior to installing ArcGIS Pro 1.4.

Microsoft Internet Explorer 10 or 11 must be installed prior to installing ArcGIS Pro.

The three ways to license ArcGIS Pro 1.4 are as follows:

  • Named User license—Using a named user license means that access to ArcGIS Pro is granted to you via your organizational account in ArcGIS Online or ArcGIS Enterprise. In both cases, an administrator will allocate an ArcGIS Pro license to you from within the your organization's ArcGIS Online organization or ArcGIS Enterprise portal; this is the standard workflow. If you are using ArcGIS Online, the standard workflow is all that is required. However, if you are using ArcGIS Enterprise, you must also use ArcGIS License Manager 10.5 to manage your ArcGIS Pro license allocations. To use ArcGIS Enterprise, you must have version 10.5 or later. Portal for ArcGIS 10.3–10.4.1 is also supported, and must also use ArcGIS License Manager 10.5.
  • Concurrent Use license—ArcGIS License Manager 10.5 or later is required to manage ArcGIS Pro licenses.
  • Single Use license—No additional software is required for licensing.

SDK requirements

The minimum requirements your system needs to create add-ins using the ArcGIS Pro SDK for .NET are described in the SDK GitHub repository.

System requirements for other versions of ArcGIS Pro

System requirements for ArcGIS Pro versions that are retired will eventually be removed from the web help. The product life cycle chart lists all retirement dates and related information.