Skip To Content

Feature compilation using stereo mapping

Available with Image Analyst license.

Collecting and editing 3D features in stereo leverages the existing editing tools. After setting the stereo model and adjusting other stereo-related parameters on the Stereo Map tab, you can switch to the Edit tab to collect features. Stereo 3D feature editing supports concurrent editing and versioning. You can edit points, multipoints, polylines, and polygons as follows:

  • You can create features using the Create tool.
  • You can modify features using the Modify tool.
  • Define XY tolerance for snapping.
For point feature, the Billboard properties is always on. For line feature, if you want to add more weight, change the line property from Strip to Tube, in the Symbology pane. For more information about editing, see A quick tour of editing.

The z-coordinate of the stereo map is based on the stereo model of the source data, which is the z-coordinate at which the stereo images will be adjusted. At ArcGIS Pro 2.1, in order to collect features, you need to create the feature classes with the following vertical coordinate system:

  • For satellite data sources, define the vertical coordinate using Ellipsoidal WGS84.
  • For aerial and drone data sources, define the vertical coordinate as same coordinate system as your GPS or GCP control points.

In this workflow, you will set up your stereo environment, use the stereo map to view the stereo model, create 3D buildings, and view your buildings in a scene. This workflow has five steps:

  1. Download sample data (optional)
  2. Set up the stereo environment
  3. Set up your stereo map collection
  4. Edit features in a stereo map
  5. View your 3D buildings in a scene


You must have either active shutter eyewear or anaglyph 3D glasses.

Download sample data

This is an optional step. If you do not have any stereo data available, you can download sample stereo data. If you already have your own stereo data, you can use your own data and proceed to the next section.

  1. In a web browser, open the Stereo Mapping Sample Data website.
  2. Click the Download button in the upper-right corner. Optionally right-click the .zip file and click Download.
  3. Once the download is complete, unzip the .zip file to C:\temp\StereoTutorial.
  4. Confirm the C:\temp\StereoTutorial location has a Data folder and a VexcelHollywood.gdb geodatabase. If you cannot place your data in this location, you will need to place the data in an appropriate location and repair the paths for the mosaic dataset to your location.

Now you have sample data to use in your stereo workflow.

Set up the stereo environment

To display data in stereo mode in ArcGIS Pro, you need to turn on the correct stereoscopic mode. This task only needs to be performed once, and the application will always used this mode for new projects you create until you change modes.

  1. Click the Project tab.
  2. Click Options.
  3. Click the Display tab.
  4. For Stereoscopic mode, choose either 3D cyan/red glasses or 3D shutter glasses, depending on the type of eyewear you are using. If you are using shutter glasses, make sure that your system meets the display requirements.
  5. Click OK and wait for the program to restart.

Your application is now ready to display data in stereo using the type of stereo viewing glasses you have specified.

Set up your stereo map collection

If you have your own stereo data or the sample that was downloaded, you can proceed to start the workflow. The sample from the data download site is a mosaic dataset that has a stereo model already built.

  1. Click the Insert tab.
  2. Click the New Map New Map drop-down arrow and click New Stereo Map New Stereo Map.

    A new stereo map opens in your display, and the Stereo Map tab is now available to use in the stereo map.

  3. On the Stereo Map tab, click Set Source Set Source.
  4. On the Set stereo source dialog box, set Source Type to Stereo model collection.

    This option filters the browse results to show only mosaic datasets.

  5. Click the Browse Browse button and browse to C:\temp\StereoTutorial\VexcelHollywood.gdb and choose the Hollywood mosaic dataset.
  6. Click the mosaic dataset, and click OK to select it.
  7. Click OK to close the Set stereo source dialog box, and load the mosaic dataset with a stereo model.
  8. Wear your stereo glasses so you can see the stereo pair in 3D.
  9. Temporarily change the stereo pointer mode from roaming to fixed by pressing F8.

    This allows you to navigate the map without panning the mouse.

  10. To return to roaming mode, press F8 again.
  11. Use the map navigation tools to zoom in and pan around until you focus on the object of interest, such as the rooftop of a building. Press and hold the Ctrl key and rotate the mouse wheel to zoom.
  12. If necessary, adjust the x-parallax by pressing and holding Ctrl+Left Arrow or Ctrl+Right Arrow until the objects look clear.

Your stereo environment is now set up with a stereo pair. You can now start your 3D editing workflow.

Edit features in a stereo map

Now that your stereo model is set up, you are ready to collect 3D features in stereo mode.

  1. Add any feature classes you want to edit. You can add existing feature classes using the Add Data button Add Data, or you can create a new feature class.
  2. Optionally open the Magnifier Magnifier and Overview Overview windows to help you navigate around the stereo model.
  3. Click the Edit tab to view all the editing tools.
  4. Turn on Snapping List By Snapping. The XY tolerance, in the Snapping Settings, controls the snapping tolerance for 3D feature collection.
  5. Hover over a building roof corner and rotate the mouse wheel to adjust the z-coordinate, also called the floating mark. To increase the z-value, rotate the wheel backward. To decrease the z-value, rotate the wheel forward. You will have the correct z height when your two stereo cursors are positioned over the same location in the left and right images. It may be easier to set the building roof height without using your stereo viewing glasses until you are familiar with operating the floating mark to achieve the proper height.
  6. Click the Create Features tool Create Features to open the Create Feature pane.

    For more information about editing, see A quick tour of editing.

  7. In the list, click the feature class where you want to save the edits.
  8. Click the Polygon tool Polygon, and create the necessary vertices on the display by controlling the floating mark. To finish the feature, right-click and click Finish Finish, or press the F2 key.
  9. Repeat steps 5 through 8 for each building roof you are creating.
  10. Once you finish collecting your features, click the Save Edits button Save Edits.

You have completed creating 3D features. To see your 3D buildings, view them in a scene with feature extrusion.

View your 3D buildings in a scene

Once you have created features that have a height value, you can view the building in a scene.

  1. Click the Insert tab.
  2. Click the New Map New Map drop-down arrow and click New Scene New Scene.

    A new scene opens where you can view your 3D data.

  3. Add your building feature class you just created.
  4. Add any additional data, such as the stereo mosaic dataset.
  5. In the Contents pane, click the buildings layer.
  6. Click the Appearance tab.
  7. Under Feature Extrusion Type, click Absolute Height.

Your 3D building rooves are now drawn in 3D.

Related topics