Skip To Content

ALTIBASE database requirements for ArcGIS Pro 2.2

Visit Esri Support for general support information on Esri's Supported Environment Policy.

Supported database versions

ALTIBASE 6.1.1.4.2

ALTIBASE 6.3.1.2.1

ALTIBASE 6.5.1.0.1

Database requirements/limitations

  • Required service packs/patches: Patch 6.3.1.1.4 has a fix for an ALTIBASE bug on "GRANT SELECT ON <sequence> TO PUBLIC" (BUG-38451)
  • Geodatabase functionality is not supported with ALTIBASE

Software required to connect to a DBMS

Your client machine (for example, the one running ArcMap) will need to have the appropriate client files installed for the RDBMS you are using. These client files are available from their respective RDBMS vendors, but some are also available on My Esri as a convenience. RDBMS client files available from My Esri are IBM Db2 and Microsoft SQL Server. Client files for ALTIBASE, Dameng, IBM Informix, IBM Netezza, Oracle, SAP HANA, and Teradata are not available on My Esri and must be obtained from the RDBMS vendors. See Database clients for more information.