Skip To Content

PostgreSQL database requirements for ArcGIS Pro 2.1

Visit Esri Support for general support information on Esri's Supported Environment Policy, as well as information on earlier versions.

Minimum supported database versions

The following versions of PostgreSQL and PostGIS are supported with ArcGIS. The specific versions listed are the minimum minor version supported and certified for each supported major release of PostgreSQL. Newer minor versions are supported, but are not certified.

  • PostgreSQL 9.6.3 (64 bit)
    • PostGIS 2.3
  • PostgreSQL 9.5.3 (64 bit)
    • PostGIS 2.2
  • PostgreSQL 9.4.8 (64 bit)
    • PostGIS 2.2

Supported operating systems

If you are using a geodatabase in PostgreSQL or are using the ST_Geometry type in a PostgreSQL database, the following operating systems have been tested and are the minimum supported version. Future updates or service packs on these operating system versions are supported and assumed to work unless otherwise stated.

For PostgreSQL on Windows, you'll need the latest Visual Studio VC++ 2017 installed on the PostgreSQL instance machine. See https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads for more information.

Windows

Supported operating systemsLatest update or service pack tested

Windows Server 2016 Standard and Datacenter

Windows Server 2012 R2 Standard and Datacenter

Update: Nov 2017

Windows Server 2012 Standard and Datacenter

Update: Nov 2017

Windows Server 2008 R2 Standard, Enterprise, and Datacenter

SP1

Note:

Windows 10, 8.1, and 7 are supported for basic testing and application development use only. They are not recommended for deployment in a production environment.

Linux

The following Linux operating systems have been tested:

Supported operating systemsLatest update or service pack tested

Red Hat Enterprise Linux Server 7

Update 4

Red Hat Enterprise Linux Server 6

Update 9

SUSE Linux Enterprise Server 12

Service Pack 2

SUSE Linux Enterprise Server 11

Service Pack 4

Ubuntu Server LTS

16.04.3

Future updates or service packs on these operating systems are supported unless otherwise stated. The operating system version and updates must also be supported by the operating system provider.

Database requirements/limitations

Use of the PostGIS geography type with ArcGIS requires PostgreSQL 9.6.3 and PostGIS 2.3.

Branch versioning is supported at PostgreSQL 9.5.3 and above.

Software required to connect to a DBMS

Most ArcGIS applications that can connect to a PostgreSQL database include the required PostgreSQL client libraries. These applications include: ArcGIS Server, ArcGIS Desktop, and ArcReader.

Esri tests and certifies specific major and minor releases of PostgreSQL installations that are available from PostgreSQL.org. For each PostgreSQL release Esri supports, available PostGIS modules are also tested and certified. No other modules extending PostgreSQL functionality are included in Esri certification.