Skip To Content

SQLite database requirements for ArcGIS Pro 2.2

Visit Esri Support for general support information on Esri's Supported Environment Policy.

Supported database versions

SQLite 3.14.1

SQLite 3.16.2

SQLite 3.19.3

SQLite 3.20.0

SQLite 3.22.0

Supported add-ons

GeoPackage 1.1 and 1.2

Spatialite 4.0

Database requirements/limitations

  • SQLite files must have a .sqlite extension to be recognized by ArcGIS.
  • GeoPackage files must have a .gpkg extension to be recognized by ArcGIS.
  • You cannot create a geodatabase in SQLite.
  • Feature services are not supported with SQLite.

Platform support

  • All platforms supported by ArcGIS Desktop
  • All platforms supported by Runtime
  • All platforms supported by ArcGIS Server