Skip To Content

An overview of fields

Tables form the foundation of geographic data and are the fundamental building blocks of any data model. Tables are a collection of information, such as a list of building owners, employees, or customer information. Layers in a map, such as city streets, buildings, or address points, are simply tables that include information about the geometry and location of those features.

Tabular information consists of rows and columns, all rows having the same columns. In ArcGIS, rows are known as records and columns are referred to as fields. Each field in a table can store a specific type of data, such as a number, date, or piece of text. So fields form the attribute information for any given layer in the map or stand-alone table.

The image below shows the attribute table for the Campus Buildings layer from the Campus Editing data model. Each row in the table represents a building on the Esri campus and all of the buildings share a set of common fields. In this example, each building has common fields for name, size, operating hours, and so on.

Attribute table for the Campus Buildings layer

The fields view

In ArcGIS Pro, you can view and manage the fields of a layer or table in the fields view. This allows you to model the attributes that are shared by a collection of features or objects in a table. Within the fields view you can edit the fields and their properties, delete fields, and create new ones.

  1. To open the fields view, highlight the layer whose fields you'd like to view in the Contents pane. This displays the Feature Layer tabs.
  2. Clicking the Data tab, you will find the Design group containing icons for Fields, Subtypes, and Domains. These are your tools for working with a data model.

    Fields, Subtypes, and Domains buttons on the Data tab

  3. Clicking the Fields button opens the fields view, displaying the layer's fields in a tabular arrangement.

Below you can see the fields view for the Building layer. The fields view lists the fields from that layer and has columns to display the properties of those fields.

Fields view for the Building layer of the Campus Editing data model

There are many data modeling workflows in the fields view for creating, deleting, and modifying fields.

Learn more about how to create, delete, and modify fields of a layer or table

Field properties for the layer

Each field, or column, in a table has properties that describe its contents and how the data in it should be displayed. You can view and, in some cases, edit the field properties in fields view. These settings in fields view are used to determine how attributes will be shown in ArcGIS Pro, including in the attribute table window, in the Pop-up window, and when editing in the Attributes pane.

Below are a list of properties that you can set for fields in the layer:

PropertyDescriptionHow to set

Visible

Show or hide a field

Check or uncheck the box next to the field. To turn all fields on or off, use the checkbox in the column header.

Read Only

Determine whether a field is editable

Check or uncheck the box next to the field. To turn all fields on or off, use the checkbox in the column header.

Field Alias

Set a descriptive name for the field

Click the field alias column for the field row and enter a field alias.

Highlight

Turn on highlighting for a field to accentuate the field when displayed.

Check or uncheck the box next to the field. To turn all fields on or off, use the checkbox in the column header.

Number Format

Set the display formatting for numeric field types

Click the ellipsis button to open the Number Format dialog box.

These settings also apply to fields that are appended in a join, although you are only able to edit the joined fields when they are accessed from the origin table.

Note:

Layer properties are only available when fields view is opened from the layer. If fields view was opened from the data source (from the Catalog pane), the layer properties will not be shown. If you have opened fields view from the layer, you can use the Current Layer drop-down in fields view to switch from layer properties view to the data source view. The data source view displays field properties that are at the feature class level, such as the alias for a field, or the field name.