Skip To Content

Mosaic layer

Mosaic datasets consist of three layers: boundary, footprint, and image. The footprint layer shows the extent of each item in the mosaic dataset as a distinct polygon. The footprint attribute table is the catalog of all the images in the mosaic dataset in addition to any associated overviews. In this table, you can sort your imagery based on any of the attributes, such as cloud cover, acquisition date, or any of the sensor characteristics. The boundary layer shows the extent of all the raster datasets in the mosaic dataset as a single polygon, which is multipart if your collection of imagery is not contiguous. The image layer controls the rendering of the mosaicked image similar to a raster layer. Display and rendering properties, such as stretch, band combination, resampling, and mosaic method, are modified on this layer.

Selecting layers from a collection of imagery

Selection group

On the Data tab, you have options for selecting the specific layers with which you want to work. If you have a collection of images over a city that comes from a variety of sensors taken at different times of the day on different dates, you can make a selection based on any of these characteristics, also known as querying by attribute. In the southwestern United States, much of the annual rainfall happens over a few weeks during the monsoon season. You may have created a mosaic dataset of Landsat imagery over New Mexico. In this collection, you have multiple scenes for each date that cover the entire state, and those images were collected on different dates. You may want to see images taken during a certain season, or you may want to look at scenes that have minimal cloud cover. These are the kinds of selections you can make using Select By Attributes Select By Attributes.

Definition Query

In addition to making a selection based on an attribute, you can make selections by drawing around the scenes in question. The Rectangle Select By Rectangle tool is good for imagery since you don't tend to work with scenes with irregular shapes. Once you have made the selection, you have a choice of how you want to display those scenes. You selected all of the Landsat scenes with minimal cloud cover from the months of July through August and you want to compare what the vegetation looks like for the rest of the year. After making the first selection, you can group the selected imagery and add it to the map. You can then switch the selection, which selects all of the images from January through June and September through December, and add this to the map as a different group.

Using the Raster Item Explorer

Once you have made a selection, you can use the Raster Item Explorer Explore Raster Items to navigate to items in a mosaic dataset or an image service, explore raster properties, and add individual rasters to the map or scene views. In the Raster Item Explorer, you can browse items using the left and right arrow buttons. Alternatively, you can use the drop-down list to browse to a specific item. By default, the drop-down list uses the OID field to display items. The display field can be changed by selecting Display field on the Options menu Menu. In the Raster Item Explorer, a preview window shows the current raster that you have selected in the drop-down list with any item-level processing applied. You can navigate this window using the standard ArcGIS Pro 2D navigation. Properties for individual rasters such as Raster Information, Band Metadata, Extent, Spatial Reference, and Statistics can be browsed to or searched for in this pane.

Add image to map

Add the displayed image to the current map view, a new map, or a new scene view.

Zoom to current item

Zoom to the current item in the map view.

Flash current item

Flash the current item in the map view.

Item Functions

Open the item in the Raster Function Editor.

Displaying overlapping imagery

Imagery Display Order group

MODIS is a systematic sensor because all of your imagery line up in aligned grids; however, with a resolution of 250 meters, those pixels may be too big for some remote sensing questions. Conversely, when working with higher-resolution imagery, the revisit cycle is not systematic, and you may get imagery that overlaps in some areas. Deciding how to resolve conflicts from overlapping imagery is a crucial component of working with collections of imagery. You can set up rules that apply to each layer as a whole, or you can apply rules to only the parts of the imagery that are overlapping. These rules are known as sort methods and can be seen on the Sort drop-down list.

Sorting with mosaic methods

Sort methods

Some of the sort methods are particularly suited for having your collection of imagery be just a collection of imagery. You don't need to do any analysis; you just need to have it in some kind of logical order. In this case, the North-West and None methods are good options. Whenever there is overlap, choosing the North-West method North-West resolves it by choosing the layer closest to the northwest corner of the boundary. The None method None orders the images in the same order as the attribute table.

Other sort methods are great for zooming in and panning around your collection of imagery. For example, when you choose the Closest To Center method Closest To Center, you will be looking at the images closest to the center of your screen. As you zoom in to a feature that you're interested in, the selection updates itself, so you look at the imagery closest to the feature. The Seamline method Seamline is another option that is great for moving around your imagery. When you put your collection of imagery together, there are a couple of options for identifying seamlines. They can be based on the footprints of the imagery or even the features within the imagery. However it is set up, when you choose this option, it generates the seamlines, ranks your images based on the distance to those seamlines, and chooses the closet imagery. The result is a smooth transition from one image to the next.

A great deal of high-resolution imagery is taken from a viewing angle that is not directly overhead. There are advantages to this in that it allows you to measure the heights of buildings based on their shadows, creating a more natural-looking image. You can see the sides of buildings rather than just the roofs. The drawback is that all of the angles are different, which can be disorienting as you pan from one image to another. Choose the Closest To Nadir method Closest To Nadir to select the imagery closest to being viewed from directly overhead. Assuming that all of your imagery is oblique, you end up with a less abrupt transition from one scene to the next if you have a lot of tall features, because the viewing angles will be fairly close together.

Use specific attributes via the By Attribute method By Attribute to select imagery with minimal cloud cover or taken near a certain time. You can then use the Lock Raster method Lock Raster to display only the images that you want. These methods have the same effect as using the selection tools of the same name.

If you have imagery over an area using multiple flight paths, you can use the Closest To Viewpoint method Closest To Viewpoint. These paths are stored in the metadata, and they allow you to view the imagery from a number of different angles, allowing you to see your imagery from all sides.

Resolving overlapping pixels

Resolve Overlap

After you've determined the method for ordering that you need, you can fine-tune your results. Using the Resolve Overlap button Resolve Overlap, you will find a set of mosaic operators. The First operator ensures that the images at the top of the list will be drawn first. Its counterpart is Last, which looks at that same list and picks from the bottom. If you've asked for Closest To Nadir Closest To Nadir, it ranks all of the layers based on their viewing angle and returns the layer with a value closest to 0 degrees.

You can also work on the pixel level. There are different averaging and statistical approaches that you can take. The Minimum and Maximum operators take the lowest and highest valued pixel, respectively, of all the overlapping layers. Using this option means that you have no guarantee of looking at the pixels of just one image in the overlapping area but rather a combination of potential layers.

Additionally, you have Blend and Mean, which average the values of the pixels in question. While Mean is the standard averaging technique, Blend works by giving more weight to pixels closer to neighboring images to produce a smoother image. Using either of these operators means that you may not be looking at pixel values from any of your layers.

Finally, you have the Sum operator, which adds the values of all the overlapping pixels. If you assume that most pixel values are relatively close to one another for each layer, this technique can be useful to visualize where you have the most layers.

Compressing your imagery


When you share imagery, the amount of data that you transmit matters. These collections can overwhelm the download capabilities of the people who are accessing your imagery. ArcGIS offers the following techniques for compressing your data:

  • None—You will not compress your data at all. The advantage is that there is no data loss and it represents the highest possible quality. The drawback is that you will be transmitting your data in the slowest possible form. If you know your users have a reliable network connection, speed may not be an issue.
  • JPEG—A compression ratio of 3:1 to 8:1, with little degradation of the image quality. When choosing the JPEG method, you can use the Quality setting to specify a value from 0 to 100. A value of 80 tends to retain image quality while providing approximately eight times the compression.
  • LZ77—A lossless compression method that is ideal for scanned maps, classified imagery, and discrete data.
  • LERC—Recommended for data with a large pixel depth, such as float, 32-bit, 16-bit, or 12-bit data. With this method, the quality value represents the maximum error value that is applicable per pixel (not an average for the image). This value is specified in the units of the mosaic dataset. For example, if the error is 10 centimeters and the mosaic dataset is in meters, enter 0.1. LERC compresses better (5 to 10 times) and faster (5 to 10 times) than LZ77 for float data and is better with integer data. With integer data and an error limit of 0.99 or less, LERC behaves as a lossless compression method.

Visualizing the layers associated with an image service

Processing Templates

Image services are essentially mosaic datasets that have been shared over the Internet. When someone creates an image service, they often build multiple layers from the source data. For example, someone might serve a collection of high-resolution imagery over a city. One of the layers associated with the collection may be a vegetation index, while another is a classification of the imagery. When you connect to a service, you have access to these layers as well. You can find them from the Processing Templates drop-down menu Processing Template. When you select one of the layers, it immediately renders on screen.

Exporting and downloading data

Export data

When working with mosaic datasets, you may eventually need to create a permanent output of your analysis. With the exception of geoprocessing tools, all of the analysis you do on a mosaic dataset or an image service happens in memory. The Export Data button Export Data opens the Copy Raster geoprocessing tool, which allows you to write to disk. If you do not want to download the source files from a mosaic dataset or image service, you can save the image that is displayed, or a part of it, using the Export Data option.

In addition to saving your data to disk, you can use the Download Rasters button Download Rasters. This will open a pane where you can download the source data from an image service and mosaic layers. This accesses the service and pulls the actual files onto your machine, rather than reading the compressed version.

The downloading capability is controlled by the administrator of the image service; therefore, not all image services allow you to download the source files. You can choose the desired source files using the attribute table or one of the selection tools. The source files may include raster datasets, LAS files, or LAS datasets. Once selected, any additional associated files will be included, such as metadata files or projection files. From the Select drop-down menu Select on the Data tab, you can draw your area of interest, make a selection based on an attribute, or select only the visible rasters. If you only want to download the source rasters, select Deselect Overviews from the Operations button Operations. These options are also available from the layer's context menu in the Contents pane. When your selection is ready, use the Download Rasters button Download Rasters to proceed.

  1. Type a path or click Browse Browse to specify a location on disk where the data will be downloaded, and check the items in the File List that you want to download. If the row is unchecked, the item will not be downloaded.
  2. Optionally, you can choose to clip the data based on the extent of the data frame or any of the layers in the Contents pane.
  3. Use the Convert Raster check box to set the parameters for how the output is saved, including the file format and compression method.
  4. Check Add output to map if you want to display what has been downloaded.

Related topics