Skip To Content

Manage processing templates

Processing templates are used to generate on-the-fly information layers. When you create a function chain, it's often built from a specific dataset; however, you can also use a raster variable in place of that dataset so it can be applied to similar datasets. When you use that variable, the function chain is now referred to as a processing template. Vegetation indices, elevation products (such as slope, aspect, and hillshade), and image classification results are just a few of the kinds of information layers you can derive using raster functions. You can add processing templates to a mosaic dataset enabling you to display your imagery as information layers. This is similar to publishing an image service with processing templates.

Adding an existing template to a mosaic dataset

  1. In the Catalog pane, locate the mosaic dataset to which you will add processing templates.
  2. Right-click the mosaic dataset and click Manage Processing Templates. This will open the Manage Processing Templates pane.
  3. To add an existing template to your mosaic dataset, click the Import button Import and browse to an existing processing template on disk, which has an .rft.xml extension.

Creating a new template

  1. In the Catalog pane, right-click the mosaic dataset and click Manage Processing Templates. This will open the Manage Processing Templates pane.
  2. To create a new template, click Create New Template from Options Menu. This will open the Processing Templates Editor. Create a new template and click Save to add it to your mosaic dataset.

Generate a thumbnail for a template

  1. Add the mosaic dataset to a Map.
  2. In the Map, zoom in to an area from which you would like to generate the thumbnail.
  3. In the Catalog pane, right-click the mosaic dataset and click Manage Processing Templates. This will open the Manage Processing Templates pane.
  4. In Options Menu, click Generate Thumbnails. This will generate thumbnails for all your templates, based on the current map extent.

Managing Templates

The Templates section contains all the templates associated with the mosaic dataset. This includes the Default Template, which will be at the top of the list. You can move templates up and down in this section by dragging them. This ordering will be the same in the Processing Templates gallery on the Data tab.

There are many more options that can be performed in the Manage Processing Templates pane:

  • Change the default processing template by selecting the Set As Default button Set as default on the desired template. If you don't want a default template to be applied, make None the default template.
  • Each template can be edited by selecting the Edit button Edit on the individual template. This will open the Function Editor. Edit the template and click Save when you are finished.
  • The properties of individual templates can be edited by selecting the Edit Properties button Edit Properties. This opens the Edit Properties dialog box.
  • Templates can be exported and saved to disk using the Export button Export.
  • Templates can be removed from the mosaic dataset using the Delete button Delete.
  • Thumbnails for individual templates can be generated using Generate Thumbnail From Map Extent Generate Thumbnail From Map Extent. This will generate a thumbnail based on the current map extent, with the template applied.
  • Thumbnails can be removed from each template in the Edit Properties dialog box, using the Delete button Delete.

Related topics