Skip To Content

Raster Item Explorer

The Raster Item Explorer can be used to filter items from a large collection of imagery in a mosaic dataset or an image service. It is used to explore the properties of individual items, add them to a map or scene, and view/edit the processing applied to an item.

The Raster Item Explorer button Explore Raster Items can be found on the Data tab, which is contextual to the mosaic layer and image service layers in the Contents pane. You can use the Raster Item Explorer by first selecting the entire layer or a subset of the layer in the Contents pane and then clicking Raster Item Explorer on the Data tab. If you already have a selection on the layer, the Raster Item Explorer pane opens on the Inspect tab so you can inspect your selected items. If no selection exists on the mosaic dataset or image service layer, the pane opens on the Select tab.

Raster Item Explorer pane listing the items contained in a mosaic dataset.

On the Select tab, you can filter the items in the mosaic or image service in multiple ways. The By Area of Interest drop-down menu allows you to filter only the visible items in the current map view, all the items in the current map view, all the items in the collection, or the selected items in the collection if you made a selection before invoking the Raster Item Explorer. You can further filter items using the By Attribute drop-down menu by selecting a field and a value or a range of values. Alternately, you can build a custom query based on multiple attributes by using the Custom option, which brings up the definition query builder. Once you have specified your query, click the Apply button to get a list of filtered items.

The list is displayed in the form of easy-to-read cards that contain metadata about the items displayed. The cards are sorted based on the field that is the displayed at the top of the card in bold. You can use the Sort By button Sort by ID to pick a different field to sort by. The Sort Order button Sort by Name can be used to pick ascending or descending order. If you change the map view extent after the pane has been opened, or you make a selection or update your selection, you can click the Refresh button Refresh to refresh results based on the new map view extent or selection.

The Configure Results button Configure Results can be used to edit the metadata shown in the cards. You can pick four fields to display in each card. You can also choose to show thumbnails.

You can use the buttons that appear when you hover over each card or the buttons that appear on the upper left of the list to work with one item or a list of items. These buttons and their function are described in the table below:

ButtonDescription
Configure parameters

View the properties of the selected items on the Inspect tab.

Select Primary Rasters

Set the selected items as a selection on the mosaic layer or image service layer.

Lock Mosaic or Image Service layer lock

Lock the mosaic layer or image service layer to the selected items.

Yellow unlocked

Unlock any locked items or reset the mosaic or image service layer back to its original settings. Note this button only exists on the toolbar above the list of items.

Add image to map

Add the selected items to the current map, a new map, or a new scene.

On the Inspect tab, you can view one or more items that are selected or filtered. To switch between items, use the left and right arrow buttons. Alternatively, you can use the drop-down list to browse to a specific item. By default, the drop-down list uses the OID field to display items. The display field can be changed by clicking Display on the options menu Menu. The preview window shows you a preview of the current item that you have selected in the drop-down list with any item-level processing applied.

Raster Item Explorer pane listing details associated with a specific item in the mosaic dataset or image service.

You can navigate this window using the standard ArcGIS Pro 2D navigation. Properties for individual rasters such as Raster Information, Band Metadata, Extent, Spatial Reference, and Statistics can be browsed to or searched for on the bottom half of the tab. You can also view the processing applied to an item by clicking the Raster Function Editor button and change the processing in the editor if using a mosaic dataset. The buttons below the preview window are as follows:

ButtonDescription
Add image to map

Add the displayed image to the current map, a new map, or a new scene.

Zoom to current item

Zoom to the current item in the map view.

Flash current item

Flash the current item in the map view.

Edit Chain

Open the item in the Raster Function Editor.