Skip To Content

The LAS dataset layer in ArcGIS Pro

The LAS dataset layer is available in ArcGIS Pro in either a 2D or 3D view. The LAS dataset stores references to one or more LAS files on disk, as well as to additional surface features. Optimized LAS (.ZLAS) are also supported by the LAS dataset. The LAS dataset allows you to examine this data in its native format quickly and easily, providing detailed statistics and area coverage of the lidar data contained in the LAS files. You can quickly change the view of the LAS dataset into a TIN-based surface model. Also, the LAS dataset allows you to work with points classified into different feature types. You can add and use a LAS dataset that was created in previous versions of ArcGIS Desktop in ArcGIS Pro.

ArcGIS Pro is context driven, which means that the options you are presented with are dependent on the type of data you have selected in the Contents pane. When you select a LAS dataset in the Contents pane, you will see a contextual tab set containing Appearance, Data and Classification tabs. The functionality presented on these tabs will contain options only relevant to the LAS dataset layer. When multiple LAS datasets are selected, a limited set of functionality will be available. Display and analysis functionality can only be conducted on one LAS dataset layer at a time in ArcGIS Pro.

From the Appearance tab you will have access to the basic functionality you need to alter the display and LAS filter options of the LAS dataset. For more information about this tab, see Change the symbology of an LAS dataset, Change filter options for a LAS dataset, and Point thinning and scalability of an LAS dataset.

Use the Data tab to complete many of the data management and analysis tasks associated with working with LAS datasets. To learn more about the functionality available from the Data tab, see Edit the data contributing to a LAS dataset.

Use the Classification tab to edit the classification codes associated with a LAS dataset. To learn more about the functionality available from the Classification tab, see Edit LAS file classification codes.

The ability to produce statistical information for LAS files referenced by the LAS dataset is essential to better understand the lidar data you are working with. When statistics are calculated, a LAS auxiliary file (.lasx) is created for each LAS file. It stores the calculated statistical information and the spatial index for each LAS file. See LAS dataset statistics for more information on understanding LAS dataset statistics in ArcGIS Pro.

Individual LAS or ZLAS files can be used in ArcGIS Pro with the same support as a LAS dataset layer.

LAS dataset layer

Adding a LAS dataset to the map view

When you open a new project in ArcGIS Pro, you will need to load a new map. From the Insert tab, click New Map. There are a few ways to add a LAS dataset to the new map view. You can either connect to a folder or use the Add Data button.

Folder connection

To connect to a folder where the LAS dataset resides, click Add Folder on the Insert tab. The Add Folder Connection dialog box appears, allowing you to browse to the folder you want to connect to. Click the folder and click OK. Next, click the View tab and click the Catalog button to open the Catalog pane. To load the LAS dataset onto a map, browse to your folder in the Catalog pane, and drag and drop it into the map.

Add Data button

On the Map tab, click the Add Data button. On the Add Data dialog box, browse to the LAS dataset and click Open. The LAS dataset opens in the map view.