Skip To Content

A quick tour of editing

Editing is performed with tools that appear on the ribbon, on the editing toolbar, and in panes. Commands on the context menu appear for specific tools and enable them to perform a variety of related edits.

The following sections are a quick tour of the editing user interfaces. For detailed steps to use a specific tool, browse the table of contents or search the help using a keyword or phrase.

Edit tab

On the Edit tab, named groups contain related tools and commands that are essential to starting and completing common editing workflows. Some groups contain a dialog box launcher button in the lower right corner that opens a dialog box or task pane related to the group.

Edit tab

Tip:

You can right-click a button on the ribbon and add it to the Quick Access Toolbar.

Clipboard

In the Clipboard group, Cut Cut, Copy Copy, Paste Paste, and Paste Special copy features to the clipboard and paste them to the same layer or a different layer.

Manage Edits

In the Manage Edits group, you can toggle topological editing on or off, view editing permissions for layers in your workspace, and change project and application settings for editing.

Editing status

Status Editing Status reports editing permissions and source information for layers in your workspace.

Editing Status

Map topology

Map Topology Map Topology enables and disables topological editing for visible layers in the current map.

Topology settings

Editing Options

The Editing Options dialog box launcher Launcher provides access to project and application settings for editing.

Options dialog box

Snapping

In the Snapping group, you can set your snapping preferences. These controls are also available in a pop-up menu on the status bar at the bottom of the current map.

Snapping modes

Features

In the Features group, you can delete selected features in the current map or scene, and open editing task panes for creating or modifying features and managing feature templates.

Create Features

Create Features Create Features opens the task pane containing feature templates and related construction tools for layers in the current map.

Create Features

Modify Features

The Modify Features Modify Features pane includes two tabs. The My Tools tab contains the same customizable list of tools that displays in the Tools gallery on the ribbon. The All Tools tab contains all editing tools that are available in your project.

Modify Features

Manage Templates

The Manage Templates dialog box launcher Launcher opens the task pane containing all feature templates defined for the project. You can batch create templates, create and configure them individually, and delete them.

Manage Templates

Selection

In the Selection group, you can set the active selection method, run a selection tool, clear a selection, and open the Attributes pane. The selection tools in the Modify Feature pane also use the active selection method you set in this group.

Attributes

Attributes Attributes opens the task pane where you edit feature attributes and related records, modify annotation properties, and manage file attachments.

Attributes pane

Attachments

The Attachments tab and toolbar appear in the pane when you select a feature with file attachments enabled.

Attachments

Annotation

The Annotation tab and toolbar appear in the pane when you select an annotation feature.

Annotation

Tools

The Tools group hosts the tools gallery. You can add and remove editing tools in this gallery from the full collection in the Modify Features pane.

Tools gallery

Elevation

The Elevation group contains tools for specifying z-values when you create z-enabled or multipatch features, and provides access to elevation surface settings for the current map or scene.

Elevation group

Editing toolbars and context menus

Editing toolbars and context menus appear when you run a particular tool, and they contain additional tools and commands for completing the workflow. To cancel or close a context menu, click anywhere in a map or a scene away from selectable features, or press the Esc key.

General editing context menu

A context menu containing general editing tools appears when you select a feature and right-click the current map or scene. If you do not select a feature, tools that require a selection are disabled. Multipatch and 3D tools appear on the menu when a map or scene contain z-enabled features.

Context menu

Reposition toolbar

The reposition toolbar appears when you run a tool that moves, scales, or rotates features. If you right-click the map while the toolbar is active, the toolbar changes to a mini toolbar and appears above a context menu containing general editing tools.

Reposition toolbar

Construction toolbar

The construction toolbar appears when you create polyline or polygon features using a feature template, or modify a feature with tools that create linear geometry such as Reshape Reshape. These tools create straight and curved line segments.

Construction toolbar

Construction context menu

If you right-click the map while the toolbar is active, the toolbar changes to a mini toolbar and appears above a context menu containing commands for creating and constraining new geometry.

Context menu
Note:

When you create point features, only Absolute XYZ Absolute XYZ is available.

Vertices toolbar

The vertices toolbar appears when you edit a polyline or a polygon feature using Vertices Edit Vertices. The tools can perform the same operation multiple times, such as clicking and deleting several vertices along a segment.

Vertices toolbar

Vertices context menu

If you right-click a vertex while the toolbar is active, the toolbar closes and a context menu appears on the map containing commands for editing vertices. When you close or exit the menu, the vertices toolbar appears.

Vertices context menu

Segments context menu

If you right-click a segment while the toolbar is active, the toolbar closes and a context menu appears on the map containing commands for editing segments. When you close or exit the menu, the vertices toolbar appears.

Context menu

Contents pane

In the Contents pane, you can write-protect a layer and toggle snapping on and off by layer.

List By Editing

The check boxes on the List By Editing tab Editing enable editing for a layer. These settings apply to the current map and do not change permissions granted at the data source.

List By Editing

List By Snapping

The check boxes on the List By Snapping tab List By Snapping enable snapping for a layer.

Contents Snapping