Skip To Content

Configure a group template

In the Template Properties dialog box, you can configure a group template's name, searchable tags, tools that appear on the tool palette, the primary template, and component templates and their builders. Symbology is a property of the feature layer.

The primary template and toolset you enable define what you create in a map. When the primary template creates point features, the line and radial toolsets create temporary construction lines. Feature attributes are defined by the individual component feature templates.

One or more feature templates can be created for the same layers and configured with different tools and attribute values. Group templates are not automatically created when you add new data to an active map or scene.

For steps to create a group template, see Create a group template.

Open template properties

You can open the Template Properties dialog box Properties in the Manage Templates or the Create Features pane.

Manage Templates

The Manage Templates pane displays all templates defined for the project.

  1. On the Edit tab in the Features group, click the Manage Templates dialog box launcher Launcher.

    The Manage Templates pane appears.

  2. In the pane, expand the map Map View and its layers.
  3. Click the layer for the template you want to configure.

    Feature templates defined for the layer appear in the template box.

  4. In the template box, click the group template.
  5. On the toolbar, click Properties Properties.
    • You can also right-click the template and use the context menu.

Create Features

The Create Features pane displays all templates defined for the current map.

  1. On the Edit tab, in the Features group, click Create Create Features.

    The Create Features pane appears.

  2. In the pane, right-click a group template and click Properties Properties.
    • You can also click the forward arrow Forward and click the menu button Menu.

Configure the tool palette

Click the Tools tab to specify a toolset, set a default tool, and enable the construction tools you want available in the tool palette.

  1. In the Template Properties dialog box, click Tools.
  2. In the pane, click the toolset drop-down arrow and choose a set of tools.
    • Point tools are available only with primary templates that create point features.
    • Polygon tools are available only with primary templates that create polygon features.
    • Line tools and Radial tools are available with primary templates that create point and polyline features.

      When the primary template creates point features, these tools create temporary construction lines. Construction lines are automatically removed from the map after builders use them to locate the component features.

  3. Click and enable Click to set as default tool for the tool you want to run automatically when the template is selected.
  4. Check the Toggle tool visibility check box for construction tools you want available in the tool palette.

Add templates and builders

Click the Builders tab to add component feature templates and configure their builders. The builders available to a component feature template is determined by the feature type it creates and the primary features or temporary construction lines you create in a map.

Primary templates that create polyline or polygon features allow you to assign a builder. Builders for a primary template are limited in scope and operate independently of the component feature templates and builders you add to the group.

To learn more about builders, see Feature builder reference.

  1. In the Template Properties dialog box, click Builders.
  2. To delete, or change a template, do one of the following respectively:
    • Hover over the template name and click Delete Delete.
    • Hover over the template name, click Edit Editable, choose another template, and click Apply.
  3. To add a component template, click Add Add, click the drop-down arrow, and choose a template.

    Parameter settings for the active builder appear in the pane. All builders available for the template appear in the builder drop-down list.

  4. Click the Choose a builder drop-down arrow and choose a builder.
    • If the active builder includes parameters, specify how you want the features created.
  5. Click Add.

    The feature template appears as component of the group template.

  6. Click OK.

    Your settings are saved and the dialog box closes.