Skip To Content

Configure a multipatch feature template

In the Template Properties dialog box, you can configure a multipatch template's name, searchable tags, tools that appear on the tool palette, the feature gallery, predefined shapes, and the attribute values that are applied to new features. Symbology is a property of the feature layer.

Adding a model file from your file system to the feature gallery imports the model to the project as a multipatch feature. A thumbnail image of the model automatically appears as a gallery item in the pane. You can import COLLADA (.dae), 3D Studio (.3ds), and other supported formats.

One or more feature templates can be created for the same layer and configured with different tools and attribute values. When you add new data to an active map or scene, a feature template is automatically created for each new layer with default settings.

For steps to create a feature template manually, see Create a feature template.

Open template properties

You can open the Template Properties dialog box Properties in the Manage Templates or the Create Features pane.

Manage Templates

The Manage Templates pane displays all templates defined for the project.

  1. On the Edit tab in the Features group, click the Manage Templates dialog box launcher Launcher.

    The Manage Templates pane appears.

  2. In the pane, expand the map Map View and its layers.
  3. Click the layer for the template you want to configure.

    Feature templates defined for the layer appear in the template box.

  4. In the template box, click the group template.
  5. On the toolbar, click Properties Properties.
    • You can also right-click the template and use the context menu.

Create Features

The Create Features pane displays all templates defined for the current map.

  1. On the Edit tab, in the Features group, click Create Create Features.

    The Create Features pane appears.

  2. In the pane, right-click a group template and click Properties Properties.
    • You can also click the forward arrow Forward and click the menu button Menu.

Configure the tool palette

Click the Tools tab to set a default tool and enable the construction tools you want available in the tool palette.

  1. In the Template Properties dialog box, click Tools.
  2. Click and enable Click to set as default tool for the tool you want to run automatically when the template is selected.
  3. Check the Toggle tool visibility check box and enable the construction tools you want available in the tool palette.
  4. Click OK.

    Your settings are saved and the dialog box closes.

Customize the gallery

Click the Tools tab to customize the gallery. You can add, remove and set the size and orientation for models in the gallery.

  1. In the Template Properties dialog box, click Tools.
  2. Click Model File Multipatch.

    The gallery appears in the pane.

  3. To add a model, click Add Add, browse to the file, and click Open. You can select and add more than one file at a time.

    The model is imported to the project and a thumbnail appears as a gallery item in the pane.

  4. To set the default size and orientation of the model, click its thumbnail, scroll the tool parameters, and expand and set one or more of the following settings:
    • Size—The feature height (Z), width (X), and depth (Y).

      Click the vertical bracket control to link or unlink the dimensions. Linking dimensions scales the model proportionally.

    • Rotation—The feature angle, tilt, and roll in 3D space.
    • Position—The insertion point of the feature along its x-, y-, and z-axis.
  5. To remove a model from the gallery, click the thumbnail and click Delete Delete Selected Item(s).
  6. Click OK.

    Your settings are saved and the dialog box closes.

Customize predefined shapes

Click the Tools tab to set the size and orientation for a predefined multipatch shape.

  1. In the Template Properties dialog box, click Tools.
  2. Click a predefined shape, scroll the tool parameters, and expand and set one or more of the following settings:
    • Size—The feature height (Z), width (X), and depth (Y).

      Click the vertical bracket control to link or unlink the dimensions. Linking dimensions scales the model proportionally.

    • Rotation—The feature angle, tilt, and roll in 3D space.
    • Position—The insertion point of the feature along its x-, y-, and z-axis.
  3. Click OK.

    Your settings are saved and the dialog box closes.

Set attribute values

Click the Features tab to set the attributes values you want applied to the features you create with the template.

  1. In the Template Properties dialog box, click Features.
  2. In the feature attribute table, type the attribute values you want applied to new features.

    The color of the row indicates how the field is being used in the map.

    Field colorDescription

    Orange

    Subtype field

    Purple

    Symbolizes the layer

    Yellow

    The Highlight property is enabled in the attribute table

    Attribute field color codes

  3. Click OK.

    Your settings are saved and the dialog box closes.