Skip To Content

Configure a scene for 3D editing

Scenes allow you to tilt your 2D map and edit data in three dimensions using a vertical axis. You can open maps and scenes at the same time and link them to display synchronously at the same center and scale of your extents as you pan and zoom in the active view. You can also share your scene on the web for visualization and analysis purposes.

To learn more about authoring and sharing a scene on the web, see Author a web scene.

When you configure a scene, you can choose a local or a global viewing mode and switch the scene at any time depending on the type of display or analysis your workflow requires. The best practice is to use a local scene with a projected coordinate system when you need to minimize distortion for distance, direction, scale or area measurements.

The following table shows the basic operational differences between local and global scenes:

Local scene 3D Scene ViewGlobal scene 3D Global View

Display your 3D content using a local perspective and scale with a geographic coordinate system (GCS) or a projected coordinate system (PCS).

Display your 3D content using a global perspective and scale with a geographic coordinate system (GCS)

Change the clipping extent of your data

You cannot change the clipping extent of your data

Perform below surface analysis

Not intended for below surface analysis

Configure basic illumination settings and visual effects

Configure enhanced illumination settings and visual effects

3D scene viewing modes

For steps to create multipatch features from scratch, see Create multipatch features.

Convert a map to a scene

To convert the current 2D map to a 3D scene, on the View tab, click Convert Convert. A global scene appears containing the data in the map and the map remains unchanged.

Note:

To open an existing scene, right-click the scene in the Catalog pane, and click Open Global View 3D Global View or Open Local View 3D Scene View.

  1. Open the map you want to convert to a scene.
  2. On the View tab, in the View group, click Convert Convert.
    • To convert a map in the Catalog pane, right-click the map and click Convert To Scene Convert.

    A global scene view appears.

  3. To change the view mode to local, on the View tab, in the View group, click Local 3D Scene View.

    A local scene view appears.

Link the map and scene

To link your new scene to the map, on the View tab, click Link Views and select Link Center Link Center or Link Center and Scale Link Center and Scale.

  1. On the scene view tab at the top of the scene, right-click and click Float.

    The scene undocks and floats over the map, allowing you to see both the map and scene views.

  2. On the View tab, in the Link group, click the Link Views drop-down arrow and choose one of the following:
    • Link Center Link Center.
    • Link Center and Scale Link Center and Scale.
  3. Using the pointer, pan and zoom in the scene.

    All map and scene views update synchronously and display the same center of your extents.

Add an elevation surface

To add an additional elevation surface to your scene, on the Edit tab, click the Map Properties dialog box launcher Launcher and click Elevation Surface.

To learn more about elevation surfaces, see Elevation surfaces .

  1. On the Edit tab, in the Elevation group, click the Map Properties dialog box launcher Launcher.

    The Map Properties dialog box appears.

  2. On the dialog box, on the Elevation Surface tab, click Add New Surface.

    A new elevation surface entry with a temporary name such as Surface 1 appears.

  3. Click the temporary name and rename it to something meaningful to you and your organization.
  4. Expand Elevation sources and click Add Elevation Source.

    The Add elevation source dialog box appears.

  5. On the dialog box, browse to the image service, raster file, or TIN dataset and click OK.
  6. Click OK.
    Tip:

    If your scene is missing the default ground elevation surface, click All Portal All Portal, type terrain3D in the search box, and press Enter.

    The elevation surface is added to the scene, and the dialog box closes.

Add a vertical coordinate system

To add a vertical coordinate system to your scene, on the Edit tab, click the Map Properties dialog box launcher Launcher and click Coordinate Systems.

To learn more about vertical systems, see Vertical coordinate systems .

  1. On the Edit tab, in the Elevation group, click the Map Properties dialog box launcher Launcher.

    The Map Properties dialog box appears.

  2. On the dialog box, on the Coordinate Systems tab, click the Current Z coordinate system box.

    A list of the available Z coordinate systems appear in a list.

  3. Expand Vertical coordinate system and choose a coordinate system.
  4. Click OK.

    The vertical coordinate system is added to the scene, and the dialog box closes.

Manage 2D and 3D group layers

In the Contents pane, scenes organize data into 2D and 3D group layers. Group layers determine whether you can drape features onto an elevation surface, display them at a specific height in relation to an elevation surface, extrude them, or apply 3D symbols.

You can drag a layer from one group to the other group at any time and change how they are displayed in 3D space. In addition to the default ground elevation surface, you can add as many elevation surfaces to a scene as your data requires, such as for a water table or a geologic layer.

When you extrude point, line, or polygon features on a 2D layer they are moved to the 3D group layer. You can also control whether features are rendered in front of features, or behind other features occupying the same 3D space by changing the depth priority setting for the layer.

2D and 3D group layers can be configured to display features in the following ways:

2D layers3D layers

On the ground elevation surface

Relative to the ground or a custom elevation surface

On a custom elevation surface

On a custom elevation surface

At an absolute height

At an offset from an elevation surface

2D and 3D layer height options

For steps to set the layer depth priority, see Set depth priority for a 3D layer.

Define how z-values are obtained

To define how z-values are obtained, in the Contents pane, right-click the layer, and click Properties Properties. Click Elevation, and click the Features are drop-down arrow.

To learn more about base heights, see Define height characteristics for layers .

  1. In the Contents pane, right-click the layer, and click Properties Properties.
  2. On the Elevation tab, click the Features are arrow and select one of the following:
    • On the ground Elevation Ground—Z-values are obtained from the ground elevation surface. Examples include any features that are placed on the ground such as light poles, trees, and cars.
    • Relative to the ground Elevation Relative To Ground—Z-values can be obtained from the feature geometry, an attribute field, or an expression. The height of features are displayed in relation to the ground elevation surface. Examples include features that are placed at a known height above or below the ground such as security cameras, well base points, or subway stations.
    • At an absolute height Elevation Absolute Height—Z-values can be obtained from the feature geometry, an attribute field, or an expression. You can also specify a vertical exaggeration value to visually distinguish the features from other features in your scene. Examples include features that are placed at a specific height regardless of the ground elevation surface such as airplanes, earthquake epicenters, or satellites.
    • On custom elevation surface Elevation On Custom—Z-values are obtained from a custom elevation surface. Examples include features that are placed on an elevation surface other than the ground such as well site intersections on a subsurface geologic plane, site pollution levels, or ozone readings.
    • Relative to custom elevation surface Elevation Relative Custom—Z-values can be obtained from the feature geometry, an attribute field, or an expression. The height of features are displayed in relation to the custom elevation surface.
  3. Click OK.

    Your settings are saved and the dialog box closes.