Skip To Content

Create a preset template

In the Manage Templates pane, Preset Template from selected features New Preset Template creates a preset template for the features you select in a map. A component template for each layer is automatically generated and a snapshot of the selected features is saved with the template.

The snapshot appears near the pointer as a preview when using the template to create new features. The features are added to a map using point construction tools in the same configuration as you selected them when you created the template.

For steps to configure the tool palette, or set attribute values, see Configure a preset template.

New preset template

To create a preset template, select the features in the map, click New New Template, and click Preset Template from selected features New Preset Template.

  1. Open the Manage Templates pane using one of the following methods:
    • On the Edit tab, in the Features group, click the Manage Templates dialog box launcher Launcher.
    • In the Create Features pane, click Manage Templates Manage Templates.

    The Manage Template pane appears.

  2. Expand the map icon Map View for the active map and click any template. This enables the tool on the toolbar.
    • If no templates exist, click the New arrow New Template, click Template New Template, and create and configure a template.
  3. On the Edit tab, in the Selection group, click Select Select.
  4. Select the features in the same configuration you want the template to create them.

    For example, to create a preset template for a utility network overhead single phase fuse tap, select the arrester, fuse, and fuse bank in the orientation that most of your use cases require.

    Note:

    To change the features or their orientation after the template is created, delete and recreate the template.

    When you create new features using a preset template, each new instance in a map is the current selection set until you create new features or press the Esc key. This allows you to move or reposition the features after you add them.

  5. In the pane, on the toolbar, click the New drop-down arrow New Template and click Preset Template from selected features New Preset Template.

    The Template Properties dialog box appears.

  6. Click General.
  7. In the Name text box, type a name.

    The OK button is enabled.

  8. In the Description text box, you can document the template with an optional description that you and your organization can search and find in the pane.
  9. In the Tags text box, keywords for Preset and Group are automatically generated. They appear as filters on the Filter drop-down menu Filter. You can delete them or add additional tags.
    • To add a tag, type the keyword and press Enter.
    • To delete a tag, click X.
  10. Click OK.

    The template is saved and the dialog box closes.


In this topic
  1. New preset template