Skip To Content

Edit a utility network

A utility network is a map of interconnected physical assets, such as valves or circuits, and a commodity that flows through them, such as water, natural gas, or electricity. It uses network topology, connectivity rules, and association rules to maintain data integrity.

For example, when you edit an electrical network, moving a pole can also move a transformer attached to it. Creating a duct bank with a preset template can also create its internal components that conform to network rules and associations defined for the network.

After you create and validate a network, you can analyze the network using the trace tool and identify the connected and associated features. The result is a selection set that you can propagate to other map views or network diagram views.

The following sections introduce a basic workflow you can use to get started editing a utility network. For detailed steps to use a specific tool, browse the table of contents or search the help using a keyword or phrase.

For a summary of how editing tools work, see Utility Network reference for editing.

Open the project

Open the project containing the map and feature service or add the feature service to a new map. A utility network can only be edited in a map with a published feature service registered as branch versioned.

Tip:

To download a project package from an online portal, type the URL in your web browser, for example, https://utilitynetwork.myorganization.com/portal/home/.

To learn more about portal connections, see Manage portal connections from ArcGIS Pro.

  1. Start ArcGIS Pro and sign in if necessary.
  2. On the start page, do one of the following:
    • Open the project Catalog View.
    • Click Browse Browse and browse to the project.
    • Create a new project using a project template Project Template.
    Note:

    When you open a project on a Portal All Portal connection, the project package (.ppkx) is downloaded and unpacked in the <User Documents>\ArcGIS\OnlineProjects folder. After you close the project, the unpacked project file (.aprx) appears in the recent projects list.

  3. On the View tab, in the Windows group, click the Catalog drop-down arrow, and click Catalog Pane Catalog Pane.

    The Catalog pane appears.

    Catalog pane

  4. Right-click the map and click Open.
    Note:

    Depending on how the service is shared, it appears on the Project or the Portal tab.

Create a new branch version

When you create a branch version, specify its name, an optional description, and the level of access you want to grant other editors. As the owner of the version, you can change these properties or delete the version at any time.

  1. On the View tab, in the Windows group, click Contents Contents.

    The Contents pane appears.

    Contents pane

  2. Click the List by Data Source tab List By Data Source.
  3. Click the feature service, for example, SDE.DEFAULT (NapervilleElectric_Oracle).

    The Data Source contextual tab appears on the ribbon.

  4. On the Versioning tab, in the Versioning group, click New Version New Version.

    The New Version dialog box appears.

    New Version

  5. Type the following information:
    • Name—The name of the version you are creating.
    • Description—A brief statement that explains the purpose of the new version.
  6. In the Access Permission section, click one of the following:
    • Private—Allows only the owner or the geodatabase administrator to view or modify the version.
    • Protected—Allows anyone to view the version, but only the owner or the geodatabase administrator can edit the version.
    • Public—Allows anyone to view or edit the version with read/write (update, insert, and delete) permissions.
  7. Check Change to this new version.
  8. Click OK.

Locate the area

When you edit a large dataset, you can use a locator to zoom to the address or street where you need to create new assets or modify the network. Locators are automatically added to your project from your portal connection. You don't need a specific locator to find x,y locations.

  1. On the Map tab, in the Inquiry group, click Locate Locate.

    The Locate pane appears.

    Locate pane

  2. In the Locate pane, type the address or street intersection, for example, W Bauer Rd & N Eagle St, and press Enter.

    A list of address candidates appears in the pane.

  3. Double-click the address candidate, or do one of the following:
    • Right-click and click Zoom To Zoom To.
    • Right-click and click Pan To Pan To.

    The map zooms or pans to the address or street name.

Create a new network feature

When you create utility features, new features automatically conform to the rules and associations defined for the network.

  1. On the Edit tab, in the Snapping group, click Snapping List By Snapping, enable your snapping preferences, and move the pointer back to the map.

    Snapping settings automatically change to conform to junction and edge connectivity rules. You can turn snapping off, but you cannot change the layers to which they are snapping.

  2. On the Edit tab, in the Features group, click Create Create Features.

    The Create Features pane appears.

    Create Features pane

  3. Type a keyword in the search box to filter the list; for example, type overhead, and press Enter.

    Feature templates matching your search criteria appear in the pane.

  4. Click a feature template that creates network feature assets, for example, a preset template that creates a fuse bank assembly.
    Tip:

    Preset templates can create an assembly and its components with a single click, for example, a cluster of electrical devices in a fuse bank or in a cabinet. The associated features automatically conform to rules defined for the utility network.

    For steps to create a preset template, see Create a preset template.

  5. Create the network features using the active snap settings.
  6. On the editing toolbar, click Finish Finish or press the F2 key.

    A dirty topology area is created for the newly added feature.

Validate the network topology

Validating an enabled network topology updates the network to include your changes.

  1. On the Contents pane, click the List by Drawing Order tab List By Drawing Order.

    Contents pane

    Tip:

    To view the rules, associations, and other properties defined for a network, right-click the network layer and click Properties Properties.

    To learn more, see Utility network layer properties.

  2. Click the utility network layer, for example, Electric Utility Network.

    The Utility Network contextual tab appears on the ribbon.

    Utility Network Data tab
  3. On the Data tab, in the Network Topology group, click the Validate drop-down arrow, and click Current Extent Current extent.

    The network topology is validated and the dirty area disappears.

  4. On the Edit tab, in the Manage Edits group, click Save Save Edits.

    The Save Edits dialog box appears.

    Save Edits

  5. Click Yes.

Run a trace

Tracing a utility network analyzes the paths within a network that are defined by connected or associated features. You can configure a trace to identify features upstream, downstream, or along connected loops, or the shortest path between two points.

To learn more, see Trace utility networks.

Create a network diagram

A network diagram is a simplified unscaled view of selected network features and their connections showing junctions, edges, and containers. You can control their appearance by selecting one of several layouts including tree, schematic, or geographical representations.

To learn more, see About network diagrams.