Skip To Content

Navigation

When you view or author maps and scenes, you need to zoom in and out, move around, and in the case of scenes, move up and down, and even stay in one spot and look around. Use navigation tools, including the Explore tool, the on-screen navigator, and the Go to XY tool, to help you do all of these. Other navigation commands and methods that can improve how you author and interact with your maps and scenes include bookmarks, linked views, map scales (2D) and scene height (3D), and pause and refresh drawing modes. These methods impact the way you get around your data, compare your data and any active edits, or change the viewing perspective. They also improve the quality of performance and how you maneuver through your GIS display. For example, pause drawing allows you to focus on specific edits or explore existing data without being impacted by continuous redrawing when your project contains large amounts of data.

Each section below will help distinguish how and when to use each of the navigation tools, commands, and methods.

Explore tool

The default tool for maps and scenes is the Explore tool Explore Tool. Use it to orient your map or scene as well as identify features.

Explore tool mouse buttons

Use mouse buttons to identify feature attributes via a pop-up, pan, zoom in and out, and rotate or tilt your content if you're working in 3D. You can access other navigation methods, such as zooming to the full extent of your data or adjusting the view to point north, using commands or keyboard shortcuts.

On-screen navigator

The on-screen navigator exposes many camera navigation commands with a single control in the lower left corner of a view. The explicit camera controls are useful for navigating through challenging GIS content, particularly 3D scenes that are underground, in buildings, or that contain lidar. The control is suitable for touch screen interaction. Its ability to rotate around a target point makes it well suited for feature inspection and 3D editing. As a passive element in the view, the navigator always indicates north. The images below show the navigator in a minimized state for heading only, compared to the full control state for 2D and 3D views.

Navigator showing heading only
Full control navigator in 2D
Full control navigator in 3D

To display or hide the navigator in a view, on the View tab, in the Navigation group, click the Navigator button Navigator. The navigator can be resized by dragging the resize handle at the top right of the control.

In its smaller display mode for heading, the navigator shows a north indicator. You can pan around your map or scene by clicking and dragging on the outer ring. A partially transparent arrow indicates the pan direction and velocity. Click the north arrow to reset the camera to face north again.

In its maximized display mode, the navigator exposes additional camera navigation capabilities. In 2D, this includes rotating the view; zooming in and out; and turning to face east, west, or south. In 3D, this includes rotating the view direction (only), pivoting around the target point in all three axes, zooming in and out on the target point, moving the camera up and down, and looking around from the current camera position.

By default, the navigator is hidden in 2D views and shown in its heading state in 3D views. Click the Project tab and click the Options tab. On the Options dialog box, under the Application heading, click the Navigation tab. Expand the On Screen Navigator heading to configure these options.

Go to XY

Sometimes you're given an input location and need to be able to navigate directly to it. You can type x,y coordinates in the Go To XY tool and navigate right away. A list of supported units also lets you change the format that is returned in real time.

To display or hide the Go To XY tool, on the Map tab, in the Navigate group, click the Go to XY button Go To XY to display the overlay in the view.

Common navigation commands

On the Map tab, in the Navigate group, there are many commonly used navigation tools. Click the launcher button Launcher to change the default navigation behavior in maps and scenes.

Navigation commandDescription

Explore Explore Tool

A multifunctional tool for navigation and feature identification. This is the default tool when you open a new or existing project. Left, right, and wheel mouse buttons all have built-in capabilities as follows:

  • Left-click—Pop-up identification for a feature
  • Left drag—Pan
  • Middle roll wheel—Zoom in and out
  • Middle click and drag—Rotate and tilt (3D only)
  • Right hold—Continuous zoom
  • Right-click—Context menu for additional tools

Previous Extent Back

Move the view back to the previous extent if it exists.

Next Extent Forward

Move the view forward to the next extent if it exists.

Zoom To Selection Zoom to Selected

The view centers and zooms in on the extent of the selected set of features.

Full Extent Full Extent

The view zooms to the full extent of the data in the map.

Bookmarks Bookmarks

Create new bookmarks or use existing bookmarks to navigate to important locations. Optionally open the Bookmarks pane to manage existing bookmarks such as update or remove.

Other navigation methods

Navigation commands

In some scenarios, you want to change your map extent based on a previous action. For example, after selecting features, you may want to zoom to them to get a closer look. Commands on a context menu or button are not like the interactive experience you have when using the mouse.

To navigate the view using buttons and commands, do the following:

  • Zoom to the full extent of all your data—Press the Insert key, or on the Map tab, in the Navigate group, click Full Extent Full Extent.
  • Zoom to the extent of a layer—Press the Alt key and click a layer in the Contents pane to zoom to the layer's extent.
  • Zoom to the extent of multiple layers—Press the Ctrl key, select the layers in the Contents pane, right-click and click Zoom To Layer.
  • Zoom to selected features—Use the Select By Attributes or Select By Location geoprocessing tool and click the Selected Features results at the bottom of the view, or use the selected feature layer's context menu in the Contents pane.
  • Return to a previous location—Create a set of bookmarks for the view.
  • Right-click a search result in the Locate pane.

Tip:

The navigation positions you use are stored as extents that you can go backward and forward to through in a list. On the Map tab, in the Navigate group, click the Previous Extent button Previous Extent or the Next Extent button Next Extent to revisit these extents when you've stopped navigating. You can also navigate to the previous or next extent by right-clicking when the Explore tool Explore Tool is active. This list of extents is only maintained as long as a view is open. The positions are also cleared after the application is closed, even though a view is saved as open in a project.

Pause and refresh drawing

Maps and scenes have two important buttons at the lower right of the display to help with interactive performance—Pause Drawing and Refresh. When a map contains a large amount of data, it can take time to load the contents into memory and draw them. When a map is actively drawing data, the Refresh button Refresh begins to spin. Click Refresh to cancel the drawing; any features that are already drawn will remain, but no additional features will be added to the map.

Alternatively, the Pause Drawing button Pause Drawing can be used to temporarily stop the drawing of your maps and scenes. When this button is clicked, the word Paused appears across the top of the view and suspends loading any additional data until it is switched off. All navigation and editing functionality is still available during this time. This allows you to make changes to the map's content without causing a redraw of the map. If you turn off the visibility of a layer, or add a new layer to the map, it will not display until you exit the pause drawing state.

In layout views, the pause drawing state only applies to map frames. It does not affect other dynamic elements, such as north arrows or scale bars

Bookmarks

Bookmarks are a way to store important locations in your maps and scenes. Bookmarks can contain both spatial and temporal components and an optional description property. Using bookmarks, you can return to a location in both space and time.

On the Map tab, click the Bookmark menu to navigate using bookmarks. Click the Manage Bookmarks button Manage Bookmarks to manage all your bookmarks from the Bookmarks pane.

Linked views

When you want to coordinate the navigation experience of multiple maps and scenes at once, you can link the views. By default, each view operates individually, but you can link them so that one active view triggers matching navigation in other views. This is useful for displaying multiple datasets side by side without having to turn layers on and off. You can examine multiple perspectives, editing updates, and so on. Linking can be applied for views to match the center of the view only, or to match the center as well as any changes to rotation and scale.

Tools and commands specific to 2D or 3D views

Though there are many similarities between navigating in 2D and 3D environments, there are some important differences.

2D scale

When a map draws, you can display the map at any map scale. You can also set up a series of map scales that allow you to select a map scale from a list. Scales are selected and entered from the list at the bottom of the display.

  • The current scale and other scales you provide are maintained in a list for easy access.
  • You can manage scale values and formats using the Scale Properties dialog box to customize a personalized scale listing.
  • To change scales, choose a value from the expanded list to zoom to the scales specified.

Learn more about scales and scale management

3D height

Height values listed at the bottom of the display depict height aboveground. In a map, you set the desired map scale, but in a scene, you set the desired height aboveground. If you enter a value of 2 meters as a 3D height, the viewpoint adjusts to 2 meters aboveground whether you're in a mountain range or by the ocean. The value displayed in the 3D height box is based on the current resolution of the elevation being displayed. It becomes progressively more accurate the closer you get to the ground.

The 3D height control value is different than the distance-to-pointer z-value depicted in the coordinate system display, which is also at the bottom of your view. Z-values represent the elevation of the current pointer location in the view.

For example, in your study area, you want to view mountains from 100 feet aboveground. Type 100 in the height list. This takes the view to 100 feet aboveground. Now you can see the mountains and want to find out the elevation of one in particular. Place your pointer at the top of the mountain. Observe the z-value that appears at the bottom of the display, grouped with the coordinates. This gives you the mountain's elevation.

Note:
  • Z-values do not appear by default. On the Map tab, in the Navigate group, click the launcher button Launcher to open navigation options. On the Options dialog box, you can enable the view to show the distance to the pointer.
  • To add a new unit to the project location units, click the Project tab and click the Options tab. On the Options dialog box, click the Units tab and click Select Unit Code in the last table row from one of the categories. Choose from the list of units. Right-click a unit to remove, format, or make the unit the default.

3D-specific keyboard shortcuts

  • Orient orthogonally—Press the P key to orient the view to be orthogonal to the surface—like looking straight down. This can make navigation easier if you need to recover the view to a more common starting place.
  • Look around—Press the B key to make the camera stay in place while you use the mouse to look around the view.

Related topics