Skip To Content

Add maps and scenes to a project

You can create new maps in ArcGIS Pro or import them from other ArcGIS Desktop applications. You can also import ArcGIS Pro map and layout files that were created in another project and map packages. Maps can use data from local, enterprise, or online sources.

Create a new map or scene

There are several types of maps in ArcGIS Pro. These include maps for displaying two-dimensional data, scenes for displaying three-dimensional data, and maps for building custom basemaps.

  1. On the Insert tab, in the Project group, click the New Map drop-down menu.
  2. Click New Map New Map, New Scene New Scene View, or New Basemap New Basemap.
  3. The new map is opened and added to the project.
Tip:

New maps, scenes, and basemaps can also be created if you right-click in the empty space at the bottom of the Catalog pane.

Import a map or a map package

You can import existing documents created in ArcMap (.mxd), ArcGlobe (.3dd), or ArcScene (.sxd) to your project. Map packages and ArcGIS Pro map and layout files (.mapx and .pagx) can be imported as well. Packages and files from the active portal are downloaded first. The document, package, or map file is opened, and a copy of each map and layout are added to the project. Map packages are unpacked in the <User Documents>\ArcGIS\Packages folder.

Note:

Map and layout files (.mapx and .pagx) and map packages (.mpkx) created with any supported version of ArcGIS Pro 1.x can be added to any project. However, map and layout files created using ArcGIS Pro 2.x cannot be added to a project using ArcGIS Pro 1.x. When a map file created with ArcGIS Pro 2.2 is added to a project using version 2.0, the map will be added but will be downgraded in a manner appropriate for the previous version of ArcGIS Pro. A map package created using ArcGIS Pro 2.x contains both 1.x and 2.x versions of the map, so the package can be added to any project; the appropriate map for the version of ArcGIS Pro you are using will be added.

When you import an ArcMap map document, at least one map and one layout are added to the project. The format of the original data frames and layout is changed to the ArcGIS Pro map and layout formats before the items are added to the project. The data frame or layout that was active in the original document is opened in a view.

ArcGlobe and ArcScene documents are imported into ArcGIS Pro as scenes. By default, ArcGlobe documents open in global view mode, and ArcScene documents open in local view mode. You can switch between global and local modes on the View tab on the ribbon.

If the imported ArcMap map document included style references, the styles are not imported into the project. You must import the ArcMap styles separately if you want them to be referenced in the project.

  1. On the Insert tab, in the Project group, click Import Map Import Map.
  2. Browse to or search for the maps you want to import, in your project or online.
  3. Click one or more maps to add them to the project.
  4. Click OK.

    When importing completes, click the notifications button Notifications. The Notifications pane will have one notification for each imported map. Hover over a notification and click View Results to see a report that lists all errors and warnings encountered, and informational messages about the import process.

    All import notifications disappear when a project closes, and will not reappear in the Notifications pane when the project opens. However, these reports are saved in an ImportLogs folder in the project's home folder as XML files. Browse into this folder in the catalog view, show the Details panel, and click these files to view the reports.

Tip:

You can drag a map or a map package from Windows Explorer and drop it on the Catalog pane or the catalog view to import it to a project.

If the original map has a description or full metadata, it is imported to the project with the map. Each imported item has a copy of the original metadata as a starting point.

Some of the data formats available in other ArcGIS Desktop applications are not supported in ArcGIS Pro; layers that reference these formats in the original map may not draw successfully after being imported. Convert these datasets to a supported format using the data conversion geoprocessing tools. Afterwards, the imported map layers can be connected to the converted datasets.

There are drawing differences between ArcGIS Desktop applications and ArcGIS Pro due to improvements to the drawing engine.

Imported maps are not connected to the files they were imported from. Future changes to the original map do not appear automatically in the project.

Copy a map from another project

Maps can be copied from one project to another if both projects are open at the same time.

  1. Browse to the collection of maps in your source project.
    • In the Catalog pane, on the Project tab, double-click Maps.
    • In a catalog view, click Maps in the Contents pane.
  2. Select the appropriate maps, for example, Ctrl-Click each map you would like to copy.
  3. Copy the maps.
    • In the Catalog pane, right-click the selected maps and click Copy.
    • In a catalog view, on the Home tab, in the Clipboard group, click Copy Copy.
  4. Browse to the collection of maps in your destination project.
  5. Paste the maps.
    • In the Catalog pane, right-click the Maps container and click Paste.
    • In a catalog view, on the Home tab, in the Clipboard group, click Paste Paste.
Tip:

You can also copy the selected maps by dragging them from the source project and dropping them onto the Maps container in the destination project.

Add a web map or web scene from a portal

Maps and scenes authored in your project can be shared with others in your organization by publishing them to your portal as web maps or web scenes. Once shared, you can add a web map or web scene to your project from the active portal.

The map in your project links to the original web map. If the web map is updated on the portal, a notification appears in ArcGIS Pro indicating you can update the map in your project to match. If you want to continue working with the version of the map you already have, dismiss the notification. Web scenes can be added and updated in the same manner.

Add a web map or web scene to the project

You can add a web map or web scene to your project from the active portal. The map or scene in your project links to the original web map or web scene.

  1. On the Catalog pane, click the Portal tab or in the Catalog view, click Portal in the Contents pane.
  2. Browse or search for the web map or web scene you want to use in the My Content, Groups, or All Portal collections.
  3. Right-click the item and click Add And Open Add.

    The original web map or web scene converts to the ArcGIS Pro map format and is added to the project. The map or scene opens in a view. In the Catalog pane and view, the blue link Link on its icon shows it is linked to the web map or web scene on the portal.

Tip:

Web maps and web scenes are also available when you click Import Map Import Map on the Insert tab on the ribbon.

Update a map or scene

When a web map or web scene in the project has been updated on the active portal, the next time you open the map a notification will appear indicating the update is available. Update the map or scene in your project with the current version of the web map or web scene on the portal to see the changes in your project. Any modifications you made to the previous version of the map are lost. If you want to save your version of the map to a file before updating your project, dismiss the notification and update the map or scene manually at a later time.

Act on a notification

  1. Click the notifications button Notifications to open the Notifications pane.
  2. Hover over a notification indicating a new version of your map or scene is available.
  3. To see what changes have been made, click the more button More button button in the bottom corner of the notification and click Open Portal Item.

    The page describing the item in the active portal opens in a browser.

  4. Click Update Map or Update Scene.

    The current version of the item stored in your project is removed. The updated web map or web scene converts to the ArcGIS Pro map format and is added to the project.

Update manually

  1. Browse or search for the linked map or scene in the Catalog pane or catalog view.
  2. Right-click the linked map or scene and click Update Update.

Related topics