Skip To Content

Catalog pane, catalog view, and browse dialog box

When you create or open a project, one of the first panes you see is the Catalog pane. The catalog view also is open when you create a new project using the project templates provided with ArcGIS Pro, and it is the active view when you create a new blank project. The Catalog pane and the catalog view allow you to access all items associated with a specific project in one place, whether they are available from a local or network computer, ArcGIS Online, or an ArcGIS Enterprise portal.

In the Catalog pane and catalog view, you can do the following:

  • Discover GIS content on local networks or your organization's portal.
  • Browse and search for layers to add to a map or analyze with a tool.
  • Connect to databases and servers.
  • Favorite frequently used folder, database, and server connections.
  • Create and import maps, scenes, layouts, and tasks.
  • Preview an item's spatial data and create a thumbnail.
  • Describe your project and its items.
  • Manage items in a project, geodatabase, toolbox, folder, or style.

As you build your project by adding maps, scenes, layouts, connections to folders, geodatabases, and so on, these items appear on the Project tab in the Catalog pane and in the Project collection in the catalog view, categorized by type.

The Catalog pane and the catalog view are designed toward different tasks. Both the pane and the view can be open at the same time, but they're independent of each other. You can switch tasks without losing your place. For example, you can edit symbols in a custom style in the catalog view, and pause in that work to add layers to a map using the Catalog pane.

Note:

The first time you browse to a location, the contents list accurately reflects the items present. If its contents are changed outside ArcGIS Pro or by someone else, you must refresh the location's content to see that change. For example, press F5 to update the list.

Catalog pane

The Catalog pane has tabs across the top that provide access to collections of items.

Use the Catalog pane to access items and drag data onto a map or tool parameter.

The Project tab provides access to the collection of items in your project; it's selected by default. The Portal tab provides access to collections of online content available from the active portal that you have permission to use. The Favorites tab allows you to collect frequently used folder, database, and server connections, and add them to your project. The History tab provides access to the geoprocessing history and raster function history for the project.

In the Catalog pane, you can do the following:

  • View the items in many containers at once.
  • Search for items by typing keywords in the Search box and pressing Enter.
  • Hover over an item and a pop-up appears showing its location, title, thumbnail, tags, and modification date if pop-ups are enabled and these details are available.
  • Ctrl+click or Shift+click many items to select them all, and add them all to a map at once, for example.

The Catalog pane docks in the ArcGIS Pro application, providing access to items in your project and the active portal while you work. After browsing or searching for content, you can drag layers onto maps, datasets onto tools, tools onto models, and so on.

Reopen the Catalog pane

The Catalog pane is usually available when you create or open a project. Once closed, you can open it again by doing the following:

  1. Click the View tab on the ribbon.
  2. In the Windows group, click Catalog Pane Catalog Pane.

Show more information in the pop-up

Some items show more information than others in the pop-up. All items can show their title, type, and location. Portal items can also show their owner. Most items can also show a modification date. When you're working with a new or unfamiliar collection of items, it may help to see more information.

  1. On the Home tab, in the Options group, check More Detail.
  2. Browse into the folder in the catalog view.
  3. In the Catalog pane, browse into the same folder and hover over the item to see its pop-up.

Local and network items will also show a thumbnail and tags if they are present for the item. A summary will also appear in the details panel of the browse dialog box. Extracting this additional information from the metadata will slow browsing of local and network items, but this can be a useful feature when you need more information.

Hide and show the pop-up

The Catalog pane shows a pop-up by default when you hover over an item. Hide it if you know your data and you find it gets in the way.

  1. On the Home tab, in the Options group, uncheck Show Pop-ups to hide the pop-up.
  2. In the Catalog pane , click the Menu button Menu and check Show Pop-ups to see them again.

Copy an item's path

If the active view is the catalog view or the map view, the Copy Path button is available on the ribbon.

  1. In the Catalog pane, click the item whose path you want to discover.

    You can select an item added to the project, an item accessed from a folder connection, a portal item, or a favorite item.

  2. Click the Copy Path button on the ribbon, in the Clipboard group.
    • If the catalog view is active, click the Home tab on the ribbon.
    • If the map view is active, click the Map tab on the ribbon.

Catalog view

The Project, Portal, and Favorites item collections are available in the catalog view as well as the Catalog pane. When the catalog view is active, quick links to the item categories and collections are available in the Contents pane.

The columns display type is well suited for managing your items. An Item's name, type, and modification date, and a portal item's owner, are listed. The contents list can be sorted using any column.

The catalog view shows item properties in columns, sorts the list using values in a column, and previews spatial data.

The tiles display type in the catalog view provides a gallery experience for exploring items. This can be helpful if you aren't sure which item to use, especially if you are accessing the active portal for the first time or if you use ArcGIS Pro infrequently. You can immediately see an item's name, type, thumbnail, and date if this information is available.

The catalog view shows item properties and thumbnails on tiles and item metadata to help you explore unfamiliar items.

Additional information is available in the details panel. In the details panel, the Metadata tab displays metadata for most items. For spatial datasets and maps, the Preview tab lets you visualize the data. For a style, you can preview the symbols, scale bars, north arrows, and other style items it contains, and modify a style item's properties in the details panel.

In the catalog view, you can do the following:

  • Click the Refresh button Refresh at the end of the Location bar to update the list of items.
  • Right-click in the whitespace around the contents list to access the context menu for the current location. For example, to create a new item in your current location.
  • Resize the columns and the details panel to improve the display of information.
  • Click a column heading to sort the contents list by that information in ascending order. Click again to sort in descending order.
  • Click Default Sort Sort by ID on the Home tab on the ribbon to return the contents list to its original order.
  • Click the Show/hide details panel button Show/hide details panel in the upper right corner to hide and show the details panel.
  • Use the Categories menu to browse collections in the Living Atlas.
  • Use the toggle button Display type toggle button in the bottom corner of the view to switch between the columns and tiles display types.
  • Click Folders or My Content, for example, and click in the Search box. Type the name of the item you want to find and press Enter. Click the item you want to use in the list of search results.

Manage your items in the catalog view. The buttons on the Home tab on the ribbon update dynamically to reflect what you can do in the current location or with the selected items:

The quick links in the Contents pane of the catalog view do not expand to support browsing in the same manner as the Project tab in the Catalog pane. In the catalog view, you see one level in a collection's hierarchy at a time. You can browse by double-clicking collections, groups, or containers in the catalog view. The following additional options are available in the catalog view to browse item collections:

  • The Location bar at the top shows your current location. Click the bar to copy the location's path.
  • Click Copy Path Copy Path on the Home tab on the ribbon to copy the selected item's path.
  • Click a place in your current location's path on the Location bar to browse to that location.
  • Click an arrow on the Location bar and click a place in the menu that appears to browse to that location.
  • Paste or type a path to another location onto the Location bar and press Enter to browse to that location. A folder connection is added to the project if the location is not already included in your project.
  • Click Up Up to go up a level in the current collection's hierarchy.
  • Click Back Back to return to your last location.
  • Click Forward Forward to return to a previous location within the same collection.
Note:

The Catalog pane does not directly interact with the catalog view. That is, browsing, searching, and selecting items in the Catalog pane has no effect on the location or the selected item in the catalog view. However, if you add or remove project items such as a folder connection in the Catalog pane, the contents list in the catalog view is updated accordingly.

Open a catalog view

From the ribbon, you can open several catalog views and use them to compare the contents of databases or folders, compare metadata for two items, copy style items from one style to another, and so on.

  1. Click the View tab on the ribbon.
  2. In the Windows group, click Catalog View Catalog View.

A new catalog view opens. Any existing catalog views and the Catalog pane will remain open if they are present and continue to provide access to items in their current location.

Switch from the Catalog pane to the catalog view

When you switch to a task that requires or is more easily performed in the catalog view, the Catalog pane may seem like it's in the way.

  1. In the Catalog pane, click the Menu button Menu.
  2. Click Switch to View Expand.

The Catalog pane closes and the catalog view opens.

Tip:

If you need more room in the catalog view, you can, for example, undock it and place it on another monitor. You can also use Auto Hide to temporarily hide the Catalog pane if you leave the catalog view docked in the ArcGIS Pro application. Or, close the Catalog pane entirely.

Change the display type

The catalog view uses the columns display type by default to make it easy to find and manage familiar items. If you're working with unfamiliar data, change the catalog view to use the tiles display type instead.

  1. On the Home tab, in the Options group, click Display Type and click Tiles to see item properties on tiles.
  2. Click Columns on the toggle button Display type toggle button in the bottom corner of the catalog view to see item properties in columns.

Hide and show the details panel

The details panel is open by default in the catalog view. Hide the details panel to show more tiles or make columns wider. Show the details panel to learn more about a specific item and preview its data.

  1. On the Home tab, in the Options group, uncheck Show Details to hide the details panel.
  2. In the catalog view, click the Show/hide details panel button Show/hide details panel to the right of the search text box to show the details panel.

Browse dialog box

The browse dialog box allows you to select an item in your project, a portal item, or an item outside your project to use for a specific task. When you click the Add Data button on the Map tab on the ribbon, the browse dialog box appears with the title Add Data.

The browse dialog box lets you explore items in a manner similar to the catalog view. Quick links provide access to the available item categories and collections. Item properties are displayed in columns that can be used to sort the contents list. A brief portion of the selected item's metadata is available in the details panel along with the item's location and owner if the selected item is accessed from the active portal.

The browse dialog box can show a brief portion of an item's metadata, including a thumbnail, in the details panel.

While the Project and Portal item collections continue to be available, the Favorites collection is not available on the browse dialog box. Add the favorite items you need to the project.

The browse dialog box also includes a Computer collection that lets you browse to and select items from locations on the local computer or the network that are not currently included in your project. This capability lets you add an existing file geodatabase to your project or import the contents of an ArcMap document, for example. Search is not available when you're browsing the computer; you can only search the active portal and locations included in the current project except for folder connections that access the root of a disk.

You browse in the dialog box in the same manner as the catalog view, by clicking quick links, double-clicking containers, and using the Location bar at the top. However, you can also do the following:

  • Click the Location bar or click in the Name text box to paste or type the path to a new location and press Enter. The dialog box browses to that location. If the location is not accessible from the computer's local or mapped network drives, the network location is accessed and the items it contains are listed; the location is not added to the project as a folder connection.
  • Paste a full path to an item, including the item's name, into the Name text box to immediately select that item. For example, paste a full path including a table's name to add it to the current map.
  • When the Groups or All Portal quick links are selected, click the Search My Organization button Search My Organization in the upper corner of the dialog box to include only items from the active portal that are provided by your organization in your search results.

When items are listed on the browse dialog box, they are filtered according to the specific items that can be used to perform the task at hand. For example, when adding data to a map, only items that can be added to a map will appear. When importing items to a project, only items that can be imported will appear. Only the item categories and collections that are appropriate to the current operation are available to you.

In certain circumstances, the browse dialog box allows you to further refine the contents list by choosing a more specific filter. For example, if you want to add a specific type of item to a map, you can select a filter that lists only that type of item.

The browse dialog box shows item properties in columns that can be used to sort the list and can filter items by type.

Sometimes the browse dialog box is used to provide access to a specific type of file that is otherwise not available in ArcGIS Pro. For example, many geoprocessing tools import data from or export data to external data formats. These tools may accept any type of file as input to a parameter, for example, by allowing files of type *.*. In this case, the browse dialog box may list all available item categories and collections, and show all types of items and files even though the title of the dialog box and the filter indicate you should select a specific type of file. In this way, you can select any file with any extension that contains data in the specified format.

Related topics