Skip To Content

Share a web style

From ArcGIS Pro, you can share a custom style as a web style to ArcGIS Online and ArcGIS Enterprise to use in the web scene viewer symbol gallery. When sharing a style, only valid symbols are included in the web style. All other style items are disregarded.

A symbol is considered valid if all of the following conditions are true:

Note:

If you will be using symbols from the web style in publicly accessible web scenes, share the web style with Everyone.

To see your web style in the scene viewer symbol gallery, it must be shared with the organization's style group. To configure your organization to display custom web styles in the scene viewer symbol gallery, see Configure map.

Share a web style

Any custom style can be shared as a web style; however, if the style contains no valid symbols, sharing will fail.

  1. To share a web style, do one of the following:
    • On the Share tab, in the Share As group, click the Share web style arrow Share web style and click the desired style.
    • In the Catalog pane or a Catalog view, right-click a custom style and click Share as web style Share as web style.

    The Share As Web Style pane appears.

  2. Provide a name for the web style.
  3. Complete the Summary and Tags fields.
  4. Use the Folder drop-down menu to specify where the web style will be stored in your portal content. Optionally click the browse button Browse to create a new folder or choose an existing one. You can also type in the name of the desired folder.
  5. Specify how the web style will be shared:
    • My Organization—If you are signed in with an organizational account, you see this option. This option allows your content to be shared with all authenticated users in the organization.
    • Everyone—This option makes your content public. Anyone can access and see it.
    • Groups—You can share your content with groups you belong to and their members.
  6. Click Share.

Considerations when sharing to older portals

Web styles cannot be shared to ArcGIS Enterprise 10.5.1 and earlier.