Skip To Content

Create a new task

This workflow guides you through the steps to create a new task in a new task item. The task that will accomplish the following:

  • Search for a work area in the map.
  • Create and attribute a new feature.

This workflow assumes that you're using your own data. Your data should contain at least one feature layer.

Create a new task item

See Create a new task file for more information.

  1. With a project open in ArcGIS Pro, open a map.
  2. On theView tab, click Tasks Tasks to open the Tasks pane.
  3. On the Insert tab, click the Task drop-down arrow and click New Task Item New Task Item.
  4. In the Task Designer pane, type Create and attribute a new feature in the Name text box.
  5. In the Description text box, type an overview description of the task item.
  6. In the Task Version text box, type the version number of the task item.

    Each time you change or update your task item, you can change the version number. Choose Auto Increment to change the task item version by one increment each time the task item is updated.

Note:

Changes in the Task Designer are saved when the project is saved. When authoring a task in Task Designer, it's recommended to save the project regularly to save your task changes. You can exit out of the task designer at any time by either closing the Task Designer pane or by clicking Options Menu in the Tasks pane and clicking Exit Designer.

Create a new task

See Create a new task for more information.

  1. With the Task Designer pane open and the new task item loaded in the Tasks pane, click the New Task button New Task.

    Tip:

    If the Task Designer pane is closed, click Options Menu in the Tasks pane and click Edit In Designer to open the Task Designer pane.

  2. Type Create a feature as the task name.
  3. Type a task description in the Description text box.

    The task description should describe what the task will achieve. For example, type Create and attribute a new feature.

  4. Leave Hide this task unchecked.

    You can hide a task when the task is incomplete or when the task is never used. For example, a person working with parcels may never create or edit condominiums and would not want to see those tasks that deal with condominiums.

Create the task steps

See Create a task step for more information.

  1. With the new task selected, click the New Step button New Step to create the first step.
  2. The first step you create will search for and locate a work area.
  3. In the Task Designer pane under General, type a short step name that best defines the step in the Name text box.

    For example, type Zoom To The Work Area.

  4. Type a short description of the step in the ToolTip text box.
  5. Type the step instructions in the Instructions text box.

    The step instructions should include information on how to execute and complete the step. For example, type Click Run and enter a search address in the Locate pane.

  6. Type instructions that inform the user how to start the step and move on to the next step in the Run/Proceed Instructions text box.

    For example, type Click Run to start the step, and click Next Step to proceed to the next step.

  7. For Step Behavior, choose Manual.

    A Manual step behavior requires the user to click Run to start the step and to click Next Step to proceed to the next step.

    Available step behaviors are Manual, Auto Run, Auto Proceed, and Automatic as described in the following table:

    Manual

    User clicks Run to execute the step and clicks Next Step to proceed to the next step.

    Auto Run

    Step automatically executes and user clicks Next Step to proceed to the next step.

    Auto Proceed

    User clicks Run to execute the step, and the step automatically proceeds to the next step.

    Automatic

    The step executes and proceeds to the next step. You can hide an automatic step so that the step runs silently in the background, for example, selecting and zooming to a feature.

  8. In the Task Designer pane, click the Actions tab. Here you'll define the command or action to execute in this step.
  9. You'll set a step command by browsing for the command using a list of tabs in ArcGIS Pro.
  10. Hover over the command action bar and click the Edit Editable icon.
  11. Under Type of Command, click the drop-down list and choose Command.
  12. Click the drop-down list under Choose commands from and choose List of Tabs.
  13. Under Main Tabs, expand MAP > Inquiry and choose the Locate Locate command. Click OK to add the command.
  14. Tip:

    You can also search for commands by choosing All Commands under Choose commands from and typing the command name in the search box.

  15. Click OK to set the chosen command and click Done or the back arrow Back to return to the Actions tab.
  16. Click the Views tab. Here you'll define the active and open views for the task step.
  17. Choose the map view that will be active for the step by clicking the map view's radio button under Active.

    This map view will be used to search for the work area. You can open or close all other views in the project by clicking the icon under Open to toggle the state of the view.

    Learn more about setting step views

  18. The second step you create will open the Create Features pane. The Create Features pane lists the feature templates and tools for the layers in the Contents pane. You choose a tool from the Create Features pane to construct a new feature.
  19. Click New Step New Step in the Tasks pane.
  20. Under General in the Task Designer pane, type Create a feature as the step name, Choose a tool to construct your features as the step instructions, and Click Next Step to Continue as the run/proceed instructions.
  21. Choose Auto Run for the step behavior.

    When running the task, the step will automatically start and open the Create Features pane. The task user clicks Next Step to move to the next step.

  22. Under Actions, click the Record icon Record on the command action bar to record the step command.

    Recording a command click is a quick way to set a step command.

  23. On the Edit tab, click the Create Create Features command to set it as the step command.

    The Create command is an embeddable command. This means that the command launches a window pane that is embedded in the Tasks pane. Not all commands are embeddable. Some embeddable commands support preset parameters when they're configured in the Task Designer pane. When embedding the Create command, the preset parameters Filter and Group By are available. These parameters can be preset to control how the feature list is displayed in the embedded Create Features window when the step is run.

    Tip:

    Click the Edit icon Editable on the command action bar to edit the properties of the embeddable command.

    Learn more about embeddable commands

  24. Under Views, choose the map view to be used for the creation of the feature.

    Choose the map view that will be active for the step by clicking the map view's radio button under Active.

  25. Under Contents, set the necessary states for the layers listed under Layer. The layer in which the new feature will be created should be editable, visible, and selectable.

    The layers listed are from the active map view chosen under Views. Click under the Visible List By Drawing Order, Selectable List By Selection, Editable Editing, and Snappable List By Snapping icons to toggle the state of each layer.

    Learn more about setting step contents

  26. Create the third step by recording a command click: with the Task Designer pane open, click Record Commands Record Commands in the Tasks pane to begin recording.

    Use Record Commands Record Commands to quickly create a sequence of steps by clicking a series of commands.

  27. On the Edit tab, click the Attributes button Attributes.

    A step is created with the Attributes command Attributes added to the command action bar on the Actions tab. The step name becomes the name of the command you clicked, which in this case, is Attributes. The step behavior is the default behavior, which is manual.

  28. Click Stop Recording Stop Recording in the Tasks pane to stop recording command clicks.
  29. Note:

    The Attributes window is an embeddable command. Embeddable commands are always embedded in the Tasks pane by default. The step behavior of embedded commands can be set to Auto Run only.

    Learn more about recording steps
  30. Under General, type Click Run to Attribute The Feature as the new step name, Enter attributes for your new feature as the step instructions, and Click Finish to complete the task as the run/proceed instructions.
  31. Under Contents, toggle the icons under Visible List By Drawing Order and Editable Editing to specify which layers you want to be visible and editable for the attribution of the feature.
  32. Save the project and close the Task Designer pane to exit out of the task design mode.

    Your task is now ready to run.