Skip To Content

001377: Tool <value> requires an enterprise geodatabase.


The result references a tool that can only execute with an enterprise geodatabase. Creating a geoprocessing service that uses tools that can only operate against enterprise geodatabases is not supported unless you have registered the database with the server's data store.


You must ensure the package or service will use an enterprise geodatabase.

  • If you are creating a geoprocessing package, check the option Include Enterprise Geodatabase data instead of referencing the data.
  • If you are creating a service, register the enterprise geodatabase with the server's data store.