Skip To Content

Lernprogramm: Nächstgelegene Einrichtung

Mit der Network Analyst-Lizenz verfügbar.

Komplexität: EinsteigerErforderliche Daten: ArcGIS Tutorial Data for Desktop

Der Solver für die nächstgelegene Einrichtung sucht eine oder mehrere Einrichtungen, die anhand der Fahrzeit oder Fahrstrecke am nächsten an einem Ereignis liegen, und gibt die besten Routen als Wegbeschreibungen zwischen Ereignis und ausgewählter Einrichtung aus. In diesem Lernprogramm suchen Sie mit diesem Werkzeug das einem Ereignis am nächsten gelegene Krankenhaus. Die Suche nach einer nächstgelegenen Einrichtung kann mit einem lokalen Netzwerk-Dataset oder einem Netzwerk-Service verknüpft werden, der in ArcGIS Online oder in ArcGIS Enterprise gehostet wird.

Vorsicht:
Wenn Sie das Tutorial mit ArcGIS Online ausführen, werden Credits verbraucht.

Abrufen der Daten

Die Daten für dieses Lernprogramm können auf arcgis.com heruntergeladen werden.

  1. Wechseln Sie zur Webseite für die Elementbeschreibung des Lernprogramms "Network Analyst" auf arcgis.com.
  2. Klicken Sie auf die Schaltfläche Herunterladen, um die Datei lokal zu speichern.
  3. Entzippen Sie die heruntergeladene Datei.

Erstellen einer Karte

  1. Öffnen Sie ArcGIS Pro.
  2. Erstellen Sie ein neues Projekt basierend auf der Vorlage Map.aptx.

    Ein neues Projekt mit einer Karte wird angezeigt.

Hinzufügen von Lernprogrammdaten zum Projekt

Ein Netzwerk-Dataset ist ein intelligentes Modell des Straßensystems. Es enthält nicht nur den Standort und die Attribute der Straßen, sondern auch Informationen darüber, inwiefern Straßen zusammenhängen – zum Beispiel welche Straßen miteinander verbunden sind, auf welchen verbundenen Straßen das Wenden erlaubt ist und wo nicht, und andere Informationen, die mögliche Reisewege und die Reisedauer beeinflussen können. Der Solver für die nächstgelegene Einrichtung referenziert das Netzwerk-Dataset, um nächstgelegene Positionen zu ermitteln.

Wenn Sie mit ArcGIS Online eine Analyse durchführen, verweist der Solver auf ein hochwertiges, weltweites Netzwerk-Dataset, das in der ArcGIS Online-Cloud gespeichert ist und ArcGIS Online-Credits verbraucht. Wenn Sie Ihre eigenen Daten verwenden, werden keine Online-Credits verwendet, Sie müssen Ihr Netzwerk-Dataset jedoch mit dem Projekt verknüpfen.

Führen Sie die folgenden Schritte aus, um ein Netzwerk-Dataset zu einer Karte hinzuzufügen.

  1. Klicken Sie im Bereich Katalog, der sich standardmäßig an der Seite der Anwendung befindet, mit der rechten Maustaste auf Ordner, und wählen Sie Ordnerverbindung hinzufügen Ordnerverbindung hinzufügen aus.

    Daraufhin wird das Dialogfeld Ordnerverbindung hinzufügen angezeigt.

  2. Navigieren Sie zu dem Ordner, in dem Sie die Lernprogrammdaten abgelegt haben, doppelklicken Sie auf Network Analyst und anschließend auf Lernprogramm, um den Ordner auszuwählen.
  3. Klicken Sie auf OK.

    Es wird eine Verbindung zu dem Lernprogrammordner erstellt.

  4. Fügen Sie als Nächstes eines der im Ordner enthaltenen Netzwerk-Datasets zu der Karte hinzu.

  5. Erweitern Sie im Bereich Katalog Ordner > Lernprogramm > SanFrancisco.gdb > Verkehr.
  6. Ziehen Sie Streets_ND, das ein Netzwerk-Dataset-Symbol aufweist Netzwerk-Dataset, auf die Karte.

    Das Netzwerk-Dataset wird dem Bereich Inhalt und der Karte hinzugefügt.

  7. Klicken Sie im Bereich Inhalt mit der rechten Maustaste auf Streets_ND, und wählen Sie Auf Layer zoomen Auf Layer zoomen aus, um den Bereich San Francisco anzuzeigen.

    Standardmäßig werden in Netzwerk-Datasets mit Verkehrsdaten die Verkehrsbedingungen für die aktuelle Uhrzeit angezeigt, wenn sie der Karte hinzugefügt werden. Da dieses Netzwerk-Dataset historische Verkehrsdaten enthält, sehen Sie die typischen Verkehrsbedingungen für die aktuelle Uhrzeit und den Wochentag. Nicht alle Straßen in diesem Netzwerk-Dataset enthalten Verkehrsdaten, d. h., es werden standardmäßig nur Netzwerk-Datasets mit Verkehrsdaten angezeigt.

    Das durch das Netzwerk-Dataset abgedeckte Gebiet ist dort, wo Sie Netzwerkanalysen vornehmen können.

    Da das Netzwerk-Dataset nicht angezeigt werden muss, um eine Analyse durchzuführen, blenden Sie es als Nächstes aus.

  8. Deaktivieren Sie im Bereich Inhalt das Kontrollkästchen bei Streets_ND, um nur die Grundkarte anzuzeigen.
  9. Navigieren Sie im Bereich Katalog zu Tutorial > SanFrancisco.gdb > Analysis.
  10. Klicken Sie mit der rechten Maustaste auf den Layer Hospitals, und wählen Sie Zu aktueller Karte hinzufügenOption "Daten hinzufügen" aus.

    Der Layer Hospitals wird dem Bereich Inhalt und der Karte hinzugefügt.

Hinweis:

Sie können der Karte auch einen Layer hinzufügen, indem Sie ihn aus dem Bereich Katalog auf die Karte ziehen.

Erstellen des Layers der nächstgelegenen Einrichtung

Auf dem Layer für die Analyse der nächstgelegenen Einrichtung werden alle Eingaben, Parameter und Ergebnisse der Analyse der nächstgelegenen Einrichtung gespeichert.

  1. Klicken Sie auf der Registerkarte Analyse in der Gruppe Werkzeuge auf Netzwerkanalyse > Nächstgelegene Einrichtung Nächstgelegene Einrichtung.

    Der Layer Nächstgelegene Einrichtung wird dem Bereich Inhalt hinzugefügt. Er enthält mehrere Sublayer, die Eingaben und Ausgaben der Analyse enthalten.

    Der Layer Nächstgelegene Einrichtung verweist auf das Netzwerk-Dataset "San Francisco", weil sich das Netzwerk bei der Erstellung des Layers im Bereich Inhalt befand.

    Hinweis:
    Zum Ändern und Anzeigen der Netzwerk-Dataset-Quelle, die zum Erstellen des Netzwerkanalyse-Layers verwendet wird, können Sie auf der Registerkarte Analyse in der Gruppe Werkzeuge auf das Dropdown-Menü Netzwerkanalyse klicken, um sie unter Netzwerkdatenquelle zu öffnen.
  2. Klicken Sie im Bereich Inhalt auf Nächstgelegene Einrichtung, um den Gruppen-Layer auszuwählen.

    Die Registerkarte Nächstgelegene Einrichtung wird in der Gruppe Network Analyst im oberen Bereich von ArcGIS Pro angezeigt.

  3. Klicken Sie auf Nächstgelegene Einrichtung, um die Steuerelemente der Registerkarte anzuzeigen.
    Die Registerkarte "Nächstgelegene Einrichtung"

    Sie verwenden diese Steuerelemente, um die Ergebnisse für die nächstgelegene Einrichtung zu definieren, die Sie generieren möchten.

    Tipp:

    Die Registerkarte Nächstgelegene Einrichtung wird nur dann angezeigt, wenn Sie einen Layer für nächstgelegene Einrichtungen im Bereich Inhalt auswählen. Wenn mehrere Layer für nächstgelegene Einrichtungen vorhanden sind, verfügen sie über eigene Registerkarten.

Hinzufügen von Einrichtungen

Sie verwenden die Feature-Class Hospitals, um die Netzwerkanalyseklasse Einrichtungen zu laden.

  1. Klicken Sie auf der Registerkarte Nächstgelegene Einrichtung in der Gruppe Eingabedaten auf Einrichtungen importieren Einrichtungen importieren.

    Der Bereich Geoverarbeitung erscheint und zeigt das Werkzeug Standorte hinzufügen. Standorte hinzufügen lädt Features in einen Netzwerkanalyse-Layer, z. B. einen Layer für nächstgelegene Einrichtungen. Das Werkzeug kann die Punkte, die Krankenhäuser darstellen, in den Sublayer für Einrichtungen laden.

  2. Stellen Sie sicher, dass der Eingabe-Netzwerkanalyse-Layer auf Nächstgelegene Einrichtung und der Sublayer auf Einrichtungen eingestellt ist.
  3. Klicken Sie auf das Dropdown-Menü unter Eingabepositionen und wählen Sie Hospitals aus. Dies ist die Punkt-Feature-Class, die Sie vorher zur Karte hinzugefügt haben.
  4. Behalten Sie die Standardeinstellungen für die restlichen Werkzeugparameter bei, und klicken Sie auf die Schaltfläche Ausführen Ausführen, die sich unten im Bereich Geoverarbeitung befindet.

    Schaltfläche "Ausführen" unter "Standorte hinzufügen"

    Es werden insgesamt 22 Krankenhäuser als Einrichtungen geladen.

Hinzufügen eines Ereignisses

Ziehen Sie einen Unfallort als Ereignis in Erwägung. Der Solver für nächstgelegene Einrichtungen sucht mindestens ein Krankenhaus, das dem Unfallort am nächsten gelegen ist.

Sie können für die Analyse auch eine Feature-Class mit bestehenden Ereignissen verwenden, indem Sie auf die Schaltfläche Ereignisse importieren klicken Ereignisse importieren; in dieser Übung zeichnen Sie das Ereignis jedoch direkt auf der Karte.

  1. Klicken Sie auf der Registerkarte Bearbeiten auf die Schaltfläche Erstellen Features erstellen.

    Der Bereich Features erstellen wird angezeigt. Er enthält eine Liste mit zu bearbeitenden Layern.

  2. Klicken Sie unter Nächstgelegene Einrichtung: Ereignisse auf Ereignisse.
  3. Wählen Sie das Werkzeug Punkt Zeigen aus, um ein Ereignis auf der Karte in dem Bereich zu erstellen, der vom Netzwerk-Dataset abgedeckt wird.
  4. Klicken Sie auf der Registerkarte Karte auf die Schaltfläche Suchen Suchen.

    Daraufhin wird der Bereich Suchen geöffnet.

  5. Nun geokodieren Sie eine Adresse als Position des Ereignisses.
  6. Geben Sie im Textfeld Suchen 2350 Pine St, San Francisco ein, und drücken Sie die EINGABETASTE.

    Im Bereich Suchen wird eine Liste mit Adressen angezeigt.

  7. Klicken Sie mit der rechten Maustaste auf die erste Adresse, und wählen Sie im Kontextmenü den Eintrag Zu Feature-Class hinzufügen aus.

    Die Adresse wird dem Sublayer Ereignisse des Analyse-Layers Nächstgelegene Einrichtung hinzugefügt.

Einrichten von Eigenschaften für die Analyse der nächstgelegenen Einrichtung

Das Menüband Nächstgelegene Einrichtung enthält den Abschnitt Reiseeinstellungen, in dem Sie Eigenschaften für die Analyse festlegen können.

  1. Erhöhen Sie auf der Registerkarte Nächstgelegene Einrichtung in der Gruppe Reiseeinstellungen den Wert im Textfeld Einrichtungen auf 3.

    Der Solver für nächstgelegene Einrichtungen sucht vom Unfallort aus nach maximal drei Krankenhäusern.

  2. Geben Sie im Textfeld Grenzwert den Wert 2 ein.

    Der Solver für nächstgelegene Einrichtungen sucht nach Krankenhäusern, die innerhalb von 2 Minuten vom Ereignisstandort aus erreicht werden können. Krankenhäuser außerhalb der Grenzwertzeit werden ignoriert. Als Einheit werden Minuten verwendet, da die aktuelle Impedanz der TravelTime in Minuten angegeben ist.

  3. Wählen Sie in der Dropdown-Liste Wegbeschreibung den Eintrag Hin zu Einrichtungen aus.

Führen Sie den Prozess zur Ermittlung nächstgelegener Einrichtungen aus.

  1. Klicken Sie auf der Registerkarte Nächstgelegene Einrichtung auf Ausführen Ausführen.

    Schaltfläche "Ausführen" auf der Registerkarte "Nächstgelegene Einrichtung"

    Wenn der Berechnungsprozess abgeschlossen ist, werden Routen in der Kartenanzeige und im Sublayer Routen des Gruppen-Layers Nächstgelegene Einrichtung angezeigt.

  2. Klicken Sie auf der Registerkarte Nächstgelegene Einrichtung in der Gruppe Bericht auf Wegbeschreibung.

    Im Bereich Wegbeschreibung wird die Wegbeschreibung vom Unfallort zu den drei Krankenhäusern angezeigt, die der Solver für nächstgelegene Einrichtungen als am nächsten gelegen ermittelt hat.