Skip To Content

Lernprogramm: Erstellen von Routen

Mit der Network Analyst-Lizenz verfügbar.

Routen stellen die schnellste oder kürzeste Verbindung entlang Straßen zu Stopps oder Punktpositionen dar. Dabei kann es sich um einfache Punkt-zu-Punkt-Routen in der von Ihnen festgelegten Reihenfolge oder in der Reihenfolge mit der kürzesten Gesamtfahrzeit oder Entfernung handeln. Eine Route ist mit einem lokalen Netzwerk-Dataset oder einem Netzwerk-Service verknüpft, der in ArcGIS Online oder ArcGIS Enterprise gehostet wird. Dieses Lernprogramm zeigt zunächst, wie ein lokales Netzwerk-Dataset und anschließend, wie der Online-Service verwendet wird.

Vorsicht:
Wenn Sie das Tutorial mit ArcGIS Online ausführen, werden Credits verbraucht.

Abrufen der Daten

Die Daten für dieses Lernprogramm können auf arcgis.com heruntergeladen werden.

  1. Wechseln Sie zur Webseite für die Elementbeschreibung des Lernprogramms "Network Analyst" auf arcgis.com.
  2. Klicken Sie auf die Schaltfläche Herunterladen, um die Datei lokal zu speichern.
  3. Entzippen Sie die heruntergeladene Datei.

Erstellen einer Karte

  1. Öffnen Sie ArcGIS Pro.
  2. Erstellen Sie ein neues Projekt basierend auf der Vorlage Map.aptx.

    Ein neues Projekt mit einer Karte wird angezeigt.

Hinzufügen von Lernprogrammdaten zum Projekt

Ein Netzwerk-Dataset ist ein intelligentes Modell des Straßensystems. Es enthält nicht nur den Standort und die Attribute der Straßen, sondern auch Informationen darüber, inwiefern Straßen zusammenhängen – zum Beispiel welche Straßen miteinander verbunden sind, auf welchen verbundenen Straßen das Wenden erlaubt ist und wo nicht, und andere Informationen, die mögliche Reisewege und die Reisedauer beeinflussen können. Der Routen-Solver verweist auf das Netzwerk-Dataset, um den kürzesten Pfad zwischen Stopps zu ermitteln.

Wenn Sie mit ArcGIS Online eine Analyse durchführen, verweist der Solver auf ein hochwertiges, weltweites Netzwerk-Dataset, das in der ArcGIS Online-Cloud gespeichert ist und ArcGIS Online-Credits verbraucht. Wenn Sie Ihre eigenen Daten verwenden, werden keine Online-Credits verwendet, Sie müssen Ihr Netzwerk-Dataset jedoch mit dem Projekt verknüpfen.

Führen Sie die folgenden Schritte aus, um ein Netzwerk-Dataset zu einer Karte hinzuzufügen.

  1. Klicken Sie im Bereich Katalog, der sich standardmäßig an der Seite der Anwendung befindet, mit der rechten Maustaste auf Ordner, und wählen Sie Ordnerverbindung hinzufügen Ordnerverbindung hinzufügen aus.

    Daraufhin wird das Dialogfeld Ordnerverbindung hinzufügen angezeigt.

  2. Navigieren Sie zu dem Ordner, in dem Sie die Lernprogrammdaten abgelegt haben, doppelklicken Sie auf Network Analyst und anschließend auf Lernprogramm, um den Ordner auszuwählen.
  3. Klicken Sie auf OK.

    Es wird eine Verbindung zu dem Lernprogrammordner erstellt.

  4. Fügen Sie als Nächstes eines der im Ordner enthaltenen Netzwerk-Datasets zu der Karte hinzu.

  5. Erweitern Sie im Bereich Katalog Ordner > Lernprogramm > SanFrancisco.gdb > Verkehr.
  6. Ziehen Sie Streets_ND, das ein Netzwerk-Dataset-Symbol aufweist Netzwerk-Dataset, auf die Karte.

    Das Netzwerk-Dataset wird dem Bereich Inhalt und der Karte hinzugefügt.

  7. Klicken Sie im Bereich Inhalt mit der rechten Maustaste auf Streets_ND, und wählen Sie Auf Layer zoomen Auf Layer zoomen aus, um den Bereich San Francisco anzuzeigen.

    Standardmäßig werden in Netzwerk-Datasets mit Verkehrsdaten die Verkehrsbedingungen für die aktuelle Uhrzeit angezeigt, wenn sie der Karte hinzugefügt werden. Da dieses Netzwerk-Dataset historische Verkehrsdaten enthält, sehen Sie die typischen Verkehrsbedingungen für die aktuelle Uhrzeit und den Wochentag. Nicht alle Straßen in diesem Netzwerk-Dataset enthalten Verkehrsdaten, d. h., es werden standardmäßig nur Netzwerk-Datasets mit Verkehrsdaten angezeigt.

    Das durch das Netzwerk-Dataset abgedeckte Gebiet ist dort, wo Sie Netzwerkanalysen vornehmen können.

    Da das Netzwerk-Dataset nicht angezeigt werden muss, um eine Analyse durchzuführen, blenden Sie es als Nächstes aus.

  8. Deaktivieren Sie im Bereich Inhalt das Kontrollkästchen bei Streets_ND, um nur die Grundkarte anzuzeigen.

Erstellen des Routen-Layers

Ein Routen-Layer bietet die benötigte Struktur und die nötigen Eigenschaften, um Routenprobleme zu organisieren und zu lösen. Er enthält außerdem die Ergebnisse nach einer Problemlösung.

  1. Klicken Sie auf der Registerkarte Analyse in der Gruppe Werkzeuge auf Netzwerkanalyse > Route Route.

    Der Routen-Layer wird zum Bereich Inhalt hinzugefügt. Er enthält mehrere Sublayer, die Eingaben und Ausgaben der Analyse enthalten.

    Die Route verweist auf das Netzwerk-Dataset "San Francisco", weil sich das Netzwerk in Inhalt befand, als der Routen-Layer erstellt wurde.

    Hinweis:
    Zum Ändern und Anzeigen der Netzwerkdatenquelle, die zum Erstellen des Netzwerkanalyse-Layers verwendet wird, können Sie auf der Registerkarte Analyse in der Gruppe Werkzeuge auf das Dropdown-Menü Netzwerkanalyse klicken, um sie unter Netzwerkdatenquelle zu öffnen.
  2. Klicken Sie im Bereich Inhalt auf Route, um den Gruppen-Layer auszuwählen.

    Die Registerkarte Route erscheint in der Gruppe Network Analyst im oberen Bereich von ArcGIS Pro.

  3. Klicken Sie auf Route, um die Steuerelemente der Registerkarte anzuzeigen.

    Registerkarte "Route"

    Sie verwenden diese Steuerelemente, um die Route zu definieren, die Sie generieren möchten.

    Tipp:

    Die Registerkarte Route wird nur dann angezeigt, wenn Sie einen Routen-Layer im Bereich Inhalt auswählen. Wenn mehrere Routen-Layer vorhanden sind, verfügen sie jeweils über eine eigene Registerkarte.

Erstellen von Stopps

Stellen Sie sich einen Stopp als Punkt vor, den Sie auf einer Reise besuchen müssen. Der Routen-Solver sucht den optimalen Weg durch das Netzwerk und verbindet dabei die von Ihnen angegebenen Stopps.

Sie können für die Analyse auch eine Feature-Class mit bestehenden Stopps verwenden, indem Sie auf die Schaltfläche Stopps importieren klicken Stopps importieren; in dieser Übung zeichnen Sie Ihre Stopps jedoch direkt auf der Karte.

  1. Klicken Sie auf der Registerkarte Bearbeiten auf Erstellen Features erstellen.

    Der Bereich Features erstellen wird angezeigt. Er enthält eine Liste mit zu bearbeitenden Layern.

  2. Klicken Sie unter Route: Stopps auf Stopps.
  3. Verwenden Sie das Werkzeug Punkt Zeigen, um einige Stopps auf der Karte in dem Bereich zu erstellen, der vom Netzwerk-Dataset abgedeckt wird.

  4. Klicken Sie auf der Registerkarte Bearbeiten auf Attribute Attribute.

    Der Bereich Attribute wird angezeigt.

  5. Sie können auch jeden beliebigen Stopp auswählen, den Sie erstellt haben, indem Sie das Werkzeug Auswählen verwenden und die Attribute des Stopps bearbeiten, z. B. den Namen. Wenn Sie angeben möchten, dass der Stopp nur von der rechten Seite eines Fahrzeugs erreichbar ist, klicken Sie auf die Dropdown-Liste CurbApproach, und wählen Sie Rechte Seite des Fahrzeugs aus.

Ausführen der Analyse

  1. Klicken Sie auf der Registerkarte Route auf Ausführen Ausführen.

    Tipp:

    Die Registerkarte Route wird nur dann angezeigt, wenn Sie einen Routen-Layer im Bereich Inhalt auswählen.

    Die Ergebnisse zeigen die schnellste Verbindung durch das Netzwerk, wobei alle von Ihnen erstellten Stopps verbunden werden. Das Stoppsymbol auf der Karte zeigt die Reihenfolgennummer in der Reihenfolge an, in der die Stopps eingegeben und vom Routen-Solver angefahren werden.

  2. Um eine optimale Route zu erstellen, bei der alle Stopps angefahren werden (auch als Handlungsreisenden-Problem, bezeichnet), verwenden Sie die Registerkarte Route in der Gruppe Reiseeinstellungen, wählen Sie das Dropdown-Menü Reihenfolge und dann die Option Beste finden aus.
  3. Klicken Sie auf Ausführen Ausführen. Die resultierende Route zeigt nun die beste Reihenfolge zum Anfahren aller Stopps an.

Erstellen einer Barriere

Die von Ihnen erstellte Route zeigt die schnellste Verbindung durch das Netzwerk unter Berücksichtigung der in Ihr Netzwerk-Dataset eingebundenen Einschränkungen. Das Netzwerk kann zum Beispiel Informationen zu Geschwindigkeitsbegrenzungen, Einbahnstraßen, Abbiegeverboten und Live- oder historischen Verkehrsdaten enthalten. Sie können das Verhalten des Netzwerks durch Bearbeiten Ihres Netzwerk-Datasets anpassen und mithilfe von Barrieren auch temporäre Änderungen an Ihrer Analyse vornehmen. Eine Barriere ist nützlich zur Modellierung von vorübergehenden Straßensperrungen. In dieser Übung ziehen Sie eine Polygon-Barriere, um ein Gebiet von Straßensperrungen zu simulieren und zu überwachen, wie sich Ihre Route verändert.

  1. Klicken Sie auf der Registerkarte Bearbeiten auf Erstellen Features erstellen.

    Der Bereich Features erstellen wird angezeigt. Er enthält eine Liste mit zu bearbeitenden Layern.

  2. Klicken Sie unter Route: Polygon-Barrieren auf Polygon-Barrieren.
  3. Verwenden Sie das Werkzeug PolygonPolygon, um ein Polygon auf der Karte darzustellen. Stellen Sie sicher, dass das Polygon mindestens eine Straße abdeckt, die von der Route verwendet wird, die Sie bereits berechnet haben.
  4. Klicken Sie auf der Registerkarte Route auf Ausführen Ausführen.

    Die Karte zeigt eine andere Route an und vermeidet dabei das Gebiet, das von der von Ihnen erstellten Barriere abgedeckt wird.

Erzeugen von Wegbeschreibungen

Um eine detaillierte Wegbeschreibung zu erzeugen, stellen Sie sicher, dass die Option Ausgabe bei Berechnung standardmäßig aktiviert ist. Die Wegbeschreibung wird beim Ausführen der Analyse nicht generiert, wenn die Option nicht aktiviert ist.

  1. Klicken Sie auf der Registerkarte Route in der Gruppe Wegbeschreibung auf Wegbeschreibung anzeigen Wegbeschreibung.

    Die Wegbeschreibung wird im Bereich Wegbeschreibung angezeigt. Die einzelnen Fahrmanöver werden in der Reihenfolge aufgeführt, in der sie ausgeführt werden sollen. Die Gesamtzeit und Entfernung der Route steht am Ende der Liste.

    Sie können die Wegbeschreibung mithilfe von zahlreichen Aktionen im Bereich Wegbeschreibung genauer anzeigen. Diese Aktionen werden in der folgenden Tabelle beschrieben:

    AktionErgebnis

    Klicken Sie auf einen Routennamen

    Die Karte wird auf die Ausdehnung der Route gezoomt.

    Zeigen Sie auf einen Stopp oder ein Manöver

    Die Position des Stopps oder Manövers wird auf der Karte markiert.

    Klicken Sie auf einen Stopp

    Die Karte schwenkt zu dem Stopp.

    Klicken Sie auf ein Manöver

    Die Karte schwenkt zur Startposition des Manövers.

    Doppelklicken Sie auf einen Stopp

    Die Karte zoomt an den Stopp heran.

    Doppelklicken Sie auf ein Manöver

    Die Karte wird auf die Ausdehnung des Manövers gezoomt.

Erstellen von Routen mit ArcGIS Online

Routen können ohne Verwendung eines lokalen Netzwerk-Datasets erstellt werden. Führen Sie die nachfolgenden Schritte aus, um einen neuen Routen-Layer basierend auf einem Online-Service zu erstellen. Für die Berechnung von Routen, die auf diese Weise erstellt wurden, werden Credits verbraucht.

Hinweis:

Um Online-Services zu verwenden, müssen Sie Mitglied einer Organisation mit Berechtigungen zum Durchführen von Netzwerkanalysen sein.

  1. Klicken Sie auf der Registerkarte Analyse in der Gruppe Werkzeuge auf Netzwerkanalyse > Netzwerkdatenquelle ändern.

    Das Dialogfeld Netzwerkdatenquelle auswählen wird angezeigt.

    Klicken Sie auf http://www.arcgis.com/ und dann auf OK.

  2. Hinweis:
    Stellen Sie sicher, dass alle bisherigen Änderungen gespeichert wurden. Um Ihre Änderungen zu speichern, klicken Sie auf der Registerkarte Bearbeiten auf Speichern.
  3. Klicken Sie auf der Registerkarte Analyse in der Gruppe Werkzeuge auf Netzwerkanalyse > Route Route.

    Der Routen-Layer wird dem Bereich Inhalt hinzugefügt. Er enthält mehrere Sublayer, die Eingaben und Ausgaben der Analyse enthalten.

    Dieser zweite Routen-Layer referenziert den ArcGIS Online-Routen-Service basierend auf einem in der Cloud gehosteten Netzwerk-Dataset.

  4. Klicken Sie im Bereich Inhalt auf Route, um den Gruppen-Layer auszuwählen.

    Die Registerkarte Route erscheint in der Gruppe Network Analyst im oberen Bereich von ArcGIS Pro.

  5. Klicken Sie auf Route, um die Steuerelemente der Registerkarte anzuzeigen. Die Schaltfläche Ausführen wird mit einem Wolkensymbol angezeigt, was darauf hinweist, dass die Route mit einem Online-Service und nicht mit einem lokalen Netzwerk-Dataset berechnet wird.

    Registerkarte "Route"

  6. Wiederholen Sie die oben aufgeführten Schritte, um Stopps zu erstellen, die Analyse auszuführen und Wegbeschreibungen zu generieren.