Skip To Content

Ansicht "Subtypes"

Mit der Ansicht "Subtypes" können Sie vorhandene Subtypes anzeigen und deren Eigenschaften und Werte bearbeiten, Subtypes löschen und neue Subtypes erstellen.

Erfahren Sie mehr über Subtypes und deren Eigenschaften.

In der Ansicht "Subtypes" werden alle vorhandenen Subtypes für einen Layer sowie Domänen und Standardwerte für jedes Feld in diesem Layer angezeigt. Das Menüband ermöglicht Ihnen die Ausführung der üblichen Bearbeitungsvorgänge der Zwischenablage wie Kopieren, Einfügen, Ausschneiden und Löschen. Mit der Schaltfläche Erstellen/Verwalten können neue Subtypes erstellt oder vorhandene verwaltet werden. In der Gruppe Design auf dem Menüband können Sie die Ansicht Felder oder die Ansicht Domänen öffnen, um in Ihrem Datenmodell zu navigieren bzw. es zu verwalten. Nachdem Sie eine Reihe von Änderungen in der Ansicht "Subtypes" durchgeführt haben, klicken Sie auf die Schaltfläche Speichern, um diese Änderungen in die Datenbank zu übernehmen.

Im nachfolgenden Beispiel wird die Erstellung von Subtypes für den Layer "Buildings" dargestellt, wobei der Workflow der vorherigen Hilfethemen in diesem Abschnitt fortgesetzt wird. Das Feld "BLDGTYPE" wurde ausgewählt, um die Subtypes darauf anzuwenden, und das Dialogfeld Subtypes verwalten wurde geöffnet, um die entsprechenden Codes und Beschreibungen für die neuen Subtypes hinzuzufügen. Diese Subtypes stellen verschiedene Typen von Gebäuden wie "Development", "Utility", "Marketing" und "Security" dar. Wenn nun ein neues Gebäude erstellt wird, wird der Gebäudetyp durch den ausgewählten Subtype festgelegt.

Erstellen von Subtypes für das Feld "BLDGTYPE" für den Layer "Building"

Nachdem Sie ein Subtype-Feld zugewiesen, die Subtype-Eigenschaften mit gültigen Werten in der Ansicht "Subtypes" ausgefüllt und auf dem Menüband auf die Schaltfläche Speichern geklickt haben, können die Subtypes beim Anzeigen oder Bearbeiten von Daten in der Kartenansicht verwendet werden. Sobald einem Feld Subtypes zugewiesen wurden, wird es in den Tabellen der Ansichten "Subtypes" und "Felder" fett formatiert und mit einem Sternchen symbolisiert. Dies wird im vorherigen Screenshot dargestellt.

Hinweis:
Wenn in der aktiven Karte nicht gespeicherte Änderungen vorhanden sind, ist die Schaltfläche Speichern deaktiviert, und Sie werden mit einem Informations-Banner darüber informiert. Um die Schaltfläche Speichern wieder zu aktivieren, müssen Sie zuerst die Änderungen auf der Karte speichern oder verwerfen.

Während Sie die Ansicht "Subtypes" bearbeiten, können Sie durch die Tabelle navigieren, indem Sie in die Zellen klicken. Sie können auch die TAB-Taste oder die oder Pfeiltasten verwenden, um in Zeilen und Spalten nach oben und unten zu navigieren.

Hinweis:

Sie können keine Subtypes erstellen, wenn keine Ganzzahlfelder verfügbar sind, die als Subtype-Feld verwendet werden können. Wenn dies der Fall ist und Sie Subtypes erstellen möchten, wechseln Sie zur Ansicht "Felder", und fügen Sie ein ganzzahliges Feld hinzu, auf dem die Subtypes basieren sollen.

Öffnen der Ansicht "Subtypes"

Die Ansicht "Subtypes" kann über die folgenden Orte geöffnet werden:

  • Bereich Katalog: Klicken Sie mit der rechten Maustaste auf die Feature-Class oder Tabelle, für die Sie die Ansicht "Subtypes" öffnen möchten, und wählen Sie Design > Subtypes aus.
  • Bereich Inhalt: Klicken Sie mit der rechten Maustaste auf einen Layer oder eine Tabelle, und wählen Sie Design > Subtypes aus.
  • Menüband: Wählen Sie einen Layer im Bereich Inhalt aus. Klicken Sie auf dem kontextbezogenen Menüband Feature-Layer auf die Registerkarte Daten, und klicken Sie in der Gruppe Design auf Subtypes.

Erstellen eines Subtypes

Führen Sie zum Erstellen eines Subtypes die folgenden Schritte aus:

  1. Wählen Sie im Fenster Inhalt einen Layer aus.

    Die kontextbezogenen Registerkarten Feature-Layer sind jetzt auf dem Menüband verfügbar.

  2. Klicken Sie im Abschnitt Design auf die Registerkarte Daten und dann auf das Element Subtypes auf dem Menüband.
  3. Klicken Sie auf dem Menüband Ansicht "Subtypes" auf die Schaltfläche Erstellen/Verwalten.

    Das Fenster Subtypes-Manager wird angezeigt.

  4. Wählen Sie aus der Dropdown-Liste Subtype-Feld ein Feld aus, das als Subtype-Feld verwendet werden soll.
  5. Geben Sie in der Spalte Code einen Codewert ein.

    Dieser Codewert ist möglicherweise bereits in den Daten vorhanden, oder Sie können einen neuen Code hinzufügen.

  6. Geben Sie in der Spalte Beschreibung eine Beschreibung für den entsprechenden Codewert ein.
  7. Wenn Sie die entsprechenden Codes und Beschreibungen hinzugefügt haben, klicken Sie auf OK, um das Fenster Subtypes-Manager zu schließen.

    Die neuen Werte werden nun der Tabelle der Ansicht Subtypes hinzugefügt.

  8. Klicken Sie auf dem Menüband Subtypes auf die Schaltfläche Speichern, um die neuen Subtypes zu dem Feld hinzuzufügen.

Das Fenster Subtypes-Manager verfügt über die Schaltfläche Codes ermitteln, mit der neue Subtypes hinzugefügt werden können. Durch Klicken auf die Schaltfläche werden die Daten durchsucht und alle im Feld vorhandenen Codewerte, die in der Subtypes-Tabelle noch nicht definiert wurden, werden dieser hinzugefügt.

Löschen eines Subtypes

Ein Subtype kann im Fenster Subtypes-Manager gelöscht werden. Die Schritte zum Zugreifen auf das Fenster Subtypes-Manager finden Sie im vorherigen Task.

  1. Wählen Sie im Fenster Subtypes-Manager die Zeile aus, die den Subtype-Code und die Beschreibung darstellt, die Sie löschen möchten.
  2. Drücken Sie die ENTF-Taste.
  3. Klicken Sie nach Abschluss dieses Vorgangs auf OK, um den Subtypes-Manager zu schließen, und klicken Sie auf dem Menüband Subtypes auf die Schaltfläche Speichern, um den Subtype aus dem Feld zu entfernen.

Mehrere Subtypes können durch Auswahl mehrerer Zeilen mit den Tasten STRG oder UMSCHALT gelöscht werden.

Ändern von Subtypes

Die Ansicht "Subtypes" kann auch verwendet werden, um den Standard-Subtype für das Feld festzulegen, eine Domäne oder einen Standardwert für bestimmte Felder in einem Subtype festzulegen oder die Subtypes neu zu sortieren.

Um den Standard-Subtype für das Feld festzulegen, öffnen Sie das Fenster Subtypes-Manager, wählen Sie einen Subtype aus der Dropdown-Liste Standard-Subtype aus, und klicken Sie auf OK. Um das Subtype-Feld für den Layer oder die Tabelle zu löschen, wählen Sie im Fenster Subtypes-Manager über das Subtype-Feld die Option Alle Subtype-Werte löschen aus. Dadurch werden alle Subtype-Werte entfernt.

In der Ansicht "Subtypes" können Sie für jeden Subtype eine Domäne auf ein Feld anwenden, indem Sie die Dropdown-Liste in der Domänenspalte des entsprechenden Subtypes verwenden. Wenn Sie eine neue Domäne für ein Feld erstellen möchten, können Sie je nach Datentyp des Feldes Neue Domäne mit codierten Werten hinzufügen oder Neue Bereichsdomäne hinzufügen aus der Dropdown-Liste auswählen. Dadurch wird die Ansicht "Domänen" geöffnet, in der Sie die neue Domäne hinzufügen können. Wenn Sie die Domäne aus einem Feld löschen möchten, wählen Sie die leere Zeile aus der Dropdown-Liste aus.

Bei Fortsetzung des Workflows der vorherigen Hilfethemen wird im folgenden Screenshot die Zuweisung einer Domäne und eines Standardwertes zum Subtype "Development" für das Feld "BLDGTYPE" dargestellt. Wenn dem Feld eine Domäne zugewiesen wurde, können Sie einen Standardwert aus der Dropdown-Liste der gültigen Domänenwerte auswählen oder einen Wert eingeben, der für den Datentyp des Feldes geeignet ist.

Zuweisen des Standardwertes "Employees" für das Feld "ACCESSTYPE" des Layers "Buildings" für den Subtype "Development"

Mit dem Fenster Subtypes-Manager können Sie Subtype-Werte auch sortieren oder neu anordnen, indem Sie auf die Spaltenüberschrift "Code" klicken. Wenn Sie auf die Überschrift klicken, wird ein Pfeil angezeigt, der angibt, ob der Code auf- oder absteigend sortiert ist. Die Beschreibungsspalte bietet auch die Funktion für auf- und absteigende Sortierung in alphabetischer Reihenfolge. Wenn Sie die Subtypes neu sortieren möchten, können Sie eine Zeile auswählen und an die gewünschte Stelle ziehen. Die endgültige Reihenfolge der Zeilen wird in der Reihenfolge der Spalten in der Ansicht "Subtypes" widergespiegelt.