Skip To Content

Importieren von Daten

Sie können einer Geodatabase Datasets hinzufügen, indem Sie sie aus anderen Speicherorten importieren oder aus anderen Datenformaten konvertieren und dann importieren.

Importieren von Feature-Classes

Importieren Sie Feature-Classes in eine Geodatabase oder ein Feature-Dataset über das Kontextmenü im Bereich Katalog. Auf diese Weise lassen sich z. B. Shapefiles, Coverages, CAD-Dateien (Computer-Aided Drafting) und Geodatabase-Feature-Classes importieren. Wenn Sie mit der rechten Maustaste auf eine Geodatabase oder ein Feature-Dataset klicken, haben Sie zwei Möglichkeiten zum Importieren von Feature-Classes:

  • Feature-Class: Konvertiert ein Shapefile, Coverage oder eine Feature-Class mit dem Werkzeug Feature-Class in Feature-Class in eine Geodatabase-Feature-Class.
  • Feature-Class(es): Konvertiert eine oder mehrere Feature-Classes oder Feature-Layers mit dem Werkzeug Feature-Class in Geodatabase in Geodatabase-Feature-Classes.

Wenn Sie mehrere Feature-Classes in eine Geodatabase importieren und diese die gleichen Einstellungen für den Import benötigen, können Sie für die Ausführung des Werkzeugs Feature-Class in Geodatabase die Option Feature Class(es) auswählen und sie alle gleichzeitig importieren. Für jede zu importierende Feature-Class wird eine Feature-Class erstellt.

Andere Feature-Classes benötigen wiederum individuelle Einstellungen für ihren Import, beispielsweise Feldzuordnungen, benutzerdefinierte Konfigurationsschlüsselwörter oder räumliche Indizes. In solchen Fällen wählen Sie Feature-Class aus, um über mehr Kontrolle über die Eigenschaften der importierten Feature-Classes zu verfügen.

Wenn Sie eine größere Anzahl Feature-Classes importieren und mehrere Werkzeuge miteinander verknüpfen möchten, können Sie ein Modell erstellen und ausführen, statt den Import jedes Mal manuell über das Kontextmenü durchzuführen. Mit einem Modell lässt sich der Importvorgang automatisieren, indem Sie Umgebungseinstellungen und Werkzeugparameter speichern und wiederverwenden. Nachdem Sie ein Modell erstellt haben, können Sie Daten importieren, das Modell bearbeiten und weitere Eingabedaten hinzufügen, beliebige Parameter ändern und anschließend das Modell mit einem einzigen Klick erneut ausführen.

Weitere Informationen zu Modellen und zur Modellerstellung

Tipp:

Die Felder, die Sie in den neuen Feature-Classes erstellen, werden entsprechend den importierten Feldern benannt. Allerdings werden für Feldnamen unzulässige Zeichen automatisch ersetzt, z. B. ein Bindestrich durch einen Unterstrich.

Feature-Classes und Koordinatensysteme

Jede Feature-Class verfügt über einen Raumbezug mit einem Koordinatensystem, das die Georeferenzierung seiner Positionen festlegt. Achten Sie beim Importieren von Feature-Classes darauf, welches Koordinatensystem das importierte Dataset enthält. Wenn Sie in ein Feature-Dataset importieren, wird die neue Feature-Class automatisch den gleichen Raumbezug wie das Feature-Dataset übernehmen. Beim Importieren von Daten in eine Geodatabase wird eine neue Standalone-Feature-Class mit dem gleichen Raumbezug wie das importierte Dataset erstellt.

Weitere Informationen zu Raumbezügen

Angenommen, Sie möchten eine Feature-Class importieren, die sich in einem anderen Koordinatensystem befindet. Beispielsweise soll eine Feature-Class, die das Koordinatensystem "North American Datum (NAD) 1927" verwendet, in ein Feature-Dataset importiert werden, die das Koordinatensystem "NAD 1983" verwendet. Mit dem Werkzeug "Projizieren" können Sie die Daten gleichzeitig importieren und in das neue Koordinatensystem umwandeln.

Weitere Informationen zum Werkzeug "Projizieren"

Importieren von Tabellen

Über das Kontextmenü im Bereich Katalog können Sie Tabellen in eine Geodatabase importieren. Auf diese Weise können dBASE-, INFO-, Vector Product Format- (VPF), OLE DB- oder Geodatabase-Tabellen importiert werden. Wenn Sie mit der rechten Maustaste auf eine Geodatabase klicken, haben Sie zwei Möglichkeiten zum Importieren von Tabellen:

  • Tabelle: Konvertiert eine Eingabetabelle mit dem Werkzeug Tabelle in Tabelle in eine dBASE-Tabelle, eine File-Geodatabase- oder Enterprise-Geodatabase-Tabelle
  • Tabelle(n): Importiert eine oder mehrere Tabellen mit dem Werkzeug Tabelle in Geodatabase in eine File- oder Enterprise-Geodatabase

Tipp:

Wenn Sie mit dem Werkzeug Tabelle in Geodatabase mehrere Tabellen gleichzeitig importieren, wird jede Tabelle in eine neue Tabelle importiert. Unzulässige oder doppelte Feldnamen werden vom Werkzeug automatisch korrigiert.

Importieren eines XML-Workspace-Dokuments

XML-Workspace-Dokumente umfassen sämtliche Inhalte einer Geodatabase oder jegliche Teilmengen des Inhalts und dienen als Methode zum Freigeben von Schema-Informationen sowie optional der Daten. Mit dem Werkzeug "XML-Workspace-Dokument importieren" können Sie vollständige Feature-Datasets, Feature-Classes oder Tabellen importieren. Sie können auch lediglich das Geodatabase-Schema ohne Daten importieren.

Sie können ein importfähiges XML-Workspace-Dokument erstellen, indem Sie Daten aus einer Geodatabase, einem Feature-Dataset, einer Tabelle oder Feature-Class exportieren. Weitere Informationen über das "Exportieren eines XML-Workspace-Dokuments"

Importieren Sie ein XML-Workspace-Dokument in eine Geodatabase, indem Sie mit der rechten Maustaste in den Bereich Katalog klicken und Importieren > XML-Workspace-Dokument auswählen. Daraufhin wird das Geoverarbeitungswerkzeug XML-Workspace-Dokument geöffnet.

Importieren von Datasets mit Geoverarbeitungswerkzeugen

Zum Importieren von Datasets mit Geoverarbeitungswerkzeugen klicken Sie auf dem Menüband auf die Registerkarte Analyse, und klicken Sie auf Werkzeuge, um den Bereich Geoverarbeitung zu öffnen. Im Bereich Geoverarbeitung können Sie entweder mithilfe des Suchfelds nach den Werkzeugen suchen oder auf die Registerkarte Toolbox klicken, wo Sie sie unter der Toolbox Conversion im Abschnitt In Geodatabase finden.

Weitere Informationen zum Toolset "In Geodatabase"