Skip To Content

Batch-Editor für Raster-Funktionen

Mit dem Batch-Editor für Raster-Funktionen können Sie Funktionen für mehrere ausgewählte Raster unter Verwendung eines schrittweisen Assistenten in einem Mosaik-Dataset einfügen, aktualisieren oder entfernen. Dabei werden Funktionen auf der Elementebene eines Mosaik-Datasets angewendet oder entfernt.

Verwenden des Batch-Editors für Raster-Funktionen

Anhand der nachfolgenden Schritte wird veranschaulicht, wie der Batch-Editor für Raster-Funktionen aufgerufen und zum Verarbeiten eines Mosaik-Datasets verwendet wird.

  1. Fügen Sie das Mosaik-Dataset einem Projekt hinzu.
  2. Wählen Sie den Datensatz bzw. die Datensätze aus, der bzw. die bearbeitet werden soll(en).
  3. Es gibt drei Möglichkeiten, Datensätze in einem Mosaik-Dataset auszuwählen:
    • Verwenden Sie die interaktiven Auswahlwerkzeuge auf der Registerkarte Daten aus.
    • Öffnen Sie über den Footprint-Layer die Attributtabelle, und wählen Sie die entsprechenden Zeilen aus.
    • Verwenden Sie die Geoverarbeitungswerkzeuge Layer nach Attribut auswählen oder Layer nach Position auswählen.
    Hinweis:

    Mosaik-Datasets enthalten primäre Raster und Übersichten. Funktionen sollten in der Regel auf primäre Raster angewendet werden. Wenn Sie alle Datensätze, einschließlich Übersichten, in Ihrem Mosaik-Dataset ausgewählt haben, wählen Sie nur primäre Raster aus, indem Sie die folgenden Schritte ausführen:

    1. Wählen Sie den Mosaik-Dataset-Gruppen-Layer im Bereich Inhalt aus.
    2. Wählen Sie auf der Registerkarte Daten Operationen > Auswahl von Übersichten aufheben aus.

  4. Klicken Sie im Bereich Inhalt mit der rechten Maustaste auf den Mosaik-Dataset-Gruppen-Layer, und klicken Sie auf Auswahl > Raster-Funktionen bearbeiten (Batch-Modus).

    Der Assistent Batch-Editor für Raster-Funktionen wird geöffnet.

  5. Auf der ersten Seite des Assistenten werden Sie aufgefordert auszuwählen, welche Operation durchgeführt werden soll. Wählen Sie eine der folgenden drei Optionen aus, und klicken Sie auf Weiter.
    • Raster-Funktion(en) einfügen: Fügt einer neuen oder vorhandenen Funktionskette an einer bestimmten Stelle mindestens eine Funktion hinzu.
    • Raster-Funktion einfügen: Ermöglicht die Bearbeitung der Parameter und Eigenschaften mindestens einer vorhandenen Funktion in mindestens einer Funktionskette.
    • Raster-Funktion entfernen: Entfernt Funktionen aus mindestens einer Funktionskette.

    Hinweis:

    Bei Auswahl von Rasterfunktion(en) einfügen wird die neue Funktion hinter der von Ihnen ausgewählten hinzugefügt. Bei Auswahl von Raster-Funktion entfernen oder Raster-Funktion aktualisieren wird die von Ihnen ausgewählte Funktion aktualisiert oder entfernt.

  6. Auf der zweiten Seite des Assistenten können Sie festlegen, welche Funktion bzw. Funktionen bearbeitet werden. Wählen Sie eine Suchmethode (nachfolgend beschrieben) aus, um festzulegen, wo Änderungen durchgeführt werden, und klicken Sie auf Suchen, um die Liste mit den verfügbaren Optionen zu füllen.
    • Funktionsname: Listet alle Funktionen in der Funktionskette des jeweils ausgewählten Rasters nach ihrem Namen auf. Dies unterscheidet sich vom Funktionstyp, da Funktionen während der Vorlagenerstellung umbenannt werden können.
    • Funktionstyp: Listet alle Funktionen in der Funktionskette des jeweils ausgewählten Rasters nach Funktionstyp auf, z. B. geometrisch. Wenn Funktionen umbenannt wurden, aber dieselbe Operation durchführen, werden sie als derselbe Funktionstyp angezeigt.
    • Verarbeitungspfad (qualifiziert nach Funktionsname): Gibt jeden möglichen Pfad zum jeweiligen Element in der jeweiligen Funktionskette des ausgewählten Rasters nach Name zurück. Eine Funktion kann in derselben Kette mehrmals vorhanden sein, Sie können jedoch auch nur einer dieser Funktionen eine neue zusätzliche Funktion hinzufügen. Der Pfad in der Funktionskette bietet hilfreichen Kontext, wenn es um die Unterscheidung zwischen mehreren Vorkommnissen einer Funktion in der Kette geht, da die Liste der Verarbeitungspfade jeden möglichen Pfad zu jeder Funktion enthält. Demzufolge kann die Liste lang sein, da mehrere Pfade zur selben Funktion vorhanden sein können.
      Hinweis:

      Die Pfade werden mit der letzten Funktion in der Kette beginnend zurück zu den Eingabe-Rastern angezeigt. Wenn Sie eine neue Funktion einfügen, wird sie hinter der von Ihnen ausgewählten Funktion eingefügt. Wenn Sie beispielsweise in der nachfolgenden Funktionskette eine neue Funktion hinter Funktion A einfügen möchten, wählen Sie den Verarbeitungspfad in den Suchergebnissen aus, die in etwa wie folgt aussieht:function B.Raster \ function A

      Beispiel für eine Funktionskette

      Die neue(n) Funktion(en) wird/werden zwischen Funktion A und Funktion B eingefügt.

    • Verarbeitungspfad (qualifiziert nach Funktionsname): Funktioniert ähnlich wie Verarbeitungspfad (qualifiziert nach Funktionsname), Funktionen werden jedoch nicht nach ihrem Namen, sondern nach ihrem Funktionstyp aufgeführt Dabei werden alle Umbenennungen ignoriert, die an Funktionen in einer Kette vorgenommen wurden.

    Hinweis:

    Wenn Sie die Option Rasterfunktion(en) einfügen auswählen, aktivieren Sie Nach der letzten Funktion in der Kette einfügen, um die Funktion am Ende der Funktionskette für jedes ausgewählte Raster hinzuzufügen. Andernfalls wird die Funktion am Anfang der Funktionskette hinzugefügt.

  7. Bis zu diesem Punkt haben Sie die Operation ausgewählt, die Sie durchführen möchten (einfügen, aktualisieren oder entfernen), und die Position(en), an denen sie durchgeführt werden sollen. Die Optionen auf der nächsten Seite des Assistenten sind je nachdem, welche Operation Sie auf der ersten Seite des Assistenten ausgewählt haben, unterschiedlich.
    • Wenn Sie Rasterfunktion(en) einfügen ausgewählt haben, enthält der Funktions-Editor beim Öffnen eine Raster-Variable. Erstellen oder importieren Sie die Funktionsvorlage, die Sie einfügen möchten. Die neue Funktionsvorlage wird zusätzlich zu der/den auf der vorherigen Seite des Assistenten ausgewählten Funktion(en) eingefügt.
      Hinweis:

      Wenn sie die Funktionsvorlage außerhalb des Batch-Editors erstellen und sie importieren möchten, müssen Sie sicherstellen, dass Sie mit @Row.Raster im Funktions-Variablen-Manager auf das Eingabe-Raster verweisen. Dadurch wird sichergestellt, dass das Raster, das durch den im Mosaik-Dataset ausgewählten Datensatz dargestellt wird, als Eingabe verwendet wird. Wenn Sie die Vorlage im Batch-Editor erstellen, wird der Variablenname automatisch erstellt.

      Eigenschaften von Faltungsvariablen
    • Wenn Sie Raster-Funktion aktualisieren ausgewählt haben, öffnet der Assistent die Seite Ausgewählte Raster-Funktion aktualisieren, auf der Sie Eigenschaften, Parameter, Variablen und Einstellungen aktualisieren können. Auf der Seite Allgemein können der Name, die Beschreibung und der Ausgabepixeltyp der Funktion geändert werden. Auf der Seite Parameter lassen sich Funktionsparameterwerte ändern. Die Seite Variablen kann verwendet werden, um den Variablennamen von Parametern zu ändern. Auf der Seite Einstellungen aktualisieren kann ermittelt werden, welche Parameter oder Einstellungen geändert wurden.

      Bearbeiten Sie alle Parameter und Einstellungen, die Sie aktualisieren möchten, wählen Sie dann Einstellungen aktualisieren aus, und stellen Sie sicher, dass die geänderten Einstellungen und Parameter aktiviert sind. Obwohl Sie zusätzliche Einstellungen manuell aktivieren können, sollten nur die Einstellungen aktiviert sein, die Sie geändert haben. Andernfalls werden die Einstellungen, die nicht geändert wurden, durch Standardwert überschrieben. Klicken Sie abschließend auf Weiter.

      Hinweis:

      Wenn Sie keine Parameter oder Einstellungen auf der Seite Einstellungen aktualisieren aktivieren, bevor Sie auf Weiter klicken, werden Sie vom Assistenten automatisch zur Seite Einstellungen aktualisieren zurück geleitet und es wird eine Meldung als Sicherheitsmaßnahme angezeigt. Wenn die Parameter und Einstellungen richtig sind, klicken Sie erneut auf Weiter.

    • Wenn Sie Raster-Funktion entfernen ausgewählt haben, müssen keine zusätzlichen Schritte ausgeführt werden. Der Assistent leitet Sie direkt zur Zusammenfassungsseite weiter.
  8. Klicken Sie auf Fertig stellen, um den Assistenten abzuschließen.

    Auf der letzten Seite des Assistenten wird eine Zusammenfassung der von Ihnen durchgeführten Änderungen bereitgestellt. Dies umfasst durchgeführten Operationen und die Verarbeitungsdetails.

    Hinweis:

    Stellen Sie sicher, dass Sie mit den Ergebnissen auf dieser Seite zufrieden sind, bevor Sie den Vorgang fortsetzen, da Prozesse nicht mehr rückgängig gemacht werden können, sobald Sie auf Fertig stellen geklickt haben.

Verwandte Themen