Skip To Content

Bearbeiten einer aktiven Tabelle

Eine Datenbank ist nur so gut wie die darin enthaltenen Informationen. Es ist wichtig, die Informationen in einer Datenbank zu bearbeiten, damit sie immer korrekt und auf dem neuesten Stand sind. Sie können sowohl räumliche Daten (Features auf einer Karte) als auch nicht räumliche Daten (z. B. Standalone-Tabelle mit Verkaufszahlen) über die Ansicht Tabelle aktualisieren und ändern.

ArcGIS Pro startet automatisch eine Editiersitzung, wenn vorhandene Daten geändert oder neue Daten erstellt werden. Es sind keine Schaltflächen zum Starten oder Beenden einer Editiersitzung vorhanden. Wenn Sie Daten in der Tabellensicht bearbeiten, bleibt die Editiersitzung so lange aktiv, bis Sie ihre Änderungen speichern oder verwerfen.

Nicht alle Tabellen sind editierbar, darunter Textdateien wie XLS-, XLSX-, TXT- und CSV-Dateien. Solche Tabellen sind schreibgeschützt, wenn sie sich in einer Karte befinden. Wenn Sie die Daten extern bearbeiten, z. B. in Excel, müssen Sie die Textdatei erneut zum Projekt hinzufügen.

Einige Attribtte können in der Tabelle nicht bearbeitet werden. Alle verwalteten Felder wie ObjectID, Shape_Length und Shape_Area sind nicht editierbar. Felder, die in der Ansicht Felder der Tabelle für den Layer als schreibgeschützt abgegrenzt sind, können ebenfalls nicht bearbeitet werden. In verbundenen Tabellen können nur die Felder der Basistabelle bearbeitet werden. Die Felder der verbundenen Tabelle sind schreibgeschützt.

Zu den Bearbeitungsmöglichkeiten gehören Bearbeiten eines Werts in einer Tabellenzelle und Bearbeiten eines Felds mit Gruppenwerten.

Hinweis:

Verwenden Sie die Ansicht "Felder" zum Erstellen, Ändern und Löschen von Feldern.

Die Bedeutung von ObjectIDs

ObjectIDs sind wichtig für die Verwaltung von Daten. Tabellen ohne ObjectIDs – auch als Nicht-OID-Tabellen bezeichnet – weisen einige Beschränkungen auf. Für die Verwendung von Nicht-OID-Tabellen oder schreibgeschützten Tabellendaten empfiehlt es sich, eine Standalone-Datenbanktabelle zu erstellen.

Excel-Tabellen können Sie mit dem Werkzeug Excel in Tabelle konvertieren. Tabellen in anderen Dateiformaten konvertieren Sie mit dem Werkzeug Table in dBASE oder Zeilen kopieren, sodass sie in ArcGIS Pro verwendet werden können. Zusätzlich können Sie mit dem Werkzeug Tabelle in Tabelle das Ausgabeverzeichnis steuern. Wenn Sie Daten mit räumlichen Information haben, können Sie mit dem Werkzeug XY-Tabelle in Punkt eine neue Point-Feature-Class auf der Basis der in der Tabelle definierten X- und Y-Koordinaten erstellen.

Verwandte Themen

In diesem Thema
  1. Die Bedeutung von ObjectIDs