Skip To Content

Filtern von Daten in der Tabelle

Das Filtern der Tabelle ermöglicht das Arbeiten mit einer Datenteilmenge, auf die Sie sich gezielt konzentrieren können. Sie können nach verschiedenen Anforderungen filtern, darunter:

  • selektierte Datensätze anzeigen
  • eine Definitionsabfrage verwenden
  • übereinstimmende Datensätze verknüpfen
  • nach Kartenzeit filtern
  • nach Kartenbereich filtern
  • nach Kartenausdehnung filtern (nur 2D)

Anzeigen selektierter Datensätze

Wenn Sie nur mit ausgewählten Datensätzen interagieren möchten, ändern Sie den Anzeigemodus der Tabelle am besten in Selektierte Datensätze anzeigen. Im Modus Selektierte Datensätze anzeigen werden in der Tabellensicht nur die Datensätze angezeigt, die in der Tabelle ausgewählt wurden. Sie können die Auswahl jederzeit ändern, indem Sie die aktuell in der Karte ausgewählten Features entsprechend der offenen Tabelle aktualisieren oder indem Sie die Auswahl in der Tabelle ändern. Die Tabelle wird dann dynamisch aktualisiert, sodass die aktuelle Auswahl angezeigt wird.

  1. Klicken Sie im Bereich Inhalt mit der rechten Maustaste auf eine Standalone-Tabelle, klicken Sie dann auf Öffnen Tabelle öffnen.
  2. Klicken Sie alternativ im Bereich Inhalt mit der rechten Maustaste auf einen Feature-Layer, klicken Sie anschließend auf Attributtabelle Tabelle öffnen.
  3. Klicken Sie am unteren Rand der geöffneten Tabelle auf Selektierte Datensätze anzeigen Ausgewählte Datensätze anzeigen.

Tipp:

Stellen Sie sicher, dass einige Features auf der Karte ausgewählt sind, um eine Tabelle direkt im Modus Selektierte Datensätze anzeigen zu öffnen. Klicken Sie mit der rechten Maustaste auf den Layer im Bereich Inhalt, zeigen Sie auf Auswahl, und klicken Sie anschließend auf Attributtabelle mit angezeigter Auswahl Ausgewählte öffnen, oder klicken Sie auf die Registerkarte Daten auf Tabelle aus Auswahl Ausgewählte öffnen.

Verwenden einer Definitionsabfrage

Eine weitere Möglichkeit zum Filtern einer Liste mit Datensätzen in der Tabelle besteht darin, einen Abfrageausdruck zu erstellen.

Zum Erstellen einer neuen Definitionsabfrage führen Sie die folgenden Schritte aus:

  1. Doppelklicken Sie im Bereich Inhalt auf eine Standalone-Tabelle, um das Dialogfeld Tabelleneigenschaften zu öffnen.
  2. Klicken Sie alternativ im Bereich Inhalt mit der rechten Maustaste auf einen Feature-Layer, und klicken Sie dann auf Eigenschaften, Eigenschaften um das Dialogfeld Layer-Eigenschaften zu öffnen.
  3. Klicken Sie im Dialogfeld Eigenschaften auf die Seite Definitionsabfrage.
  4. Klicken Sie auf Klausel hinzufügen.
  5. Erstellen Sie einen Ausdruck, mit dem die Untermenge der anzuzeigenden Datensätzen und Features festgelegt wird.
  6. Klicken Sie auf Hinzufügen, um den Ausdruck hinzuzufügen. Klicken Sie auf OK, um das Dialogfeld zu schließen.

Weitere Informationen zum Erstellen von gültigen Abfragen finden Sie unter Erstellen einer Abfrage im Abfrage-Manager.

Zum Entfernen einer Definitionsabfrage wählen Sie den entsprechenden Layer oder die entsprechende Standalone-Tabelle im Bereich Inhalt aus. Ändern Sie auf der Registerkarte Daten in der Gruppe Definitionsabfrage die Einstellung der Dropdown-Liste in <Keine>.

Tipp:

Wenn ein Layer oder eine Standalone-Tabelle im Bereich Inhalt ausgewählt ist, können Sie alternativ auch eine Definitionsabfrage über die Multifunktionsleiste starten. Klicken Sie auf der Registerkarte Daten in der Gruppe Definitionsabfrage auf das Startprogramm für das Dialogfeld Startprogramm.

Verknüpfen übereinstimmender Datensätze

Wenn Sie Tabellen miteinander verbinden, können Sie festlegen, dass nur die übereinstimmenden Datensätze angezeigt werden. Entfernen Sie dazu das Kontrollkästchen für Alle Ziel-Features beibehalten im Werkzeug Verbindung hinzufügen.

Wenn ein Datensatz der Zieltabelle keine Entsprechung in der Join-Tabelle besitzt, wird dieser Datensatz aus der erstellten Zieltabelle entfernt. Wenn die Zieltabelle der Attributtabelle eines Layers entspricht, werden Features, die keine verbundenen Daten aufweisen, nicht auf der Karte angezeigt.

Beispiel für das ausschließliche Beibehalten von passenden Datensätzen beim Verbinden

Hinweis:

Wenn auf die Join-Tabelle oder die Zieltabelle eine Definitionsabfrage angewendet wird, wird die Definitionsabfrage von der resultierenden Zieltabelle berücksichtigt.

Filtern nach Kartenzeit

Enthält Ihre Karte zeitbezogene Layer, filtert die Tabelle Datensätze in Abhängigkeit von der aktuellen Kartenzeit heraus. Wenn Sie den Zeitschieberegler in der Kartenansicht schrittweise durchlaufen bzw. die Wiedergabe über ihn starten, werden nur die Datensätze in der Tabelle angezeigt, die in die aktuelle Zeitspanne fallen. Standardmäßig ist der Filter bei aktivierter Zeit in der Karte aktiviert. Wenn Sie alle Datensätze der Tabelle anzeigen möchten, können Sie die Option Nach Zeit filtern Kartenzeit im unteren Bereich der Tabellensicht deaktivieren. Sie können die Filteroptionen auch über die Registerkarte Tabelle, Registerkarte Ansicht, Gruppe Filter, aufrufen.

Filtern nach Kartenbereich

Enthält Ihre Karte bereichsbezogene Layer, filtert die Tabelle Datensätze in Abhängigkeit vom aktuellen Kartenbereich heraus. Wenn Sie den Bereichsschieberegler in der Kartenansicht schrittweise durchlaufen bzw. die Wiedergabe über ihn starten, werden nur die Datensätze in der Tabelle angezeigt, die in den aktuellen Bereich fallen. Standardmäßig ist der Filter bei aktiviertem Bereich in der Karte aktiviert. Wenn Sie alle Datensätze der Tabelle anzeigen möchten, können Sie die Option Nach Bereich filtern Kartenbereich im unteren Bereich der Tabellensicht deaktivieren. Sie können die Filteroptionen auch über die Registerkarte Tabelle, Registerkarte Ansicht, Gruppe Filter, aufrufen.

Hinweis:

Zeit- und Bereichsfilter können gleichzeitig verwendet werden. Wenn Ihre Karte sowohl zeit- als auch bereichsbezogen ist, dann wird die Tabelle Datensätze enthalten, auf die beide Filter angewendet wurden.

Filtern nach Kartenausdehnung

Die Filterung von Datensätzen der Tabelle anhand der aktuellen Kartenausdehnung ist nur in 2D-Ansichten möglich. Um für die Tabellenansicht nur die Datensätze herauszufiltern, die Features im sichtbaren geographischen Bereich der Karte entsprechen, klicken Sie im unteren Bereich der Tabelle in der Liste Filter auf Nach Ausdehnung filtern Nach Ausdehnung filtern. Klicken Sie optional auf der Registerkarte Tabelle, Registerkarte Ansicht, Gruppe Filter, auf Ausdehnung Nach Ausdehnung filtern. Während Sie die Karte auf verschiedene Ausdehnungen schwenken und zoomen, werden die Tabellenzeilen entsprechend aktualisiert. Die Layer-Sichtbarkeit hat keinen Einfluss auf den Filter für die Ausdehnung. Die Datensätze der Tabelle werden entsprechend der Kartenausdehnung gefiltert, auch wenn die Layer-Sichtbarkeit im Bereich Inhalt deaktiviert oder durch eine Einstellung des Sichtbarkeitsbereichs unterdrückt ist.

So erkennen Sie, ob Ihre Tabellendaten gefiltert sind

Die Attributtabelle zeigt im unteren Teil des Tabellenfensters eine Liste mit Symbolen für Filterindikatoren für "Nach Bereich filtern" Kartenbereich, "Nach Zeit filtern" Kartenzeit, "Nach Ausdehnung filtern" Nach Ausdehnung filtern und "Sortierung" Benutzerdefinierte Sortierung an. Die Symbole sind je nach aktivem Filtervorgang automatisch aktiviert und ansonsten ausgegraut. Wenn Sie den Filterstatus deaktivieren und alle Datensätze in der Tabelle anzeigen möchten, klicken Sie auf ein Filtersymbol. Sie können die Filteroptionen nach Bereich, Zeit oder Ausdehnung auch über die Registerkarte Tabelle, Registerkarte Ansicht, Gruppe Filter steuern. Zum Entfernen jeglicher Sortierungen von Datensätzen klicken Sie mit der rechten Maustaste auf die Spaltenüberschrift und klicken auf Benutzerdefinierte Sortierung Benutzerdefinierte Sortierung. Klicken Sie im Fenster Benutzerdefinierte Sortierung auf Löschen.

Die nachfolgende Abbildung zeigt die Indikator-Symbole für gefilterte oder sortierte Tabellen.

Tabelle wird gefiltert

Verwandte Themen