Skip To Content

Verwalten der Schema-Layer-Definition für Ihre Vorlagen

Eine Schemavorlage verfügt über Konfigurationseigenschaften zum Definieren der in Schemas zulässigen Netzwerk-Features (Schemaregeln und Layout-Definition) und der Darstellung (Schema-Layer-Definition) der erstellten Netzwerkschemas.

Dieses Thema konzentriert sich auf die Schema-Layer-Definition und erläutert, wie sie für eine Vorlage eingerichtet werden muss.

Hinweis:

Die Bearbeitung einer Schemavorlagen-Layer-Definition ist ein Verwaltungs- und Konfigurationsvorgang, der vom Datenbankbesitzer des Versorgungsnetzes über eine direkte Verbindung mit der Default-Version durchgeführt werden muss.

Zusätzlich zu diesen Anforderungen muss das mit dem ArcGIS Enterprise-Portal verbundene Konto der Besitzer des Versorgungsnetzes sein, damit dieser Vorgang ausgeführt werden kann. Dies bildet im Grunde eine Zwei-Faktor-Authentifizierung.

Netzwerkschema-Layer und Schema-Layer-Definition

In ArcGIS Pro werden alle neu erstellten Netzwerkschemas in einer Kartenansicht angezeigt. Dies geschieht durch einen Netzwerkschema-Layer, bei dem es sich um eine besondere Art von Verbund-Layer handelt. Diese werden im folgenden Screenshot mit den Nummern 1 und 2 dargestellt:

Schemakarte, Netzwerkschema-Layer und dessen Sublayer

Netzwerkschema-Layer können nur bei geöffneter Kartenansicht aufgerufen werden.

Die meisten Aspekte der einzelnen Sublayer unter einem Netzwerkschema-Layer (Nummer 3 in der Abbildung oben) lassen sich wie bei jedem anderen Layer über die Befehle auf dem Menüband, über die Registerkarte Feature-Layer und das Dialogfeld Layer-Eigenschaften steuern.

Sie können Layer-Eigenschaften für jedes geöffnete Netzwerkschema in Ihrem Projekt festlegen. Jedes Schema kann Eigenschaften aufweisen, die sich von denen anderer Schemas im Projekt unterscheiden. Die Standardeigenschaften von Netzwerkschema-Layern werden in der Schemavorlage festgelegt. Dies erfolgt mithilfe der Geoverarbeitungswerkzeuge Schema-Layer-Definition erstellen oder Schemavorlagendefinitionen exportieren. Diese Werkzeuge zeigen alle auf einer Schemavorlagenanzeige basierenden Netzwerkschemas standardmäßig auf dieselbe Weise an. Die Standardeinstellung sieht die Verwendung der Eigenschaften des Netzwerkschema-Layers vor, die die Schema-Layer-Definition für die Vorlage bilden.

Netzwerkschema-Layer

Netzwerkschema-Verbund-Layer

Wenn ein Netzwerkschema geöffnet wird, wird es standardmäßig in einem Netzwerkschema-Layer angezeigt. Der Netzwerkschema-Layer besteht aus den folgenden Elementen:

  • einem Layer für jede Versorgungsnetz-Quellklasse (Nr. 1 unten)
  • einem zusätzlichen Satz von Layern
    • Versorgungsnetzobjekten wie Systemknoten, Konnektivitätszuordnungen und strukturellen Anbauten (Nummer 2 unten)
    • in Schemapunkte transformierte Container-Polygon- oder Linien-Netzwerk-Features (Nummer 3 unten)
    • in Schema-Polygone transformierte Container-Punkt-Netzwerk-Features (Nummer 4 unten)
    • reinen Schema-Features wie Reduktionskanten (Nummer 5 unten)
Netzwerkschema-Layer und Sublayer

Dies gilt unabhängig davon, auf welcher Vorlage Ihr Schema basiert – d. h. eine von Ihnen erstellte Vorlage oder eine standardmäßig vom Versorgungsnetz bereitgestellte Vorlage – und bis die Schema-Layer-Definition für die Vorlage angepasst wird.

Netzwerkschema-Sublayer

Die in einem Netzwerkschema-Layer enthaltene Gruppe von Sublayern ist diesem Netzwerkschema-Layer wie folgt untergeordnet:

  • Deren Darstellungsreihenfolge wird zum Zeitpunkt ihrer Erstellung festgelegt.
  • Der Verweis auf die Quelldaten eines Netzwerkschemas wird vom System verwaltet. Jeder Sublayer bezieht sich auf eine interne Schemakante, einen Knoten oder eine Container-Feature-Class, die sich auf die Versorgungsnetz-Feature-Class bezieht, die sie darstellt.
  • Standardeigenschaften für die Sublayer, aus denen ein Netzwerkschema-Layer besteht, sind erst dann verfügbar, wenn auf der Vorlagenebene eine Schema-Layer-Definition vorhanden ist. Die Eigenschaften von Netzwerkschema-Layern werden durch Ausführung des Werkzeugs Schema-Layer-Definition erstellen oder Schemavorlagendefinitionen importieren importiert.

Schema-Sublayer unter einem Netzwerkschema-Layer können jedoch bei Bedarf entfernt werden.

Eigenschaften des Netzwerkschema-Layers

Bei den Eigenschaften des Netzwerkschema-Layers handelt es sich um eine Gruppe von Layer- und Beschriftungseigenschaften, die für jeden Sublayer festgelegt werden, die einen Netzwerkschema-Layer bilden. Die meisten Aspekte werden über die Registerkarte Feature-Layer oder die Einstellungen im Dialogfeld Layer-Eigenschaften gesteuert.

  • Auf der Registerkarte Feature-Layer wird Folgendes gesteuert:
    • Darstellung, Sichtbarkeit und Anzeigeeffekte der Netzwerkschema-Features über die Registerkarte Aussehen
    • Beschriftung der Netzwerkschema-Features über die Registerkarte Beschriftung
  • Im Dialogfeld Layer-Eigenschaften können Sie auf Folgendes zugreifen:
    • Layer-Name und Sichtbarkeitsbereichseinstellung auf der Registerkarte Allgemein
    • Auswahleinstellungen zum Darstellen von Netzwerkschema-Features, wenn deren Auswahl auf der Registerkarte Auswahl erfolgt
    • Abfragefilter, die auf der Registerkarte Definitionsabfrage festgelegt werden

Verwalten von Layer-Definitionen für eine Vorlage

Für die im Versorgungsnetz enthaltenen Schemavorlagen wird standardmäßig keine Layer-Definition initialisiert. Dies bedeutet, das jedes auf diesen Vorlagen basierende Schema mit einer grundlegenden Layer-Definition angezeigt wird, die beim Öffnen des Schemas dynamisch erstellt wird.

Die von Ihnen hinzugefügten Schemavorlagen werden mit einer festgelegten primären Standard-Layer-Definition erstellt.

In beiden Fällen werden die Netzwerkschemas unabhängig davon, ob ein Schema auf einer von Ihnen hinzugefügten oder standardmäßig vom Versorgungsnetz installierten Vorlage basiert, auf genau die gleiche Weise dargestellt, bis Sie eine Schema-Layer-Definition für die Vorlage initialisieren. Es wird Folgendes angezeigt:

  • Ein Layer, Systemknoten, ist für die Repräsentation der Systemknoten vorgesehen. Diese Netzwerkelemente werden niemals in Ihrer geographischen Karte dargestellt, werden jedoch möglicherweise im Schema sichtbar, wenn sie als Von- oder Nach-Knoten für eine Netzwerklinie vorhanden sind, die im Schema dargestellt wird.
  • Zwei Layer, Konnektivitätszuordnungen und Struktureller Anbau, sind für die Repräsentation der Konnektivitäts- und struktureller Anbauzuordnungen vorgesehen. Diese Zuordnungen werden möglicherweise als Kanten in Schemas dargestellt, wenn die Regel Konnektivitätszuordnungen hinzufügen oder die Regel Strukturelle Anbauten hinzufügen für die Schemavorlage konfiguriert ist.
  • Ein Layer, Reduktionskanten, stellt Schemakanten dar, die Netzwerkelementen entsprechen, die in Ihren Schemas reduziert werden können. Diese reduzierten Kanten können in Ihren Schemas erstellt werden, wenn Regeln zum Reduzieren von Knoten für die Schemavorlage konfiguriert sind.
  • Ein Layer für jedes Linien-Feature oder Container-Polygon-Feature des Netzwerks (z. B. eine Strukturgrenze), das als Punkt-Feature in Ihren Schemas transformiert werden kann. Diese Punktschema-Features können in Ihren Schemas erstellt werden, wenn die Regel Container ausblenden oder die Regel Kanten reduzieren für die Schemavorlage konfiguriert sind.
  • Für jedes Container-Punkt-Feature des Netzwerks kann ein Layer als Polygon-Feature in Ihren Schemas transformiert werden. Diese Polygon-Schema-Features können in Ihren Schemas erstellt werden, wenn Regeln zum Einblenden von Knoten für die Schemavorlage konfiguriert sind.

Die Schema-Layer-Definition kann in einem der folgenden Fälle auf Vorlagenebene initialisiert werden:

  • wenn Layer-Definitionen mit dem Werkzeug Schema-Layer-Definition erstellen erstellt werden
  • wenn eine Netzwerkschema-Layer-Definitionsdatei mit dem Werkzeug Schemavorlagendefinitionen importieren anhand einer für den Parameter Schema-Layer-Definitionsdatei festgelegten Schema-Layer-Definitionsdatei (.ndld) in die Vorlage importiert wird
  • wenn die Schemavorlage mit dem Werkzeug Schemavorlage hinzufügen und einer für den Parameter Schema-Layer-Definitionsdatei festgelegten Definitionsdatei für Netzwerkschema-Layer (.ndld) erstellt wird

Initialisieren der Schema-Layer-Definition für eine Vorlage

Verwenden Sie das Werkzeug Schema-Layer-Definition erstellen, um eine Schema-Layer-Definition in einer Vorlage zu initialisieren.

Dieses Werkzeug muss in ArcGIS Pro verwendet werden, da es einen Eingabe-Versorgungsnetz-Layer erfordert, der in einer aktiven Karte referenziert wird.

Es bereitet den Netzwerkschema-Verbund-Layer für alle auf der Eingabevorlage basierenden Schemas entsprechend den Layern in der aktiven Eingabekarte vor, sodass jedes Netzwerkschema mit folgenden Elementen angezeigt wird:

  • einem Sublayer für jeden Layer, der als Eingabe festgelegte Versorgungsnetz-Features in der aktiven Karte referenziert
  • je nach festgelegten Werkzeugeinstellungen einige oder keine der zusätzlichen Layer, die für die Darstellung reiner schematischer Feature-Darstellungen vorgesehenen sind

Wenn Sie nach der Ausführung des Werkzeugs Schema-Layer-Definition für eine Vorlage ein Schema basierend auf dieser Vorlage erstellen und die Schema-Sublayer mit denjenigen vergleichen, die sich in der als aktive Karte festgelegten Versorgungsnetzkarte befinden, werden Sie Folgendes feststellen:

  • Für jeden Layer ist ein Sublayer vorhanden, der Netzwerk-Features in dieser Versorgungsnetzkarte referenziert, und zwar mit genau denselben Einstellungen, d. h. die Layer- und Beschriftungseinstellungen, der Maßstab, die Sichtbarkeit, die Abfragefilter usw. sind identisch.
    Hinweis:

    Darüber hinaus werden diese Subtype-Gruppen-Layer unter dem Schema-Layer beibehalten, wenn Layer in der Versorgungsnetzkarte unter Subtype-Gruppen-Layern angeordnet werden. Dies gilt für die Subtype-Gruppen-Layer, die Sie mit dem Befehl Voreinstellung hinzufügen > Subtype-Gruppen-Layer auf der Registerkarte Karte festlegen, jedoch nicht für Standard-Gruppen-Layer. Für den Fall, dass die Layer in der Versorgungsnetzkarte unter Standard-Gruppen-Layern angeordnet sind, werden diese Gruppen im erstellten Netzwerkschema-Layer zusammengeführt. Unter einem Verbund-Layer ist kein Standardgruppen-Layer vorhanden, jeder Sublayer wird in diesem Fall auf derselben Ebene angezeigt.

  • Es gibt keine Sublayer zur Darstellung von Features, die nicht Teil des Versorgungsnetzes sind.
  • Die Reihenfolge der Sublayer unter dem Netzwerkschema-Layer spiegelt die Reihenfolge der Layer in der Versorgungsnetzkarte wider.

Ausgehend von den vorstehenden Ausführungen empfiehlt es sich, eine bestimmte Karte zu erstellen, die als Eingabe für das Werkzeug Schema-Layer-Definition erstellen verwendet wird. Da das Arbeiten mit Kartenservices, die eine große Anzahl von Layern referenzieren, sich auf die Performance auswirken kann, sollten Sie, wenn Sie den Zugriff auf die Netzwerkschemas über einen Kartenservice beabsichtigen, bei der Erstellung dieser spezifischen Karte die Netzwerk-Features berücksichtigen, die für die Schemavorlage von Bedeutung sind. Angenommen, für Ihre Vorlage wurden einige Regeln zum Entfernen von Features konfiguriert, um alle Features des Übertragungsnetzes zu verwerfen. In diesem Fall sollen sich keine Sublayer unter dem Netzwerkschema-Layer zur Darstellung von Übertragungsschema-Features befinden. Um zu verhindern, dass diese Sublayer erstellt werden, sollten Sie sicherstellen, dass in der als Eingabe für das Werkzeug Schema-Layer-Definition erstellen verwendeten Karte kein Layer vorhanden ist, der Übertragungs-Features referenziert.

Anhand der nachfolgenden Schritte wird die ordnungsgemäße Konfiguration dieser spezifischen Eingabekarte und die Einrichtung des Werkzeugs Schema-Layer-Definition zum Initialisieren der Schema-Layer-Definition für eine Vorlage veranschaulicht.

Voraussetzung:

  • Starten Sie ArcGIS Pro.
  • Melden Sie sich mit Ihren Anmeldeinformationen als Besitzer des Versorgungsnetzes bei Ihrem ArcGIS Enterprise-Portal an.
  • Laden Sie Ihr Projekt, oder erstellen Sie ein Projekt.
  • Fügen Sie der Standardverzweigung der Datenbank eine Verbindungsdatei hinzu, die das Versorgungsnetz referenziert, mit dem Sie arbeiten möchten, oder erstellen Sie eine neue. Stellen Sie außerdem sicher, dass Sie die Verbindung mit den Anmeldeinformationen des Besitzers für das Versorgungsnetz herstellen.

  1. Aktivieren Sie eine Karte, die Ihre Versorgungsnetzdaten über eine direkte Verbindung referenziert, und stellen Sie sicher, dass Sie auf die Default-Version verweisen. Sie können auch eine Karte erstellen, indem Sie einen der folgenden Schritte ausführen:
    • Um Schema-Layer-Definitionen für Ihre Vorlage unter Verwendung einfacher Layer für die Anzeige aller Netzwerkquellenklassen zu initialisieren, führen Sie die folgenden Schritte aus:
      1. Blenden Sie im Bereich Katalog auf der Registerkarte Projekt unter Datenbanken Ihre Datenbankverbindungsdatei ein, und klicken Sie mit der rechten Maustaste auf das Versorgungsnetz.
      2. Klicken Sie auf Zu einer neuen Karte hinzufügen.
      3. Wenn Sie aufgefordert werden, der Karte alle am Versorgungsnetz beteiligten Feature-Classes hinzuzufügen, klicken Sie auf Ja.
    • Führen Sie zum Initialisieren der Schema-Layer-Definitionen mit der Option Voreingestellte Subtype-Gruppen-Layer für die Anzeige aller Netzwerkquellenklassen die folgenden Schritte aus:
      1. Erstellen Sie eine Karte, und klicken Sie auf Ihre Vorlage.
      2. Klicken Sie auf der Registerkarte Karte auf Voreinstellung hinzufügen, und klicken Sie dann auf Subtype-Gruppen-Layer.
      3. Navigieren Sie zu Ihrer Datenbankverbindungsdatei, wählen Sie alle Netzwerkquellenklassen unter dem Netzwerk-Dataset aus, und klicken Sie auf OK.
      4. Blenden Sie im Bereich Katalog auf der Registerkarte Projekt unter Datenbanken Ihre Datenbankverbindungsdatei ein, und ziehen Sie das Versorgungsnetz in die aktive Karte.

    Hinweis:

    Sie können für einige Netzwerkquellenklassen auch einfache Layer kombinieren und für andere wiederum Subtype-Gruppen-Layer voreinstellen.

  2. Erstellen Sie eine Kopie der Karte.

    Diese Kopie wird mit dem Werkzeug Schema-Layer-Definition erstellen verwendet.

  3. Überprüfen Sie für alle Layer in dieser Karte, was die Layer oder Subtype-Layer darstellen, und entfernen Sie Layer oder Subtype-Layer, die für Ihre Schemavorlage nicht relevant sind. Wenn Ihre Vorlage beispielsweise für die Einblendung aller Container-Punkt-Features des Netzwerkes konfiguriert ist, entfernen Sie die Layer, die Punktverteilungs-Assemblys oder Strukturknoten darstellen.
  4. Berücksichtigen Sie für jeden in der Karte verbleibenden Layer die folgenden Optionen:
    1. Teilen Sie die Layer nach allen vorliegenden Filtern.
    2. Ändern Sie den Namen des Layers.
    3. Richten Sie die Darstellungseigenschaften des Layers ein.
    4. Richten Sie die Beschriftungseinstellungen des Layers ein.
    5. Definieren Sie den Sichtbarkeitsbereich des Layers.
    6. Ordnen Sie die Layer in der Karte neu an.
  5. Wenn für einen oder mehrere Layer in der Karte Abfragefilter festgelegt wurden, die bestimmte Netzwerk-Features ausblenden, entfernen Sie diese, damit sie in den erstellten Schemas dargestellt werden können. Gehen Sie dazu folgendermaßen vor:
    • Wenn diese Filter zum Ausblenden von Inhaltsnetzwerk-Features konfiguriert sind, klicken Sie auf den Dropdown-Pfeil Inhalt anzeigen in der Gruppe Zuordnungen auf der Registerkarte Versorgungsnetzdaten, und klicken Sie auf Anzeigen, um diese Filterung automatisch zu deaktivieren.
    • Wenn diese Filter für andere Zwecke konfiguriert sind, führen Sie die folgenden Schritte aus:
      1. Klicken Sie im Bereich Inhalt mit der rechten Maustaste auf den Layer, und klicken Sie auf Eigenschaften.
      2. Klicken Sie im angezeigten Dialogfeld Layer-Eigenschaften auf die Registerkarte Definitionsabfrage.
      3. Klicken Sie am unteren Rand der Registerkarte auf Ausdruck löschen, oder ändern Sie den Abfrageausdruck, um die Features zu filtern, die in Ihren Schemas angezeigt werden sollen.
      4. Klicken Sie auf OK.
  6. Suchen und laden Sie das Werkzeug Schema-Layer-Definition erstellen im Feld Suchen des Bereichs Geoverarbeitung.
  7. Klicken Sie auf den Dropdown-Pfeil neben dem Feld Eingabe-Versorgungsnetz, und wählen Sie den in der aktiven Karte referenzierten Versorgungsnetz-Layer aus.
  8. Wählen Sie aus der Liste Eingabe-Schemavorlage die Vorlage aus, für die Sie die Schema-Layer-Definition erstellen möchten.
  9. Blenden Sie den Abschnitt Zusätzliche Sublayer ein, und berücksichtigen Sie die folgenden Optionen:
    1. Deaktivieren Sie Systemknoten, wenn Sie sich sicher sind, dass keine Systemknoten in Ihren Schemas vorhanden sein sollen.
    2. Lassen Sie die Option Konnektivitätszuordnung aktiviert, wenn Ihre Vorlage für die Darstellung von Konnektivitätszuordnungen, d. h. für die Ausführung der Regel "Konnektivitätszuordnungen hinzufügen" bzw. der Regel "Verfolgung", konfiguriert ist.
    3. Lassen Sie die Option Strukturelle Anbauten ausgewählt, wenn Ihre Vorlage für die Darstellung struktureller Anbauzuordnungen, d. h. für die Ausführung der Regel "Strukturelle Anbauten hinzufügen", konfiguriert ist.
    4. Deaktivieren Sie die Option Reduktionskanten, wenn Ihre Vorlage nicht für die Ausführung von Regeln zum Reduzieren von Knoten konfiguriert ist.
    5. Identifizieren Sie in der Liste Einzubeziehende Punkte jeden Layer, der Container-Polygon-Netzwerk-Features darstellt. Wenn für Ihre Vorlage keine Regel zum Ausblenden von Containern konfiguriert wurde, um die zugehörigen Schema-Features auszublenden, entfernen Sie diesen Layer. Identifizieren Sie anschließend jeden Layer, der Linien-Netzwerk-Features darstellt. Wenn für Ihre Vorlage eine Regel zum Reduzieren von Kanten konfiguriert wurde, um die zugehörigen Schema-Features zu reduzieren, entfernen Sie diesen Layer.
    6. Identifizieren Sie unter der Liste Einzubeziehende Polygone jeden Layer, der Container-Punkt-Netzwerk-Features darstellt. Wenn für Ihre Vorlage keine Regel zum Einblenden von Containern konfiguriert wurde, um die zugehörigen Schema-Features einzublenden, sollten Sie diesen Layer entfernen.
    7. Aktivieren Sie für jeden Punkt- und Polygon-Layer, der in den Schritten e und f oben nicht entfernt wurde, die Option Subtype-Layer auf der rechten Seite, wenn der zugehörige Layer mit voreingestellten Subtype-Gruppen-Layern erstellt werden soll. Andernfalls verwendet der Layer eine einfache, nach Subtype kategorisierte Layer-Repräsentation.
  10. Klicken Sie auf Ausführen.

Um zu überprüfen, ob die Schema-Layer-Definition nach Ihren Wünschen initialisiert wurde, führen Sie die folgenden Schritte für die geänderte Vorlage aus:

  1. Wählen Sie eine Gruppe von Netzwerk-Features in der aktiven Karte aus.
  2. Erstellen Sie ein temporäres Schema basierend auf Ihrer Vorlage, und überprüfen Sie, ob die Schema-Sublayer genauso wie die Netzwerk-Features in der aktiven geographischen Karte angezeigt werden.

Wenn der Netzwerkschema-Layer ungeeignete Elemente aufweist, müssen Sie möglicherweise folgende Schritte ausführen:

  1. Initialisieren Sie die Schema-Layer-Definition für Ihre Vorlage neu, indem Sie die Schritte 3 bis 10 oben erneut ausführen. Dies beinhaltet die Optimierung der Layer in der Karte, die Sie in den Schritten 3 bis 5 erstellt haben, und anschließend die erneute Ausführung des Werkzeugs Schema-Layer-Definition erstellen für Ihre Vorlage anhand dieser Karte.
  2. Bearbeiten Sie die neu erstellten Netzwerkschema-Sublayer, und importieren Sie diese neuen Einstellungen als neue Schema-Layer-Definition für die Vorlage. Diese Schritte werden im nächsten Abschnitt näher beschrieben.

Wenn Sie mit dem Schema-Layer zufrieden sind, ist ein weiterer Vorgang erforderlich, damit die geänderte Schema-Vorlage im Versorgungsnetz-Service vollständig funktionsfähig ist. Dafür müssen Sie eine Verbindung mit ArcGIS Server Manager herstellen und diesen Service beenden und neu starten.

Optimieren der Schema-Layer-Definition für eine Vorlage

Um die aktuell für eine Vorlage eingerichtete Schema-Layer-Definition zu optimieren, beispielsweise zum Anpassen der Einstellungen für Sublayer, die zur reinen "schematischen" Feature-Darstellung dienen (Systemknoten, Reduktionskanten, Konnektivitätszuordnungen, strukturelle Anbauten usw.), oder zum Hinzufügen von Beschriftungen, müssen Sie in ArcGIS Pro zunächst über den Schema-Layer arbeiten, der auf Ihrer Vorlage basiert und mit einer direkten Verbindung mit der Datenbank erstellt wurde. Anschließend müssen Sie die Netzwerkschema-Sublayer bearbeiten und gewünschte Beschriftungen einrichten, bevor Sie diese Schema-Layer-Definition mit dem Werkzeug Schema-Layer-Definition exportieren exportieren. Dieses Werkzeug erstellt eine Ausgabe-Netzwerkschema-Layer-Definitionsdatei (.ndld). Dann können Sie das Werkzeug Schemavorlagendefinitionen importieren ausführen und dabei diese resultierende .ndld-Datei für den Parameter Schema-Layer-Definitionsdatei angeben.

Anhand der folgenden Schritte wird erläutert, wie Sie die für eine Vorlage eingerichtete Schema-Layer-Definition optimieren können:

Voraussetzung:

  • Starten Sie ArcGIS Pro.
  • Melden Sie sich mit Ihren Anmeldeinformationen als Besitzer des Versorgungsnetzes bei Ihrem ArcGIS Enterprise-Portal an.
  • Laden Sie Ihr Projekt, oder erstellen Sie ein Projekt.
  • Fügen Sie der Standardverzweigung der Datenbank eine Verbindungsdatei hinzu, die das Versorgungsnetz referenziert, mit dem Sie arbeiten möchten, oder erstellen Sie eine neue. Stellen Sie außerdem sicher, dass Sie die Verbindung mit den Anmeldeinformationen des Besitzers für das Versorgungsnetz herstellen.

  1. Aktivieren Sie eine Karte, die Ihre Versorgungsnetzdaten über eine direkte Verbindung referenziert, und stellen Sie sicher, dass Sie auf die Default-Version verweisen. Sie können auch eine Karte erstellen, wie nachfolgend beschrieben:
    1. Blenden Sie im Bereich Katalog auf der Registerkarte Projekt unter Datenbanken Ihre Datenbankverbindungsdatei ein.
    2. Klicken Sie mit der rechten Maustaste auf das Versorgungsnetz, und klicken Sie auf Zu einer neuen Karte hinzufügen.
    3. Klicken Sie auf Ja, wenn Sie dazu aufgefordert werden, der Karte alle am Versorgungsnetz beteiligten Feature-Classes hinzuzufügen.

Bearbeiten der Sublayer unter einem Netzwerkschema-Layer

Um Sublayer unter einem Netzwerkschema-Layer basierend auf Ihrer Vorlage zu bearbeiten, führen Sie die folgenden Schritte aus:

  1. Wählen Sie einige Netzwerk-Features in der aktiven Karte aus.
  2. Wählen Sie den Versorgungsnetz-Layer im Bereich Inhalt und auf der Registerkarte Utility Network aus, klicken Sie auf den Dropdown-Pfeil Neues Schema, und klicken Sie auf die Vorlage, anhand derer Sie die Layer-Definition optimieren möchten.

    Es wird ein Schemakarte mit einem neu erstellten Schema angezeigt.

  3. Berücksichtigen Sie im Bereich Inhalt jeden Sublayer unter dem Netzwerkschema-Layer, und wählen Sie die entsprechende Option aus:
    1. Entfernen Sie alle Sublayer oder Subtype-Gruppen-Layer, die für die Schemavorlage nicht relevant sind.
    2. Wenn Subtype-Gruppen-Layer verwendet werden, dann entfernen Sie alle Subtype-Layer, die sich auf Features beziehen, die in den Schemas nie dargestellt werden.
    3. Ändern Sie die Namen der nicht entfernten Sublayer.
    4. Richten Sie Darstellungseigenschaften für jeden gewünschten Sublayer ein.
    5. Richten Sie die Beschriftungseinstellungen ein, die Sie für die Sublayer erwarten.
    6. Definieren Sie den Sichtbarkeitsbereich der Sublayer.
    Vorsicht:

    Je mehr Layer unter einem Schema-Layer vorhanden sind, desto langsamer ist die Schema-Layer-Anzeige. Durch Entfernen aller Sublayer, Subtype-Gruppen-Layer oder Subtype-Layer, die für die Schemavorlage nicht relevant sind, lässt sich die Anzeige beschleunigen.

Exportieren der Schema-Layer-Definition aus dem Netzwerkschema-Layer

Führen Sie zum Exportieren der Schema-Layer-Definitionen, die aktuell für den von Ihnen bearbeiteten Netzwerkschema-Layer festgelegt sind, Schema-Layer-Definition exportieren aus, wie anhand der folgenden Schritte erläutert:

  1. Klicken Sie auf der Registerkarte Analyse auf Werkzeuge.
  2. Geben Sie in das Textfeld Suchen den Text Schema exportieren ein, und wählen Sie das Werkzeug Schema-Layer-Definition exportieren aus.
  3. Wählen Sie im Bereich Geoverarbeitung aus der Dropdown-Liste Eingabe-Netzwerkschema-Layer den Schema-Layer aus, der in der aktiven Schemakarte referenziert wird (der Schemakarte, deren Layer-Eigenschaften Sie im vorherigen Abschnitt geändert haben). Dies ist Temporäres Schema.
  4. Geben Sie die Ausgabedatei an. Navigieren Sie also zu einem Speicherort und wählen ihn aus. Geben Sie einen Namen für die zu erstellende Netzwerkschema-Layer-Datei ein, z. B. NewDiagramLayerDefinitions, und klicken Sie auf Speichern.
  5. Klicken Sie auf Ausführen.

    Eine Schema-Layer-Definitionsdatei (.ndld) wird im angegebenen Ausgabeverzeichnis erstellt.

Importieren der Schema-Layer-Definition in eine Vorlage

Um eine Schema-Layer-Definition in eine Vorlage zu importieren, führen Sie das Werkzeug Schemavorlagendefinitionen importieren aus, wie anhand der folgenden Schritte erläutert:

  1. Klicken Sie auf der Registerkarte Analyse auf Werkzeuge.
  2. Geben Sie in das Textfeld Suchen den Text Schema importieren ein, und wählen Sie das Werkzeug Schemavorlagendefinitionen importieren aus.
  3. Klicken Sie neben dem Feld Eingabe-Versorgungsnetz auf die Schaltfläche Durchsuchen, wechseln Sie zu Projekt\Datenbanken, wählen Sie Ihre Datenbankverbindungsdatei aus, und navigieren Sie zum Versorgungsnetz.
  4. Wählen Sie aus der Dropdown-Liste Eingabe-Schemavorlage die Vorlage aus, in die Sie die Schemavorlagendefinitionen importieren möchten.
  5. Klicken Sie neben dem Feld Schema-Layer-Definitionsdatei auf die Schaltfläche Durchsuchen, und navigieren Sie zur Schema-Layer-Definitionsdatei (.ndld), die mit dem Werkzeug Schema-Layer-Definition exportieren erstellt wurde, und wählen Sie sie aus.
  6. Klicken Sie auf Ausführen.

Vorsicht:

Damit die geänderte Schema-Vorlage im Versorgungsnetz-Service vollständig funktionsfähig ist, müssen Sie eine Verbindung mit ArcGIS Server Manager herstellen und diesen Service beenden und neu starten.