Skip To Content

Konfigurieren einer Feature-Vorlage

Im Dialogfeld Vorlageneigenschaften können Sie den Namen einer Feature-Vorlage, durchsuchbare Tags, die auf der Werkzeugpalette verfügbaren Werkzeuge und die Attributwerte, die auf neue Features angewendet werden, konfigurieren. Symbolisierung ist eine Eigenschaft des Feature-Layers.

Weitere Registerkarten werden unter den folgenden Bedingungen im Dialogfeld angezeigt:

  • Die Registerkarte Beziehung wird angezeigt, wenn eine Tabelle in der Karte vorhanden ist und die Tabelle in einer Beziehungsklasse als Ziel und die Feature-Class als Quelle dient. Sie können einer Feature-Vorlage eine oder mehrere Tabellenvorlagen für Komponenten hinzufügen.
  • Die Registerkarte Annotation wird angezeigt, wenn durch eine Feature-Vorlage Annotations-Features erstellt werden. Sie können die Standardtextzeichenfolge festlegen und formatieren sowie Attributwerte für den Subtype der Annotationsklasse und das Textsymbol angeben.

  • Die Registerkarte Bemaßung wird angezeigt, wenn durch eine Feature-Vorlage Bemaßungs-Features erstellt werden. Sie können den Textwert anpassen und Anzeigeeinstellungen für Bemaßungslinien und andere Symboleigenschaften überschreiben.

Für einen Layer können eine oder mehrere Feature-Vorlagen erstellt und mit unterschiedlichen Werkzeugen und Attributwerten konfiguriert werden. Wenn Sie einer aktiven Karte oder Szene neue Daten hinzufügen, wird automatisch für jeden neuen Layer eine Feature-Vorlage mit den Standardeinstellungen erstellt.

Schritte zum manuellen Erstellen einer Feature-Vorlage finden Sie unter Erstellen einer Feature-Vorlage.

Öffnen der Vorlageneigenschaften

Sie können das Dialogfeld Vorlageneigenschaften Eigenschaften im Bereich Vorlagen verwalten oder Features erstellen öffnen.

Vorlagen verwalten

Im Bereich Vorlagen verwalten werden alle Vorlagen aufgelistet, die für das Projekt definiert sind.

  1. Klicken Sie auf der Registerkarte Bearbeiten in der Gruppe Features auf das Startprogramm für das Dialogfeld Vorlagen verwalten Startprogramm.

    Der Bereich Vorlagen verwalten wird angezeigt.

  2. Blenden Sie in dem Bereich die Karte Kartenansicht und deren Layer ein.
  3. Klicken Sie auf den Layer für die Vorlage, die Sie konfigurieren möchten.

    Für den Layer definierte Feature-Vorlagen werden im Vorlagenfeld angezeigt.

  4. Klicken Sie im Vorlagenfeld auf die Gruppenvorlage.
  5. Klicken Sie auf der Werkzeugleiste auf Eigenschaften Eigenschaften.
    • Sie können auch mit der rechten Maustaste auf die Vorlage klicken und das Kontextmenü verwenden.

Features erstellen

Im Bereich Features erstellen werden alle für die aktuelle Karte definierten Vorlagen angezeigt.

  1. Klicken Sie auf der Registerkarte Bearbeiten in der Gruppe Features auf Erstellen Features erstellen.

    Der Bereich Features erstellen wird angezeigt.

  2. Klicken Sie in dem Bereich mit der rechten Maustaste auf eine Gruppenvorlage und dann auf Eigenschaften Eigenschaften.
    • Sie können auch auf den Vorwärtspfeil Weiter und auf die Menüschaltfläche Menü klicken.

Konfigurieren der Werkzeugpalette

Klicken Sie auf die Registerkarte Werkzeuge, um ein Standardwerkzeug festzulegen und die Konstruktionswerkzeuge zu aktivieren, die auf der Werkzeugpalette zur Verfügung stehen sollen.

  1. Klicken Sie im Dialogfeld Vorlageneigenschaften auf Werkzeuge.
  2. Klicken Sie auf Klicken Sie hier, um das Werkzeug als Standardwerkzeug festzulegen, um das Werkzeug zu aktivieren, das bei Auswahl der Vorlage automatisch ausgeführt werden soll.
  3. Aktivieren Sie das Kontrollkästchen Werkzeug ein-/ausblenden, und aktivieren Sie die Konstruktionswerkzeuge, die auf der Werkzeugpalette zur Verfügung stehen sollen.

Festlegen von Attributwerten

Klicken Sie auf die Registerkarte Attribute, um die Attributwerte festzulegen, die auf die mit der Vorlage erstellten Features angewendet werden sollen.

Hinweis:

Diese Registerkarte ist für Annotations- oder Bemaßungs-Feature-Vorlagen nicht verfügbar.

  1. Klicken Sie im Dialogfeld Vorlageneigenschaften auf Attribute.
  2. Um alle versteckten Attributfelder anzuzeigen, aktivieren Sie die Option Nicht sichtbare Felder anzeigen.
  3. Geben Sie in der Feature-Attributtabelle die Attributwerte ein, die auf die neuen Features angewendet werden sollen.
    • Für Attribute, die den Layer mit codierten Domänenwerten symbolisieren, können Sie auf Alle Werte hinzufügen Alle Werte hinzufügen klicken und eine Symbolklasse auswählen, wenn der Layer mit einem Einzelwert-Renderer symbolisiert wird.
  4. Neben jedem Attributwert können Sie Eingabeaufforderung für Attributwert aktivieren und das Feld im Bereich Features erstellen unter der Werkzeugpalette anzeigen.
    Hinweis:

    Diese Einstellung kann einen Workflow vereinfachen, da Sie andernfalls auf den Vorwärtspfeil Aktive Vorlage Weiter klicken und einen erforderlichen Attributwert eingeben müssen.

  5. Klicken Sie auf OK.

    Ihre Einstellungen werden gespeichert und das Dialogfeld wird geschlossen.

Farbcodes für Felder

Felder mit einem bestimmten Zweck oder einer bestimmten Funktion werden farblich hervorgehoben. Die Farbcodes werden in der folgenden Tabelle beschrieben:

FeldfarbeBeschreibung

Orange

Subtype-Feld

Violett

Symbolisiert den Layer.

Gelb

Die Eigenschaft "Hervorheben" ist in der Attributtabelle aktiviert.

Attributfeld-Farbcodes

Hinzufügen einer Tabellenvorlage

Klicken Sie auf die Registerkarte Beziehung, um eine oder mehrere Tabellenvorlagen für Komponenten hinzuzufügen. Bei jeder Erstellung eines neuen Features wird der von der Tabellenvorlage definierten zugehörigen Tabelle mit Attributwerten automatisch ein Datensatz durch die Feature-Vorlage hinzugefügt.

Hinweis:

Diese Registerkarte ist nur verfügbar, wenn die Karte eine Tabelle enthält und die Tabelle einer Beziehungsklasse als Ziel angehört, während die Feature-Class der Ursprung ist.

Tabellenvorlagen können einen Workflow vereinfachen, da Sie anderenfalls jedes Mal, wenn Sie ein neues Feature mit zugehörigen Datensätzen in anderen Tabellen erstellen, auf die Option Neue zur Beziehung hinzufügen Beziehungen im Bereich Attribute klicken müssen.

Schritte zum Erstellen einer Tabellenvorlage finden Sie unter Erstellen einer Tabellenvorlage.

  1. Klicken Sie im Dialogfeld Vorlageneigenschaften auf Beziehungen.

    Tabellen in der Karte werden angezeigt, wenn die Tabelle und die von der Feature-Vorlage referenzierte Feature-Class Teil einer Beziehungsklasse sind.

  2. Klicken Sie auf Hinzufügen Hinzufügen und dann auf den Dropdown-Pfeil. Wählen Sie eine Tabellenvorlage aus, und klicken Sie auf Hinzufügen.
    • Um die Vorlage zu entfernen, zeigen Sie mit der Maus auf den Namen der Vorlage, und klicken Sie auf Löschen Löschen.
    • Um die Vorlage zu ersetzen, zeigen Sie mit der Maus auf den Namen der Vorlage, klicken Sie auf Bearbeiten Editierbar, wählen Sie eine andere Tabellenvorlage aus, und klicken Sie auf Übernehmen.

    Wenn in dem Projekt nur eine Tabellenvorlage für die Feature-Class und die zugehörige Tabelle vorhanden ist, wird diese der Vorlage automatisch hinzugefügt.

  3. Klicken Sie auf OK.

    Ihre Einstellungen werden gespeichert und das Dialogfeld wird geschlossen.

Konfigurieren von Annotationseigenschaften

Klicken Sie auf die Registerkarte Annotation, um die Standardtextzeichenfolge festzulegen und zu formatieren sowie Attributwerte für den Subtype der Annotationsklasse und das Textsymbol anzugeben.

Weitere Informationen finden Sie unter Verwalten der Eigenschaften einer Annotations-Feature-Class.

Hinweis:

Diese Registerkarte ist nur bei Annotations-Feature-Vorlagen verfügbar.

  1. Klicken Sie im Dialogfeld Vorlageneigenschaften auf Annotation.
  2. Geben Sie im Textfeld die Standardtextzeichenfolge ein, die auf neue Annotations-Features angewendet werden soll.
  3. Klicken Sie auf die Formatierungswerkzeuge, um die Schriftart, den Schriftschnitt und die Größe des Textes zu ändern.
  4. Legen Sie die Annotation-Feature-Class und das Symbol fest. Wenn die Annotation-Feature-Class mehr als eine Annotationsklasse enthält, werden die Annotationsklassen als Subtypes angezeigt.
    1. Klicken Sie auf das Feld AnnotationClassID, und legen Sie den Subtype der Annotationsklasse fest.
    2. Klicken Sie auf das Feld SymbolID, und legen Sie die Symbolnummer fest.
    3. Neben jedem Feld können Sie Eingabeaufforderung für Attributwert aktivieren und das Feld im Bereich Features erstellen unter der Werkzeugpalette anzeigen.
  5. Klicken Sie auf OK.

    Ihre Einstellungen werden gespeichert und das Dialogfeld wird geschlossen.

Konfigurieren von Bemaßungseigenschaften

Klicken Sie auf die Registerkarte Bemaßung, um Style-Einstellungen zu speichern und beizubehalten. Sie können den Textwert und dessen Winkelausrichtung anpassen. Um die Anzeigeeinstellungen für Bemaßungslinien und andere Symboleigenschaften zu überschreiben, klicken Sie auf das entsprechende Steuerelement.

Weitere Informationen finden Sie unter Ändern einer Bemaßung.

Hinweis:

Diese Registerkarte ist nur bei Bemaßungs-Feature-Vorlagen verfügbar.

  1. Klicken Sie im Dialogfeld Vorlageneigenschaften auf Bemaßung.
  2. Führen Sie einen oder mehrere der folgenden Vorgänge aus, um die Bemaßung anzupassen:
    • Blenden Sie Text ein, um den Textwert, den Ausrichtungswinkel oder die Platzierung zu ändern oder wiederherzustellen.
    • Blenden Sie Bemaßungslinien ein, um Bemaßungslinien darzustellen oder auszublenden oder die Symbolisierung der Pfeilspitzen zu ändern.
    • Blenden Sie Erweiterungslinien ein, um die Bemaßungslinie zu ändern und Erweiterungslinien darzustellen oder auszublenden.
  3. Klicken Sie auf OK.

    Ihre Einstellungen werden gespeichert und das Dialogfeld wird geschlossen.