Skip To Content

Erstellen von spiralförmigen Kurven

Die Konstruktionswerkzeuge für Linien-Features im Bereich Features erstellen umfassen Konstruktionsmethoden zur Erstellung von spiralförmigen Kurven als verdichtete Polylinien. Das Dialogfeld ist auf der Konstruktionswerkzeugleiste und im Kontextmenü verfügbar, wenn Sie ein Feature erstellen.

Eine spiralförmige Kurve ist eine Kurve mit einem festen Startpunkt und einem Radius, der sich proportional zu seinem Abstand auf dem Bogen vom Startpunkt ändert, wenn er zunimmt oder abnimmt. Die Geometrie wird mit einer Anfangspeilung, einem Startradius, einem Endradius und einer Bogenlänge oder einem Delta-Winkel definiert.

Spiralförmige Kurven werden häufig im Straßen- und Eisenbahnbau verwendet, um den sicheren Übergang von sich bewegenden Fahrzeugen in oder aus einem Kreisweg oder einer geraden Linie zu gewährleisten.

Hinweis:

Ist Gelände zu Grid Gelände-zu-Grid-Korrektur aktiviert, werden die eingegebenen Richtungswerte für die resultierende Geometrie gedreht, und die Werte für Radius und Bogenlänge werden skaliert.

Weitere Informationen finden Sie unter Aktivieren oder Deaktivieren von "Gelände zu Grid".

  1. Wenn die aktuelle Karte keinen Polylinien-Feature-Layer enthält, fügen Sie ihn hinzu.
    1. Klicken Sie auf der Registerkarte Ansicht auf den Bereich Katalog Bereich "Katalog", und erweitern Sie Datenbanken Datenbanken.
    2. Erweitern Sie die Standarddatenbank oder die Datenbank, die Ihre Daten enthält.

      Klicken Sie zum Erstellen einer Polygon-Feature-Class mit der rechten Maustaste auf die Datenbank, klicken Sie auf Neu und dann auf Feature-Class.

    3. Ziehen Sie die Feature-Class auf die Karte.

      Eine Feature-Vorlage mit Standardeinstellungen wird automatisch für den neuen Layer generiert.

  2. Wenn Sie Linien-Features erstellen, für die die Eingabewerte mit dem Feature in COGO-Attributfeldern gespeichert werden müssen, machen Sie die Linien-Features COGO-fähig.

    COGO-fähige Linien-Feature-Classes zeichnen mithilfe der COGO-Symbolisierung und enthalten einen Beschriftungsausdruck, der jede Linie mit ihrer COGO-Bemaßung, sofern vorhanden, beschriftet.

    Weitere Informationen finden Sie unter COGO aktivieren.

  3. Wenn Sie mit Z-aktivierten Features arbeiten, wählen Sie auf der Registerkarte Bearbeiten in der Gruppe Höhe aus, wie Z-Werte zu Features hinzugefügt werden sollen.

    Die Schritte zum Hinzufügen von Z-Werten beim Erstellen von Z-aktivierten Features finden Sie unter Festlegen einer Höhe für 3D-Features.

  4. Legen auf der Registerkarte Bearbeiten die Voreinstellungen für das Fangen fest, und öffnen Sie den Bereich Features erstellen.
    1. Aktivieren Sie in der Gruppe Fangen die Fangeinstellungen.
      Tipp:

      Um die Funktion "Fangen" vorübergehend zu deaktivieren, halten Sie beim Zeichnen eines Features die Leertaste gedrückt.

    2. Klicken Sie in der Gruppe Features auf Erstellen Features erstellen.
  5. Wählen Sie im Bereich eine Linien-Feature-Vorlage aus, und konfigurieren Sie das Konstruktionswerkzeug.
    1. Klicken Sie auf eine Linien-Feature-Vorlage, und klicken Sie auf die Schaltfläche Aktive Vorlage Weiter.
    2. Klicken Sie auf 2-Punkt-Linie 2-Punkt-Linie.
    3. Aktivieren Sie 2-Punkt-Linien weiterführen, um 2-Punkt-Linien-Features zu erstellen, die miteinander verbunden sind.

      Wenn Sie kontinuierliche Linien-Features mit zwei Punkten erstellen, wird eine Spirale als Feature erstellt, und es erfolgt eine Aktualisierung der COGO-Attribute. Wenn Sie das Konstruktionswerkzeug "2-Punkt-Linie" nicht verwenden, wird die Spirale als Segmente angelegt, und die COGO-Attribute werden nicht aktualisiert.

      Kontinuierliche Linien-Features mit zwei Punkten erzeugen automatisch den ersten Stützpunkt an den Koordinaten des letzten Stützpunktes des zuvor erstellten 2-Punkt-Linien-Features.

    Die Werkzeugleiste "Konstruktion" wird im unteren Bereich der Karte angezeigt.

    Konstruktionswerkzeugleiste
  6. Klicken Sie auf die Karte oder den Endpunkt einer vorhandenen Linie oder eines vorhandenen Bogens, an der bzw. an dem die spiralförmige Kurve starten soll.
  7. Klicken Sie mit der rechten Maustaste, und klicken Sie auf Spiralförmige Kurve.

    Die Vorschau dreht sich in die berechnete Tangenten-Richtung, und das Dialogfeld wird angezeigt.

  8. Geben Sie die Anfangspeilung als Tangenten-Richtung oder Sehnenrichtung an.
  9. Geben Sie den Startradius mit einer der folgenden Methoden an:
    • Wenn Sie von einer Kreisbogentangente starten, geben Sie den Radiuswert an.
    • Wenn Sie von einer geradlinigen Tangente starten, drücken Sie die ENTF-Taste, um den Radiuswert zu löschen und den Parameter auf INFINITY festzulegen.
  10. Geben Sie den Endradius mit einer der folgenden Methoden an:
    • Wenn Sie mit einer Kreisbogen-Tangente enden, geben Sie den Radiuswert an.
    • Wenn Sie mit einer geradlinigen Tangente enden, drücken Sie die ENTF-Taste, um den Radiuswert zu löschen und den Parameter auf INFINITY festzulegen.

    Hinweis:
    Die Angabe gleicher Start- und Endradien erzeugt einen Kreisbogen, der nicht verdichtet ist.

  11. Geben Sie die Länge der Spirale als Bogenlänge oder Delta-Winkel an.
  12. Um die Ausrichtung der Kreisbogen-Vorschau und der resultierenden Skizze umzukehren, klicken Sie auf Links oder Rechts.
  13. Klicken Sie auf den Dropdown-Pfeil Verdichten mit, und geben Sie an, wie Sie die Spirale verdichten möchten.
    • Abweichung: Erstellt Segmente mit unterschiedlichen Längen, die innerhalb der angegebenen maximalen Entfernung von einer echten Kurve abweichen.
    • Winkel: Erstellt Segmente, die den angegebenen Winkel nicht überschreiten. Die Länge der Liniensegmente nimmt mit zunehmender Krümmung ab.
    • Länge: Erstellt Segmente, die die angegebene Länge nicht überschreiten.
  14. Drücken Sie die EINGABETASTE, um das Dialogfeld zu schließen und die spiralförmige Kurve zu erstellen.

In diesem Thema