Skip To Content

Bearbeiten von Feature-Attributen

Sie können im Bereich Attribute Attribute auf der Registerkarte Attribute Features identifizieren und Attribute bearbeiten, die in einer Feature-Attributtabelle oder zugehörigen Tabelle gespeichert sind. Die Registerkarte Geometrie bietet schnellen Zugriff auf Editierwerkzeuge zum Verschieben fertiggestellter Features und Bearbeiten von Stützpunkten.

Durch Attributregeln verwaltete Felder beschränken Ihre Änderungen auf Werte, die durch die Regel definiert sind. Wenn Ihre Änderungen gegen eine Regel verstoßen, wird im Bereich eine Benachrichtigung angezeigt, dass die Regel die Änderungen nicht zulässt.

Weitere Informationen finden Sie unter Überblick über Attributregeln.

Bearbeiten von Attributen und zugehörigen Datensätzen

Beim Bearbeiten von Feature-Attributen im Bereich "Attribute" können Sie Features auf mehreren Layern auswählen und bearbeiten, ohne die Attributtabelle zu öffnen. Sie können den Bereich entweder so festlegen, dass Ihre Änderungen bei der Eingabe automatisch übernommen werden, oder so festlegen, dass gewartet wird, bis Sie die Übernahme durch einen Klick bestätigen.

Informationen zum Bearbeiten von Attributen in der Attributtabelle finden Sie unter Öffnen von Tabellendaten.

  1. Klicken Sie auf der Registerkarte Bearbeiten in der Gruppe Auswahl auf Attribute Attribute.

    Der Bereich Attribute wird angezeigt.

    Registerkarte "Attribute"
  2. Klicken Sie auf Auswählen Selektieren, und wählen Sie das Feature aus.

    Im Bereich wird die Auswahlliste angezeigt.

  3. Klicken Sie auf die Registerkarte Attribute.
  4. Blenden Sie die Auswahlliste ein, und klicken Sie auf das Feature, das Sie bearbeiten möchten.
    1. Um ein Feld zu bearbeiten, das mehreren Features gemeinsam ist, halten Sie die STRG-Taste gedrückt, während Sie auf Elemente in der Liste klicken.
    2. Wenn neben einem Element in der Liste ein Warnsymbol Warnung angezeigt wird, können Sie mit der rechten Maustaste auf das Element klicken und dann auf Zur Karte hinzufügen Option "Daten hinzufügen" klicken, um es der Karte hinzuzufügen.
  5. Klicken Sie auf das Feld, das Sie bearbeiten möchten, und ändern Sie den Wert.

    Wenn Automatisch zuweisen deaktiviert ist, werden bearbeitete Felder mit einem vertikalen grünen Balken auf der linken Seite des Feldnamens hervorgehoben, bis Sie auf Übernehmen klicken.

  6. Übernehmen Sie die Änderungen mit einer der folgenden Methoden:
    • Wenn Automatisch zuweisen deaktiviert ist, klicken Sie auf Übernehmen.
    • Wenn Automatisch zuweisen aktiviert ist, drücken Sie die Eingabetaste.

Farbcodes für Felder

Felder mit einem bestimmten Zweck oder einer bestimmten Funktion werden farblich hervorgehoben. Die Farbcodes werden in der folgenden Tabelle beschrieben:

FeldfarbeBeschreibung

Orange

Subtype-Feld

Violett

Symbolisiert den Layer.

Gelb

Die Eigenschaft "Hervorheben" ist in der Attributtabelle aktiviert.

Attributfeld-Farbcodes

Kopieren und Einfügen von Attributen

Wenn Sie mehrere Features auswählen, können Sie mit der rechten Maustaste auf Features in der Auswahlliste klicken und mithilfe des Kontextmenüs Attributwerte zwischen Features kopieren und einfügen. Mit den Feldzuordnungseinstellungen lässt sich festlegen, wie Attributwerte zwischen Features kopiert werden.

Informationen über die Schritte zum Übertragen von Attributen zwischen Features durch Klicken auf das Quell- und Ziel-Feature finden Sie unter Übertragen von Attributen zwischen Features.

  1. Klicken Sie auf der Registerkarte Bearbeiten in der Gruppe Auswahl auf Attribute Attribute.

    Der Bereich Attribute wird angezeigt.

  2. Klicken Sie auf Auswählen Selektieren, und wählen Sie die Features aus.

    Im Bereich wird die Auswahlliste angezeigt.

  3. Klicken Sie auf die Registerkarte Attribute.
  4. Blenden Sie die Auswahlliste ein, klicken Sie mit der rechten Maustaste auf das Feature, das die zu kopierenden Attribute enthält, und klicken Sie auf Attribute kopieren Kopieren.

    Die Attributwerte werden in die Zwischenablage kopiert.

  5. Klicken Sie in der Auswahlliste mit der rechten Maustaste auf das Feature, in das Sie die Attribute kopieren möchten, und klicken Sie auf Attribute einfügen Einfügen.
  6. Wenn Automatisch zuweisen deaktiviert ist, klicken Sie auf Übernehmen.

Bearbeiten von Gruppenattributwerten

Gruppenattributwerte werden in Form von verschiedenen Optionen in einer Dropdown-Liste für ein bestimmtes Feld angezeigt. Der Inhalt einer Dropdown-Liste basiert auf mindestens einem Feld in der ausgewählten Feature-Class oder Tabelle, das als Lookup-Feld dient.

So kann beispielsweise der aktuelle Name im Namensfeld einer Stadt bestimmen, welche Postleitzahlen in der Dropdown-Liste angezeigt werden, wenn Sie in das Feld für Postleitzahlen klicken. Das Ganze kann insofern erweitert werden, als dass weitere zugehörige Felder einbezogen werden, mit denen sichergestellt wird, dass über mehrere Felder verteilt nur gültige Attributwerte eingegeben werden.

Beteiligte Felder und die zugehörigen Gruppenwerte werden auf der Tabellenebene der Quelldaten als Feldgruppe definiert. Mit einer Feldgruppe wird angegeben, inwiefern ein Wert in einem Feld die Liste der gültigen Optionen für andere Felder bestimmt.

Weitere Informationen finden Sie unter Gruppenwerte.

Tipp:

Um die Liste mit Gruppenwerten zu ändern, öffnen Sie die Attributtabelle und klicken im Menüband auf die Registerkarte Daten. Klicken Sie in der Gruppe Design auf Gruppenwerte Gruppenwerte.

  1. Klicken Sie auf der Registerkarte Bearbeiten in der Gruppe Auswahl auf Attribute Attribute.

    Der Bereich Attribute wird angezeigt.

    Bereich "Attribute", "Gruppenwerte"
  2. Klicken Sie auf Auswählen Selektieren, und wählen Sie das Feature aus.

    Im Bereich wird die Auswahlliste angezeigt.

  3. Klicken Sie auf die Registerkarte Attribute.
  4. Vergewissern Sie sich, dass Automatisch zuweisen deaktiviert ist.
  5. Blenden Sie die Auswahlliste ein, und klicken Sie auf das Feature, das Sie bearbeiten möchten.
  6. Klicken Sie auf den Dropdown-Pfeil für das Attributfeld, das Sie bearbeiten möchten.

    In der Liste werden standardmäßig alle gültigen Optionen für das Feld basierend auf dem Wert des übergeordneten Feldes angezeigt.

    Hinweis:

    Es hat sich bewährt, am logischen Anfang der Feldgruppe zu beginnen und sich von den Dropdown-Listen zu den gültigen Werten führen zu lassen. Außer Kraft gesetzte Werte werden ausgegraut angezeigt und können nicht ausgewählt werden.

  7. In der Dropdown-Liste können Sie auf die folgenden Steuerelemente klicken und Ihre Auswahl erkunden:
    • Teilübereinstimmungen: Wenn Sie mit der Maus auf dieses Steuerelement zeigen, wird ein Pullout-Menü mit allen für die Feldgruppe definierten Werten angezeigt. Sie werden unter dem Feldnamen angezeigt, für den sie geeignete Auswahlmöglichkeiten darstellen. Für die Auswahl einer Teilübereinstimmung müssen möglicherweise weitere Felder bearbeitet werden, bis sich eine gültige Kombination aus Feldwerten ergibt.
    • Alle anzeigen: Zeigt alle für die Feldgruppe verfügbaren Attributwerte an. Dies kann nützlich sein, wen Sie Attributwerte über alle Felder verteilt ändern möchten. Dieses Steuerelement wird unten in der Dropdown-Liste angezeigt, wenn Sie auf Übereinstimmungen anzeigen klicken.
    • Übereinstimmungen anzeigen: Zeigt alle gültigen Optionen für das Feld basierend auf dem Wert des übergeordneten Feldes an. Dies ist die Standardeinstellung. Dieses Steuerelement wird oben in der Dropdown-Liste angezeigt, wenn Sie auf Alle anzeigen klicken.
  8. Klicken Sie in der Dropdown-Liste oder im Pullout-Menü auf den Attributwert, den Sie für das aktuelle Feld übernehmen möchten.
    Vorsicht:

    Bei Auswahl eines nicht übereinstimmenden Wertes wird keine gültige Kombination für die Feldgruppe festgelegt und im Bereich wird eine Benachrichtigung mit den Feldern angezeigt, die die Änderungen verhindern. In diesem Fall wird das Feld mit einem vertikalen gelben Balken auf der linken Seite des Feldnamens hervorgehoben, bis Sie einen gültigen Wert ausgewählt haben.

  9. Klicken Sie auf Übernehmen, um die Änderungen anzuwenden.