Skip To Content

Hinzufügen oder Entfernen von Dateianlagen

Mit der Standard- oder Advanced-Lizenz verfügbar.

Klicken Sie im Bereich Attribute Attribute auf die Registerkarte Anlagen, um Dateianlagen hinzuzufügen, zu aktualisieren, zu öffnen oder zu entfernen. Wählen Sie zum Anzeigen der Registerkarte ein Feature aus, das eine Dateianlage enthält oder für die Speicherung von Anlagen aktiviert ist.

Dateianlagen sind Dateien, die in einer Anlagentabelle einer Geodatabase-Feature-Class gespeichert und mit einzelnen Features verknüpft sind. Mit ihnen können Sie nichtgeographische Daten mit geographischen Informationen verknüpfen.

Alternativ können Sie auch Geoverarbeitungswerkzeuge verwenden. Weitere Informationen finden Sie unter Überblick über das Toolset "Anlagen".

Aktivieren von Anlagen

Standardmäßig können in Features keine Dateianlagen gespeichert werden. Um Dateianlagen zu aktivieren, führen Sie das Geoverarbeitungswerkzeug im Bereich "Geoverarbeitung" für die Quell-Feature-Class aus.

Weitere Informationen zu dem Geoverarbeitungswerkzeug finden Sie unter Aktivieren von Anlagen.

  1. Klicken Sie auf der Registerkarte Analyse in der Gruppe Geoverarbeitung auf Werkzeuge.

    Daraufhin wird der Bereich Geoverarbeitung angezeigt.

  2. Geben Sie in das Suchfeld Aktivieren ein, und klicken Sie auf Anlagen aktivieren.

    Anlagen aktivieren (Werkzeug)

  3. Klicken Sie auf den Dropdown-Pfeil Eingabe-Dataset, und wählen Sie die Quell-Feature-Class mit den Features aus, an die Sie Dateien anhängen möchten.Durchsuchen
  4. Klicken Sie auf Ausführen Ausführen.

Hinzufügen einer Anlage

Beim Hinzufügen einer Dateianlage wird ein Dateibrowser geöffnet, und die ausgewählten Dateien werden in die Anlagentabelle der Feature-Class kopiert.

  1. Klicken Sie auf der Registerkarte Bearbeiten in der Gruppe Auswahl auf Attribute Attribute.
  2. Klicken Sie auf Auswählen Selektieren, und wählen Sie das Feature aus, an das Sie eine Datei anhängen möchten.
  3. Blenden Sie die ausgewählten Elemente in dem Bereich ein, und klicken Sie auf das Feature.
  4. Klicken Sie auf die Registerkarte Anlagen.

    Registerkarte "Anlage"

  5. Klicken Sie auf der Werkzeugleiste auf Hinzufügen Hinzufügen.

    Der Dateibrowser Anlage auswählen wird geöffnet.

  6. Wählen Sie im Dateibrowser die Dateien aus, die Sie an das Feature anhängen möchten, und klicken Sie auf Öffnen.

    Die Datei wird in die Anlagentabelle kopiert.

Entfernen von Anlagen

Durch Entfernen einer Dateianlage werden die ausgewählten Dateien aus der Anlagentabelle der Feature-Class gelöscht.

  1. Klicken Sie auf der Registerkarte Bearbeiten in der Gruppe Auswahl auf Attribute Attribute.

    Der Bereich Attribute wird angezeigt.

  2. Klicken Sie auf Auswählen Selektieren, und wählen Sie das Feature aus, das die zu entfernende Anlage enthält.
  3. Blenden Sie die ausgewählten Elemente in dem Bereich ein, und klicken Sie auf das Feature.
  4. Klicken Sie auf die Registerkarte Anlagen.
  5. Klicken Sie auf die Datei, die Sie entfernen möchten.
  6. Klicken Sie auf der Werkzeugleiste auf Anlage entfernen Löschen.

    Die Datei wird aus der Anlagentabelle gelöscht.

Öffnen einer Anlage

Beim Öffnen einer Dateianlage wird die ausgewählte Datei in der verknüpften Anwendung geöffnet, die auf dem Gerät installiert ist.

  1. Klicken Sie auf der Registerkarte Bearbeiten in der Gruppe Auswahl auf Attribute Attribute.
  2. Klicken Sie auf das Werkzeug Auswählen Selektieren, und wählen Sie das Feature aus, das Sie bearbeiten möchten.
  3. Blenden Sie die ausgewählten Elemente in dem Bereich ein, und klicken Sie auf das Feature.
  4. Klicken Sie auf die Registerkarte Anlagen.
  5. Klicken Sie auf die Datei, die Sie öffnen möchten.
  6. Klicken Sie auf der Werkzeugleiste auf Anlage öffnen Durchsuchen.

    Die Datei wird in der verknüpften Anwendung geöffnet, die auf dem Gerät installiert ist.

Aktualisieren einer Anlage

Beim Aktualisieren einer Dateianlage wird ein Dateibrowser geöffnet, und die ausgewählte Datei in der Anlagentabelle der Feature-Class wird durch die ausgewählte Datei aus Ihrem Dateisystem ersetzt.

  1. Klicken Sie auf der Registerkarte Bearbeiten in der Gruppe Auswahl auf Attribute Attribute.
  2. Klicken Sie auf das Werkzeug Auswählen Selektieren, und wählen Sie das Feature aus, das Sie bearbeiten möchten.
  3. Blenden Sie die ausgewählten Elemente in dem Bereich ein, und klicken Sie auf das Feature.
  4. Klicken Sie auf die Registerkarte Anlagen.
  5. Klicken Sie auf die Datei, die Sie aktualisieren möchten.
  6. Klicken Sie auf der Werkzeugleiste auf Anlage aktualisieren Aktualisieren.

    Der Dateibrowser Anlage aktualisieren wird geöffnet.

  7. Wählen Sie die Datei im Dateibrowser aus, und klicken Sie auf Öffnen.

    Die Datei in dieser Anlagentabelle wird durch die ausgewählte Datei ersetzt.

Speichern einer Anlage

Beim Speichern einer Dateianlage wird ein Dateibrowser geöffnet, und die ausgewählte Datei wird an den ausgewählten Speicherort in Ihrem Dateisystem kopiert.

  1. Klicken Sie auf der Registerkarte Bearbeiten in der Gruppe Auswahl auf Attribute Attribute.

    Der Bereich Attribute wird angezeigt.

  2. Klicken Sie auf das Werkzeug Auswählen Selektieren, und wählen Sie das Feature aus, das Sie bearbeiten möchten.
  3. Blenden Sie die ausgewählten Elemente in dem Bereich ein, und klicken Sie auf das Feature.
  4. Klicken Sie auf die Registerkarte Anlagen.
  5. Klicken Sie auf die Datei, die Sie in Ihrem Dateisystem speichern möchten.
  6. Klicken Sie auf der Werkzeugleiste auf Anlage speichern Speichern.

    Der Dateibrowser Anlage speichern wird geöffnet.

  7. Wählen Sie den Ordner im Dateibrowser aus, und klicken Sie auf Speichern.

    Die Datei wird im Dateisystem gespeichert.