Skip To Content

Erste Schritte mit Bearbeitungsvorgängen

Die Bearbeitung erfolgt mithilfe von Werkzeugen auf dem Menüband, auf der Werkzeugleiste "Bearbeitung" und in Bereichen. Befehle im Kontextmenü "Bearbeitung" werden für bestimmte Werkzeuge angezeigt und ermöglichen Ihnen die Durchführung einer Vielzahl von zugehörigen Änderungen.

Eine Editiersitzung wird automatisch gestartet, wenn Sie vorhandene Daten ändern oder neue Daten erstellen. Die Editiersitzung wird beendet, wenn Sie die Änderungen speichern oder verwerfen. Alle folgenden von Ihnen durchgeführten Änderungen führen zu einer Fortsetzung der Editiersitzung, bis Sie die Änderungen speichern oder verwerfen.

In den folgenden Abschnitten wird ein grundlegender Workflow für den Einstieg in die Bearbeitung von Features vorgestellt. Detaillierte Schritte zum Verwenden eines bestimmten Werkzeugs erhalten Sie, indem Sie das Inhaltsverzeichnis durchsuchen oder in der Hilfe nach einem bestimmten Schlagwort oder Ausdruck suchen.

Öffnen des Projekts

Öffnen Sie das Projekt, das die Karte und Features enthält, die Sie bearbeiten möchten. Wenn kein Projekt vorhanden ist, können Sie ein neues Projekt erstellen und die Standard-Geodatabase verwenden, die im Bereich Katalog angezeigt wird und denselben Namen wie das Projekt trägt.

  1. Starten Sie ArcGIS Pro, und melden Sie sich ggf. an.
  2. Führen Sie auf der Startseite einen der folgenden Schritte aus:
    • Öffnen Sie eines der zuletzt verwendeten Projekte Katalogansicht.
    • Klicken Sie auf Ein anderes Projekt öffnen Durchsuchen, und navigieren Sie zu dem Projekt.
    • Erstellen Sie ein neues Projekt anhand einer Projektvorlage Projektvorlage.
    Hinweis:

    Wenn Sie ein Projekt über eine Portal-Verbindung Gesamtes Portal öffnen, wird das Projektpaket (.ppkx) heruntergeladen und im Ordner <User Documents>\ArcGIS\OnlineProjects entpackt. Nach dem Schließen des Projekts wird die entpackte Projektdatei (.aprx) in der Liste der zuletzt verwendeten Projekte angezeigt.

  3. Klicken Sie auf der Registerkarte Ansicht in der Gruppe Fenster auf den Dropdown-Pfeil Katalog und dann auf Bereich "Katalog" Bereich "Katalog".

    Der Bereich Katalog wird angezeigt.

    Bereich "Katalog"

  4. Blenden Sie Karten Karten ein, und gehen Sie wie folgt vor:
    • Klicken Sie mit der rechten Maustaste auf die Karte, und klicken Sie auf Öffnen Kartenansicht.
    • Klicken Sie auf der Registerkarte Einfügen in der Gruppe Projekt auf Neue Karte Neue Karte.

    Die Karte wird geöffnet.

Hinzufügen von Daten zur Karte

Wenn Sie eine Feature-Class auf eine aktive Karte ziehen, wird automatisch eine Feature-Vorlage mit den Standardeinstellungen erstellt.

  1. Blenden Sie im Bereich Katalog Datenbanken Datenbanken ein.
  2. Blenden Sie die Datenbank mit den Daten ein, und ziehen Sie die Feature-Class auf die Karte.

    Der Layer wird der aktiven Karte hinzugefügt, und für jeden neuen Layer wird automatisch eine Feature-Vorlage mit den Standardeinstellungen erstellt.

Erstellen einer neuen Feature-Class

Wenn keine Feature-Daten vorhanden sind, können Sie mit der rechten Maustaste auf die Standard-Geodatabase klicken und eine neue Feature-Class erstellen.

  1. Klicken Sie mit der rechten Maustaste auf die Standarddatenbank, klicken Sie auf Neu und dann auf Feature-Class Polygon-Feature-Class.

    Daraufhin wird der Bereich Geoverarbeitung angezeigt.

    Feature-Class erstellen

  2. Geben Sie den Namen der Feature-Class ein.
  3. Klicken Sie auf den Dropdown-Pfeil Geometrie-Typ, und wählen Sie einen Geometrie-Typ aus.
  4. Legen Sie ein Koordinatensystem mit einer der folgenden Methoden fest:
    • Klicken Sie auf den Dropdown-Pfeil Koordinatensystem, und wählen Sie das für die Karte oder einen Layer in der Karte angegebene Koordinatensystem aus.
    • Klicken Sie auf Koordinatensystem auswählen Koordinatensystem, und wählen Sie ein Koordinatensystem aus.
  5. Klicken Sie auf AusführenAusführen.

    Die Feature-Class wird erstellt, der Layer wird der aktiven Karte hinzugefügt, und es wird automatisch eine Feature-Vorlage mit den Standardeinstellungen erstellt.

Dokumentieren von Daten

Um Ihre Daten zu dokumentieren, aktualisieren Sie das Metadaten-Tag und die Zusammenfassungsfelder des Elements mit Informationen, die dessen Verwendungszweck und Inhalt kurz beschreiben. Geben Sie beispielsweise eine kurze Begründung dafür ein, warum Sie das Projekt erstellt haben, oder welche Art von Daten mit einer Feature-Class erfasst werden.

Hinweis:

Metadaten sind Daten, die andere Daten beschreiben. Sie werden verwendet, um Daten zu dokumentieren und zu strukturieren, sodass sie gefunden und schneller durchsucht werden können. Anhand präziser Metadaten können andere Benutzer die Qualität und Eignung Ihrer Daten für deren Datenkompilierung oder in Bezug auf ihre Analyseanforderungen bewerten.

Weitere Informationen finden Sie unter Empfehlungen für das Bearbeiten von Metadaten.

  1. Klicken Sie im Bereich Katalog mit der rechten Maustaste auf die Feature-Class, und klicken Sie auf Metadaten anzeigen Dokumentmetadaten.

    Die Ansicht Katalog wird geöffnet, und im Menüband wird die Registerkarte Startseite angezeigt.

  2. Klicken Sie auf der Registerkarte Startseite in der Gruppe Metadaten auf Bearbeiten Bearbeiten.

    Die Ansicht Metadaten wird geöffnet.

  3. Geben Sie in der Ansicht Metadaten mindestens ein Schlagwort in das Textfeld Tags ein.

    Wenn Sie im Bereich Katalog auf die Feature-Class zeigen, werden Tags mit den Pop-up-Informationen angezeigt.

  4. Geben Sie im Textfeld Zusammenfassung (Zweck) Informationen ein, die erläutern, warum Sie die Daten erstellt haben.
  5. Klicken Sie auf der Registerkarte Metadaten in der Gruppe Metadaten verwalten auf Speichern Änderungen speichern.
  6. Schließen Sie die Ansicht Metadaten und die Ansicht Katalog.

Hinzufügen von Attributfeldern

Wenn Sie eine neue Feature-Class erstellen, enthält sie nur Systemfelder, die das Objekt und dessen Form definieren. Mithilfe der Werkzeuge auf der Registerkarte Daten können Sie Attributfelder für die Daten, die Sie mit jedem Feature erfassen möchten, hinzufügen, löschen oder ändern.

Weitere Informationen zu Feldern finden Sie unter Überblick über Felder.

  1. Klicken Sie auf der Registerkarte Ansicht in der Gruppe Fenster auf Inhalt Inhalte.

    Der Bereich Inhalt wird geöffnet.

    Bereich "Inhalt"

  2. Klicken Sie auf den neuen Feature-Layer.

    Die kontextbezogene Registerkarte Feature-Layer wird im Menüband mit den Registerkarten Aussehen, Beschriftung und Daten geöffnet.

  3. Klicken Sie auf der Registerkarte Daten in der Gruppe Design auf Felder.

    Die Ansicht Felder wird geöffnet, und im Menüband wird die Registerkarte Felder angezeigt.

  4. Klicken Sie auf der Registerkarte Felder in der Gruppe Änderungen auf Neues Feld.

    Der Feature-Tabelle wird ein neues Feld hinzugefügt.

  5. Doppelklicken Sie auf das Feld Feldname, und geben Sie einen Namen ein.
  6. Doppelklicken Sie auf das Feld Datentyp, wählen Sie einen Datentyp aus, und führen Sie diese Aktion auch für die anderen Eigenschaftsfelder aus, die für den Datentyp relevant sind.
  7. Klicken Sie auf der Registerkarte Felder in der Gruppe Änderungen auf Speichern Änderungen speichern.
  8. Schließen Sie die Ansicht Felder.

Symbolisieren von Layern

Unter Symbolisierung eines Feature-Layers versteht man die Konfiguration der Eigenschaften eines Layers, um Punkt-, Linien- oder Polygon-Features als bestimmte Symbole darzustellen; z. B. wenn Sie ermitteln möchten, was die Features darstellen, oder um qualitative oder quantitative Unterschiede basierend auf Attributwerten zu vermitteln.

Weitere Informationen finden Sie unter Symbolisieren von Feature-Layern .

  1. Klicken Sie im Bereich Inhalt mit der rechten Maustaste auf den Layer, und klicken Sie auf Symbolisierung Symbolisierung.

    Der Bereich Symbolisierung wird angezeigt.

  2. Klicken Sie auf den Dropdown-Pfeil Symbolisierung, wählen Sie einen Typ aus, der für die Daten geeignet ist, und konfigurieren Sie die Eigenschaften. Features können je nach enthaltenem Datentyp auf unterschiedliche Weise symbolisiert werden:

    Das Feature-Vorlagen-Symbol, das im Bereich Features erstellen angezeigt wird, wird automatisch aktualisiert.

Überprüfen der Editierbarkeit von Layern

Es sind keine Schaltflächen zum Starten oder Beenden einer Editiersitzung vorhanden. Es empfiehlt sich, die Editierbarkeit eines Layers im Dialogfeld Bearbeitungsstatus zu überprüfen, bevor Sie mit der Bearbeitung beginnen. Im Bereich Inhalt können Sie die Bearbeitung für Layer, die Sie vor unerwünschten Änderungen schützen müssen, deaktivieren.

  1. Klicken Sie auf der Registerkarte Bearbeiten auf Status Bearbeitungsstatus.

    Das Dialogfeld Bearbeitungsstatus wird angezeigt.

  2. Überprüfen Sie die Bearbeitungsberechtigungen für die Layer im Workspace, achten Sie auf die Layer, die Sie bearbeiten können, und klicken Sie auf Schließen.
  3. Klicken Sie im Bereich Inhalt auf die Registerkarte Nach Bearbeitung auflisten Nach Bearbeitung auflisten, und deaktivieren Sie den Layer, der nicht bearbeitet werden soll.

Erstellen von Features

Im Bereich Features erstellen werden mit Feature-Vorlagen Features für bestimmte Layer erstellt. Die Datenquelle eines Feature-Layers definiert die zweidimensionalen (2D) oder dreidimensionalen (3D) Features, die von einer Vorlage erstellt werden.

Weitere Informationen finden Sie unter Einführung in die Erstellung von 2D- und 3D-Features.

  1. Klicken Sie auf der Registerkarte Bearbeiten in der Gruppe Features auf Erstellen Features erstellen.

    Der Bereich Features erstellen wird angezeigt.

    Features erstellen

    Hinweis:

    Warnsymbole Warnung und Benachrichtigungsmeldungen weisen Sie darauf hin, wenn von einer Vorlage nicht sichtbare Features erstellt oder vorhandene Vorlagen nicht in dem Bereich angezeigt werden. Weitere Informationen finden Sie unter Meldungen zu Feature-Vorlagen.

  2. Klicken Sie in dem Bereich auf eine Feature-Vorlage.
  3. Klicken Sie neben der Werkzeugpalette auf den Vorwärtspfeil Vorwärts.

    Die Werkzeugpalette und die Feature-Attributtabelle für die aktive Vorlage werden im Bereich angezeigt.

    Aktive Vorlage
  4. Geben Sie die Attributwerte ein, die Sie auf das neue Feature in der Feature-Attributtabelle anwenden möchten.
    Tipp:

    Um die Attributwerte mit der Vorlage zu speichern und bei der nächsten Verwendung der Vorlage wiederzuverwenden, klicken Sie auf die Menüschaltfläche Menü und dann auf Eigenschaften Eigenschaften.

  5. Klicken Sie auf die Karte, und erstellen Sie das Feature.
    • Sie können das automatisch ausgeführte Standardwerkzeug verwenden oder auf ein anderes Werkzeug auf der Werkzeugpalette klicken.
    • Wenn Sie ein 3D-Feature erstellen, können Sie Z-Werte mit den Werkzeugen auf der Registerkarte Bearbeiten in der Gruppe Höhe eingeben.
  6. Um das Feature fertig zu stellen, klicken Sie mit der rechten Maustaste, und wählen Sie Fertig Fertig stellen aus, oder drücken Sie die Taste F2.
  7. Klicken Sie auf der Registerkarte Bearbeiten in der Gruppe Änderungen verwalten auf Speichern Änderungen speichern.

    Das Dialogfeld Änderungen speichern wird angezeigt.

    Änderungen speichern

  8. Klicken Sie auf Ja, um die Änderungen in der Geodatabase zu speichern.

Ändern eines Features

Mit den Editierwerkzeugen im Bereich Features ändern Features ändern werden vorhandene Features geändert. Die Registerkarte Eigene Werkzeuge enthält die gleiche anpassbare Liste von Werkzeugen, die auf dem Menüband in der Galerie Werkzeuge angezeigt wird. Die Registerkarte Alle Werkzeuge enthält alle Editierwerkzeuge, die im Projekt verfügbar sind.

Weitere Informationen finden Sie unter Einführung in die Änderung von Features.

  1. Klicken Sie auf der Registerkarte Bearbeiten in der Gruppe Features auf Ändern Features ändern.

    Der Bereich Features ändern wird angezeigt.

    Features ändern

  2. Blenden Sie eine Werkzeugkategorie ein, und klicken Sie auf ein Werkzeug.

    Das Werkzeug wird in dem Bereich geöffnet.

  3. Klicken Sie in dem Bereich auf Auswählen Aktive Auswahl, und wählen Sie das bzw. die Features für die Bearbeitung aus.

    Die ausgewählten Features werden in dem Bereich aufgelistet.

    Tipp:

    Die Auswahlwerkzeuge, die im Bereich mit einem aktiven Editierwerkzeug angezeigt werden, enthalten zusätzliche Funktionalität, mit denen sich der Workflow optimieren lässt. Es empfiehlt sich, diese für das Auswählen von Features zu verwenden. Sie übernehmen die Auswahlmethoden von dem auf der Registerkarte Bearbeiten aktiven Auswahlwerkzeug.

    Weitere Informationen finden Sie unter Auswählen von Features zur Bearbeitung.

  4. Bearbeiten Sie das Feature mit den Schritten, die durch das spezifische Werkzeug vorgegeben sind.
  5. Um das Feature fertig zu stellen, klicken Sie mit der rechten Maustaste, und wählen Sie Fertig Fertig stellen aus, oder drücken Sie die Taste F2.
  6. Klicken Sie auf der Registerkarte Bearbeiten in der Gruppe Änderungen verwalten auf Speichern Änderungen speichern.

    Das Dialogfeld Änderungen speichern wird angezeigt.

    Änderungen speichern
  7. Klicken Sie auf Ja, um die Änderungen in der Geodatabase zu speichern.