Skip To Content

Rubbersheet für Features durchführen

Zur Option Transformieren Transformieren im Bereich Features ändern gehören die Interpolationsmethoden "Lineare Nachbarn" und "Natürliche Nachbarn" für sichtbare und bearbeitbare Rubbersheeting-Features. Sie können sichtbare und bearbeitbare Features transformieren, indem Sie sie auswählen oder indem Sie alle Features in angegebenen Layern transformieren.

Versatz-Links aus zwei Punkten definieren die Ursprungs- und Zielposition der Features, die Sie transformieren. Um zu verhindern, dass bestimmte Stützpunkte verschoben werden, können Sie Ankerpunkte hinzufügen und sie an Features fangen, und Flächenpolygone zeichnen, um die Stützpunkte, die transformiert werden, weiter zu begrenzen.

Nach dem Transformieren von Features werden Versatz-Links automatisch gelöscht und die Zielpunkte werden in Ankerpunkte umgewandelt.

Nach einer Transformation wird häufig Rubbersheeting verwendet, um die Ausrichtungsgenauigkeit der transformierten Features weiter zu verfeinern.

Eine Anleitung zum Transformieren von Features mithilfe der Transformationsmethoden "Affin" bzw. "Ähnlichkeit" finden Sie unter Transformieren von Features.

  1. Aktivieren Sie auf der Registerkarte Bearbeiten in der Gruppe Fangen die Fangeinstellungen.
    Tipp:

    Sie können die Leertaste gedrückt halten, um beim Erstellen von Ankerpunkten und Darstellen von Versatz-Links oder Rubbersheet-Flächen-Polygonen die Fangfunktion vorübergehend zu deaktivieren.

  2. Klicken Sie auf der Registerkarte Bearbeiten in der Gruppe Features auf Ändern Features ändern.

    Der Bereich Features ändern wird angezeigt.

  3. Blenden Sie Ausrichten ein, und klicken Sie auf Transformieren Transformieren.

    Das Werkzeug wird in dem Bereich geöffnet.

  4. Wählen Sie die Features, die Sie transformieren möchten, mit einer der folgenden Methoden aus:
    • Klicken Sie auf die Registerkarte Ausgewähltes Feature, und verwenden Sie Aktive Auswahl Aktive Auswahl, um das Feature auszuwählen, das Sie transformieren möchten.
      Hinweis:

      Um Ihre Auswahl zu verfeinern, klicken Sie mit der rechten Maustaste auf ein Feature im Bereich, und verwenden Sie die Befehle im Kontextmenü.

      Kontextmenü zur Auswahl

    • Klicken Sie auf die Registerkarte Layer, und wählen Sie den Layer aus, in dem sich die Features befinden. Mit dieser Methode werden alle Features im ausgewählten Layer transformiert.
  5. Klicken Sie auf den Dropdown-Pfeil Transformationsmethode, und wählen Sie eine Interpolationsmethode aus.
    • Rubbersheet (Linear): Diese Methode nimmt weniger Zeit in Anspruch und eignet sich, wenn viele gleichmäßig über die Transformationsfläche verteilte Links vorhanden sind. Bei dieser Methode wird die natürliche Nachbarschaft nicht berücksichtigt.
    • Rubbersheet (Natürlicher Nachbar): Diese Methode nimmt mehr Zeit in Anspruch, liefert jedoch genauere Ergebnisse, wenn die Versatz-Links unregelmäßig über die Transformationsfläche verteilt sind. Sie ähnelt der Interpolationsmethode "Inverse Distance Weighting".
  6. Stellen Sie eine geeignete Anzahl von Versatz-Links aus zwei Punkten dar, die die Ursprungs- und Zielposition der Features definieren, die Sie transformieren. Sie können beliebig viele Links darstellen.
    1. Klicken Sie auf Neue Links hinzufügen Neuen Link hinzufügen.

      Die Konstruktionswerkzeugleiste für Segmente wird im unteren Bereich der Karte angezeigt.

      Werkzeugleiste für Segment-Konstruktionswerkzeuge
    2. Fangen Sie den Ursprungspunkt an einer Kante oder einem Stützpunkt des Features, das Sie transformieren, und klicken Sie darauf.
    3. Fangen Sie den Endpunkt an der neuen Zielposition, und klicken Sie darauf.
    Tipp:

    Sie können beim Darstellen von Links Zeit sparen, indem Sie auf Links aus Datei laden Durchsuchen klicken und vordefinierte Links laden, die sich in einer mit ArcMap erstellten Link-Datei befinden. Link-Dateien sind durch Tabulatoren getrennte ASCII-Textdateien, die pro Zeile für jeden Link zwei Paar XY-Koordinatenwerte enthalten.

    Sie können vier- oder fünfspaltige Link-Dateien laden. Eine vierspaltige Link-Datei enthält ein Paar Quell- und Zielkoordinatenwerte. Eine fünfspaltige Link-Datei enthält eine ID-Spalte (Zeichenfolge oder numerisch), die den Spalten mit den Koordinatenwerten vorangestellt ist.

    Beispielinhalte für eine fünfspaltige Link-Datei.

    3	1032507.603691	1865947.186470	1032507.207115	1865926.170407
    2	1032508.350801	1865986.785187	1032509.079486	1866025.405116
    1	1032388.666424	1865961.179459	1032361.009572	1865981.280533

  7. Fügen Sie Positionen, die Sie fixieren möchten und bei denen Sie verhindern möchten, dass sie beim Transformieren der Features verschoben werden, Ankerpunkte hinzu.
    1. Klicken Sie auf Ankerpunkte hinzufügen Ankerpunkt.

      Die Konstruktionswerkzeugleiste für Punkte wird im unteren Bereich der Karte angezeigt.

      Werkzeugleiste für Punkt-Konstruktionswerkzeuge
    2. Klicken Sie auf den Ankerpunkt, und fangen Sie ihn an einer Kante oder einem Stützpunkt des Features, das Sie einschränken möchten.
  8. Um die anzupassenden Flächen weiter zu begrenzen und bestimmte Stützpunkte herauszufiltern, zeichnen Sie mindestens ein Polygon um die Stützpunkte, die Sie transformieren möchten. Sie können beliebig viele Flächenpolygone zeichnen.
    1. Klicken Sie auf Rubbersheet-Fläche hinzufügen Rubbersheet-Fläche.

      Die Konstruktionswerkzeugleiste für Segmente wird im unteren Bereich der Karte angezeigt.

      Werkzeugleiste für Segment-Konstruktionswerkzeuge
    2. Klicken Sie, und zeichnen Sie ein Polygon um die Stützpunkte, die Sie transformieren möchten. Alle anderen Stützpunkte werden nicht transformiert.
    3. Doppelklicken Sie, oder klicken Sie auf Fertig stellen Fertig stellen, um das Polygon fertigzustellen.
  9. Gehen Sie wie folgt vor, um einen Ankerpunkt, einen Versatz-Link oder ein Flächenpolygon zu löschen:
    • Klicken Sie auf Auswählen Selektieren, wählen Sie den Ankerpunkt, den Link oder das Flächenpolygon aus, und drücken Sie die Entf-Taste, oder klicken Sie mit der rechten Maustaste, und klicken Sie anschließend im Kontextmenü auf Löschen.
    • Um alle Ankerpunkte, Versatz-Links und Flächenpolygone zu löschen, klicken Sie im Bereich auf Alle Links löschenLöschen.
  10. Klicken Sie auf Transformieren.

    Die Features werden transformiert, die Versatz-Links werden gelöscht, und die Zielpunkte werden in Ankerpunkte umgewandelt.


In diesem Thema