Skip To Content

Layout-Dateien

Layout-Dateien (Dateierweiterung .pagx) sind gespeicherte Layouts, die projektübergreifend freigegeben werden können. Sie können als Vorlage für neue Projekte verwendet werden und für Konsistenz einer Reihe von Layouts in einer Organisation sorgen. Layout-Dateien können Kartenrahmen und Elemente, die Karten und Layer referenzieren, oder leere Kartenrahmen, die keine Karten und Layer referenzieren, enthalten. Leere Kartenrahmen können gefüllt werden, nachdem die Layout-Datei importiert wurde, und die referenzierten Umgebungselemente werden entsprechend aktualisiert.

Speichern einer Layout-Datei mit leeren Kartenrahmen

Eine Layout-Datei mit leeren Kartenrahmen enthält keine Daten. Das Layout weist möglicherweise formatierte Elemente, z. B. einen Kartenrahmen, eine Legende und einen Nordpfeil auf, dem Kartenrahmen ist jedoch keine Karte zugeordnet. Wenn Sie eine Layout-Datei mit leeren Kartenrahmen importieren und dann eine Referenz des Kartenrahmens zu einer Karte festlegen, werden alle anderen Elemente im Layout entsprechend aktualisiert. Layout-Dateien mit leeren Kartenrahmen können als Layout-Vorlagen verwendet werden. Das Layout kann in verschiedene Projekte importiert werden und auf vielfältige Karten verweisen, das Layout bleibt jedoch konsistent.

Gehen Sie wie folgt vor, um eine Layout-Datei mit leeren Kartenrahmen aus einem vorhandenen Layout zu erstellen und zu importieren:

  1. Öffnen Sie das vorhandene Layout, um es als Layout-Datei zu speichern.
  2. Klicken Sie im Bereich Inhalt mit der rechten Maustaste auf den Kartenrahmen und auf Eigenschaften.

    Der Bereich Element wird angezeigt.

  3. Legen Sie im Bereich Element die Option Karte auf <Keine> fest.

    Das Layout wird neu dargestellt, und die Karte wird nicht mehr angezeigt. Alle anderen Elemente, die auf die Karte verwiesen haben, werden ebenfalls nicht mehr dargestellt.

  4. Wiederholen Sie für alle zusätzlichen Kartenrahmen im Layout Schritt 2 und 3.
  5. Klicken Sie im Bereich Inhalt mit der rechten Maustaste auf die Kartenumgebung, und klicken Sie auf Eigenschaften.
  6. Überprüfen Sie im Bereich Element, ob Kartenrahmen auf einen der Kartenrahmen festgelegt ist, die Sie in den Schritten 2 bis 4 auf <Keine> festgelegt haben.

    Wenn die Kartenumgebung auf keinen leeren Kartenrahmen verweist, wird sie automatisch aktualisiert, sobald der Kartenrahmen gefüllt wird, und Sie müssen das Element manuell aktualisieren.

  7. Wählen Sie auf der Registerkarte Freigeben die Option Layout-Datei aus.
  8. Legen Sie den Namen und Speicherort der Layout-Datei fest, und klicken Sie auf Speichern.

Nachdem eine Layout-Datei mit leeren Kartenrahmen erstellt wurde, können Sie sie in ein Projekt importieren und mithilfe jeder Karte in diesem Projekt füllen. Gehen Sie dazu wie folgt vor:

  1. Öffnen Sie das Projekt, dem Sie die Layout-Datei hinzufügen möchten.
  2. Klicken Sie auf der Registerkarte Einfügen auf Neues Layout.
  3. Klicken Sie auf Layout-Datei importieren Importieren.
  4. Navigieren Sie im Dialogfeld Importieren zu der Layout-Datei, und klicken Sie auf OK.
  5. Klicken Sie im Bereich Inhalt mit der rechten Maustaste auf den Kartenrahmen und auf Eigenschaften.

    Der Bereich Element wird angezeigt.

  6. Legen Sie im Bereich Element die Option Karte auf die gewünschte Karte fest.

    Das Layout wird neu dargestellt, sodass im Kartenrahmen die ausgewählte Karte angezeigt wird. Alle anderen Elemente, die auf die Karte verweisen, werden entsprechend aktualisiert.

Hinweis:

Wenn die Layout-Datei Tabellen- oder Diagrammrahmen enthält, überprüfen Sie die Eigenschaften, um sicherzustellen, dass die gewünschte Tabelle bzw. das gewünschte Diagramm angezeigt wird. Eine Karte kann mehrere Tabellen und Diagramme aufweisen, und möglicherweise muss die Tabelle oder das Diagramm, das bzw. die automatisch gefüllt wurde, manuell aktualisiert werden.

Speichern einer Layout-Datei mit Karten und Layern

Eine Layout-Datei kann mit Karten und Layern gespeichert werden, die zugeordnete Daten referenzieren. In diesem Fall verweisen die Element im Layout, z. B. der Kartenrahmen, die Legende und der Nordpfeil, auf Karten und Layer. Wenn Sie eine Layout-Datei importieren, die Karten referenziert, werden diese Karten ebenfalls importiert.

Hinweis:

In Layout-Dateien werden keine Daten gespeichert. Eine aufgefüllte Layout-Datei verweist auf vorhandene Datenpfade. Wenn die Daten verschoben werden oder wenn die Layout-Datei für eine Person freigegeben wird, die keinen Zugriff auf die zugeordneten Daten hat, werden die Datenverknüpfungen unterbrochen, und das Layout wird nicht ordnungsgemäß dargestellt.

Gehen Sie wie folgt vor, um eine Layout-Datei mit Karten und Layern aus einem vorhandenen Layout zu erstellen und zu importieren:

  1. Öffnen Sie das vorhandene Layout, um es als Layout-Datei zu speichern.
  2. Klicken Sie auf der Registerkarte Freigeben auf Layout-Datei.
  3. Legen Sie den Namen und Speicherort der Layout-Datei fest, und klicken Sie auf Speichern.

Nachdem eine gefüllte Layout-Datei erstellt wurde, können Sie sie wie folgt in ein Projekt importieren:

  1. Öffnen Sie das Projekt, dem die Layout-Datei hinzugefügt werden soll.
  2. Klicken Sie auf der Registerkarte Einfügen auf Neues Layout.
  3. Klicken Sie auf Layout-Datei importieren Importieren.
  4. Navigieren Sie im Dialogfeld Importieren zu der Layout-Datei, und klicken Sie auf OK.

    Wenn die Karte in der Layout-Datei im Projekt bereits vorhanden ist, können Sie Vorhandene Karten beim Importieren von Layouts wiederverwenden aktivieren, damit Karten nicht doppelt angelegt werden. Nicht im Projekt vorhandene Karten werden dennoch kopiert, wenn diese Option aktiviert ist.

Verwandte Themen