Skip To Content

Arbeiten mit einem Tabellenrahmen

Der folgende Workflow wurde für die Arbeit mit Daten aus dem Living Atlas entwickelt. Sie fügen ein Layout, einen Kartenrahmen und einen Tabellenrahmen hinzu. Dann ändern Sie den Tabellenrahmen und verbessern sein Aussehen.

Zusammenfassung des Lernprogramms

Play Video

  • Videolänge: 02:11
  • Dieses Video wurde mit ArcGIS Pro 2.1. erstellt.

Hinzufügen einer Karte und von Daten aus dem Living Atlas

Bevor Sie eine Tabelle hinzufügen können, müssen Sie eine Karte erstellen und dem Layout eine Karte mit einem Layer hinzufügen.

  1. Starten Sie ArcGIS Pro. Geben Sie, falls notwendig, auf dem Bildschirm Anmelden bei ArcGIS einen Benutzernamen und ein Kennwort ein, und klicken Sie dann auf Anmelden.
  2. Klicken Sie auf die Projektvorlage Karte. Geben Sie einen Namen und einen Speicherort für das Projekt an, und klicken Sie auf OK.
  3. Klicken Sie im Bereich Katalog auf die Registerkarte Portal, und klicken Sie auf die Registerkarte Living Atlas Living Atlas.
  4. Geben Sie im Suchfeld USA States (Generalized) ein. Drücken Sie EINGABE.
  5. Klicken Sie in den Suchergebnissen mit der rechten Maustaste auf den Feature-Layer USA States (Generalized), und klicken Sie dann auf Zu aktueller Karte hinzufügen Zu aktueller Karte hinzufügen.
  6. Deaktivieren Sie dazu im Bereich Inhalt den Grundkarten-Layer Topographic.

Symbolisieren von Layern

  1. Klicken Sie im Bereich Inhalt ggf. auf den Layer-Namen USA_States_Generalized, um sicherzustellen, dass dieser ausgewählt ist.
  2. Klicken Sie auf dem Menüband unter Feature-Layer auf die Registerkarte Aussehen. Klicken Sie in der Gruppe Darstellung auf das Dropdown-Menü Symbolisierung und dann auf Einzelwerte.
  3. Klicken Sie im Bereich Symbolisierung auf das Dropdown-Menü von Feld 1, und klicken Sie auf Region.

    Die Bundesstaaten werden nach ihren Werten im Feld Region symbolisiert.

  4. Ändern Sie das Farbschema in Satz 3 (10 Klassen).
    Tipp:

    Aktivieren Sie die Kontrollkästchen Namen anzeigen und Alle zeigen, und führen Sie einen Bildlauf durch, um das Farbschema Satz 3 anzuzeigen.

  5. Klicken Sie auf das Dropdown-Menü Mehr, und deaktivieren Sie Alle anderen Werte anzeigen.
  6. Schließen Sie den Bereich Symbolisierung.

Hinzufügen eines Layouts

  1. Klicken Sie auf dem Menüband auf die Registerkarte Einfügen. Klicken Sie in der Gruppe Projekt auf das Dropdown-Menü Neues Layout. Klicken Sie unter ANSI - Querformat auf Letter (8,5 x 11 Zoll).

    Eine Layout-Ansicht wird geöffnet.

  2. Klicken Sie mit der rechten Maustaste auf das Lineal oben im Layout, und klicken Sie dann auf Führungslinien hinzufügen. Führen Sie im Dialogfeld Führungslinie hinzufügen die folgenden Schritte aus:
    1. Klicken Sie unter Ausrichtung auf Beide.
    2. Wählen Sie unter Platzierung die Option Versatz von Kante aus.
    3. Ändern Sie den Wert für Rand in 0,5.
    4. Klicken Sie auf OK.
  3. Klicken Sie mit der rechten Maustaste bei der 3-Zoll-Markierung auf das vertikale Lineal (Seitenlineal), und klicken Sie dann auf Führungslinie hinzufügen.

    Sie fügen die Tabelle unterhalb dieser Führungslinie hinzu.

  4. Klicken Sie auf der Registerkarte Einfügen in der Gruppe Kartenrahmen auf das Dropdown-Menü Kartenrahmen, und wählen Sie für die gerade hinzugefügte Karte die Standardausdehnung aus.
  5. Ziehen Sie in der Layout-Ansicht bei gedrückter Maustaste den Kartenrahmen innerhalb der Führungslinien auf, wie gezeigt.

    Kartenrahmen im Layout mit Führungslinien

Ändern der Ausdehnung eines Kartenrahmens

  1. Wählen Sie den Kartenrahmen ggf. im Layout aus.
  2. Geben Sie im Maßstabsfeld unten in der Ansicht 1:30.000.000 ein, und drücken Sie die Eingabetaste.

    Der Kartenmaßstab wird geändert. Als Nächstes aktivieren Sie die Karte und ändern die Position so, dass nur die Festlandfläche der USA angezeigt wird.

  3. Klicken Sie auf dem Menüband auf die Registerkarte Layout. Klicken Sie in der Gruppe Karte auf Aktivieren Kartenrahmen aktivieren.
  4. Schwenken Sie mit dem Werkzeug Erkunden Werkzeug "Erkunden" den Kartenrahmen, bis die Festlandfläche der USA sichtbar ist und zentriert angezeigt wird.
  5. Klicken Sie auf dem Menüband unter Aktivierter Kartenrahmen auf die Registerkarte Layout. Klicken Sie in der Gruppe Karte auf Aktivierung schließen Aktivierung schließen.

    In der Ausdehnung der Karte werden 48 Bundesstaaten angezeigt.

Eine Legende zum Layout hinzufügen

  1. Klicken Sie auf dem Menüband auf die Registerkarte Einfügen. Klicken Sie in der Gruppe Kartenumgebungen auf Legende Legende. Ziehen Sie ein Rechteck im Layout links unten im Kartenrahmen.

    Eine Überlaufanzeige Mehr zeigt an, dass die Legendenelemente nicht in das Rechteck passen.

  2. Erweitern Sie im Bereich Inhalt das Element Legende. Klicken Sie mit der rechten Maustaste auf USA_States_Generalized, und klicken Sie dann auf Eigenschaften.
  3. Deaktivieren Sie im Bereich Legendenelement formatieren unter Anzeigen die Optionen Name des Gruppen-Layers und Layer-Name.
  4. Vergrößern Sie ggf. die Legende, indem Sie an einem Ziehpunkt ziehen, bis die Überlaufanzeige ausgeblendet wird.
  5. Klicken Sie im Layout in einen leeren Bereich, um die Auswahl der Legende aufzuheben.

    Nach Region symbolisierte Festlandfläche der USA

Hinzufügen eines Tabellenrahmens zum Layout

  1. Blenden Sie bei Bedarf im Bereich Inhalt die Elemente Kartenrahmen und Karte ein. Klicken Sie auf den Layer-Namen USA_States_Generalized, um diesen auszuwählen.
  2. Klicken Sie auf der Registerkarte Einfügen in der Gruppe Kartenumgebungen auf Tabellenrahmen Tabellenrahmen.
  3. Zeichnen Sie unter dem Kartenrahmen ein Rechteck mit derselben Breite wie der Kartenrahmen, um den Tabellenrahmen zu definieren.
  4. Blenden Sie im Bereich Inhalt das Element Tabellenrahmen ein. Deaktivieren Sie alle Felder außer STATE_NAME, Region und Population.

    Die deaktivierten Felder werden nicht länger im Tabellenrahmen angezeigt. Sie können dem Tabellenrahmen Felder auch hinzufügen, indem Sie mit der rechten Maustaste auf das Element Tabellenrahmen im Bereich Inhalt klicken und Feld hinzufügen auswählen. Sie können Felder entfernen, indem Sie unter Tabellenrahmen mit der rechten Maustaste auf den Feldnamen und dann auf Entfernen Entfernen klicken.

Sortieren der Felder des Tabellenrahmens

  1. Klicken Sie im Bereich Inhalt mit der rechten Maustaste auf das Element Tabellenrahmen, und klicken Sie dann auf Eigenschaften.
  2. Klicken Sie im Bereich Tabellenrahmen formatieren unter Tabellenrahmen auf die grafische Registerkarte Anordnung Registerkarte "Anordnung". Klicken Sie unter Sortieren auf Ein neues Sortierfeld hinzufügen Sortieren, und klicken Sie dann auf STATE_NAME.

    Die Bundesstaaten werden nun alphabetisch im Tabellenrahmen angeordnet.

    Hinweis:

    Die Lücken zwischen den Tabellenrahmenelementen können geändert werden, indem die Werte unter Abstand erhöht oder verringert werden. Auf der Registerkarte Anordnung können Sie auch die Einpassungsmethode der Felder im Tabellenrahmen ändern. Standardmäßig ist Spalten und Schriftgröße anpassen ausgewählt, um so viele Informationen aus der Tabelle unterzubringen wie möglich. Weitere Informationen zu den Einpassungsmethoden finden Sie unter Hinzufügen und Ändern von Tabellenrahmen.

Ändern der Komponenten des Tabellenrahmens

Sie können die unten beschriebenen Änderungen vornehmen, um das Aussehen der Tabelle zu verbessern.

Überschrift

  1. Klicken Sie ggf. im Bereich Inhalt mit der rechten Maustaste auf das Element Tabellenrahmen, und klicken Sie dann auf Eigenschaften, um den Bereich Tabellenrahmen formatieren zu öffnen.
  2. Klicken Sie im Bereich Tabellenrahmen formatieren unter Tabellenrahmen auf die Registerkarte Anzeige Anzeige. Klicken Sie unter Überschrift auf die Schaltfläche Überschriftentextsymbol.

    Der Bereichsstatus wird geändert, um Zugriff auf Textsymbole bereitzustellen.

  3. Klicken Sie am oberen Rand des Bereichs auf die Registerkarte Eigenschaften. Blenden Sie auf der Registerkarte Allgemein Allgemein Aussehen ein. Ändern Sie Schriftartenname in Arial.
  4. Blenden Sie Position ein, und ändern Sie die Option für Horizontale Ausrichtung in Zentriert Horizontal zentriert ausrichten.
  5. Klicken Sie auf Anwenden.
  6. Klicken Sie im oberen Teil des Bereichs auf die Schaltfläche Zurück Zurück, um zur Registerkarte Anzeige Anzeige zurückzukehren.
  7. Ändern Sie unter Überschrift neben Unterstrichen die Unterstreichungsfarbe der Überschrift in Grau 20 %.
  8. Ändern Sie neben Hintergrund die Hintergrundfarbe der Überschrift in Oxidblau.

Zeilen

Sie können den Text des gesamten Tabellenrahmens in eine Schriftart Ihrer Wahl ändern.

  1. Blenden Sie auf der Registerkarte Anzeige Anzeige ggf. Zeilen ein. Klicken Sie neben Text auf die Schaltfläche Zeilentextsymbol.

    Der Bereichsstatus wird geändert.

  2. Klicken Sie am oberen Rand des Bereichs ggf. auf die Registerkarte Eigenschaften.
  3. Blenden Sie auf der Registerkarte Allgemein Allgemeindie Option Aussehen ein, und ändern Sie den Schriftartennamen in Arial. Klicken Sie auf Anwenden.
  4. Klicken Sie auf die Schaltfläche Zurück Zurück, um zur Registerkarte Anzeige Anzeige zurückzukehren.

    Sie können die Hintergrundfarbe alternierender Zeilen anpassen, um die Übersichtlichkeit der Tabelle zu verbessern.

  5. Ändern Sie unter Zielen neben Hintergrund 2 die Farbe des Zeilenhintergrunds 2 in Grau 10 %.
  6. Verringern Sie den Zeilenwert für Hintergrund 1 auf 1 Zeile.
  7. Verringern Sie den Zeilenwert für Hintergrund 2 auf 1 Zeile.

Ändern des Tabellenrahmenfeldes

  1. Klicken Sie im Bereich Inhalt mit der rechten Maustaste auf das Element Tabellenrahmen, und klicken Sie dann auf Öffnen.

    Die Attributtabelle USA_States_Generalized wird geöffnet.

  2. Klicken Sie auf dem Menüband unter Tabelle auf die Registerkarte Ansicht. Klicken Sie in der Gruppe Feld auf Felder Felder, um die Ansicht Felder der Tabelle zu öffnen.
  3. Suchen Sie die Tabellenzeile mit dem Feldnamen POP2012 und dem Alias Population.
  4. Doppelklicken Sie in der Spalte "Zahlenformat" für diese Zeile auf den Zellenwert Numerisch, um die Schaltfläche Anzeigeformatierung für numerische Feldtypen festlegen anzuzeigen.
  5. Klicken Sie auf die Schaltfläche, um das Dialogfeld Zahlenformat zu öffnen.
  6. Aktivieren Sie das Kontrollkästchen Tausender-Trennzeichen anzeigen, und klicken Sie auf OK.
  7. Klicken Sie auf dem Menüband auf der Registerkarte Felder in der Gruppe Änderungen auf Speichern Speichern.
  8. Schließen Sie die Ansicht "Felder" der Tabelle, und schließen Sie die Tabelle.
  9. Klicken Sie im Bereich Inhalt mit der rechten Maustaste auf das Feld Population, und klicken Sie dann auf Eigenschaften.
  10. Klicken Sie im Bereich Element unter Anzeige neben Datentext auf die Schaltfläche Zeilentextsymbol.

    Der Bereichsstatus wird geändert.

  11. Klicken Sie am oberen Rand des Bereichs ggf. auf die Registerkarte Eigenschaften.
  12. Blenden Sie auf der Registerkarte Allgemein Allgemein Position ein. Klicken Sie neben Horizontale Ausrichtung auf Rechts Rechtsbündig, und klicken Sie auf Übernehmen.

    Das nachstehende Bild zeigt einen Teil des Tabellenrahmens, den Sie geändert haben:

    Teil des geänderten Tabellenrahmens der Tabelle

  13. Klicken Sie auf der Symbolleiste für den Schnellzugriff oben im ArcGIS Pro-Fenster auf die Schaltfläche Speichern Speichern, um das Projekt zu speichern.

Kartenserie

Tabellenrahmen werden in Kartenserien ebenfalls dynamisch aktualisiert. Eine Kartenserie ist eine Sammlung von Kartenseiten (auch als Kartenblätter bezeichnet), die aus einem einzigen Layout erstellt wird, mit dem ein geographischer Bereich dargestellt wird. Auf jeder Kartenseite wird über das Layout und die Iteration über eine Reihe von Kartenausdehnungen ein Teil des größeren geographischen Bereichs angezeigt. In diesem Beispiel erstellen Sie eine Kartenserie auf Grundlage der Bundesstaaten. Die Tabelle wird auf jeder Seite automatisch aktualisiert, sodass jeweils nur die in der Ausdehnung sichtbaren Bundesstaaten sichtbar sind.

  1. Klicken Sie auf dem Menüband auf die Registerkarte Layout. Klicken Sie in der Gruppe Seite einrichten auf das Dropdown-Menü Kartenserie und dann auf Räumlich.
  2. Stellen Sie im Dialogfeld Eigenschaften: Layout unter Index-Layer sicher, dass der Layer USA_States_Generalized ausgewählt ist und im Namensfeld sowie Sortierfeld der Eintrag STATE_NAME ausgewählt wurde.
  3. Klicken Sie auf OK.

    Eine Kartenserie wird erstellt und der Tabellenrahmen aktualisiert, sodass die Bundesstaaten in der sichtbaren Ausdehnung des Kartenrahmens angezeigt werden.

    Bereich "Inhalt" für eine Kartenserie

  4. Doppelklicken Sie im Bereich Inhalt auf einige Bundesstaaten, um zu sehen, wie Kartenrahmen und Tabellenrahmen aktualisiert werden.

    Kartenserien mit einer dynamischen Tabelle

  5. Klicken Sie auf der Symbolleiste für den Schnellzugriff auf die Schaltfläche Speichern Speichern, um das Projekt zu speichern.

Verwandte Themen