Skip To Content

Lernprogramm: Erstellen und Ändern eines Berichts

Komplexität: EinsteigerErforderliche Daten: ArcGIS Tutorial Data for Desktop

In diesem Lernprogramm erfahren Sie, wie Sie aus einer Tabelle in einer File-Geodatabase einen Bericht erstellen und diesen anschließend weiteren Erfordernissen entsprechend ändern.

In diesem Szenario sind Sie als GIS-Analyst bei einer führenden Orangensaft-Vertriebsgesellschaft tätig. Ihr Vorgesetzter hat Sie gebeten, für ein Stakeholder-Meeting am nächsten Vormittag einen Umsatzbericht mit nach County-Unterregion aufgeschlüsselten Umsatzdaten zu generieren. Sie haben eine File-Geodatabase-Tabelle mit den Umsatzinformationen für das zweite Quartal der drei Countys in Ihrem Zuständigkeitsbereich erhalten. Bei diesem Meeting geht es jedoch nur um Imperial County, da seitens der Stakeholder ein Rückzug aus dieser Region erwogen wird. Sie wurden gebeten, eine PDF-Datei des endgültigen Berichts bereitzustellen, die für alle Stakeholder freigegeben werden kann.

Abrufen der Daten

Die Daten für dieses Lernprogramm können auf ArcGIS Online heruntergeladen werden.

  1. Wechseln Sie zur Webseite mit der Elementbeschreibung des Lernprogramms "Bericht" auf arcgis.com.
  2. Klicken Sie auf Herunterladen, um die Datei lokal zu speichern.
  3. Entzippen Sie die heruntergeladene Datei.

Gestalten des Berichts

Zunächst müssen Sie einen speziell auf dieses Szenario abgestimmten Bericht erstellen. Sie verwenden den Bereich Neuen Bericht erstellen, um die Daten zu konfigurieren, Feldgruppierung und -sortierung anzuwenden, Summenstatistiken hinzuzufügen und eine Vorlage sowie ein Styling-Design auszuwählen, bevor Sie den Bericht erstellen. Weitere Informationen zu diesem Bereich finden Sie unter Hinzufügen eines neuen Berichts zu Ihrem Projekt.

  1. Öffnen Sie ArcGIS Pro. Melden Sie sich ggf. bei ArcGIS Online an.
  2. Erstellen Sie ohne Vorlage ein neues Projekt.
  3. Klicken Sie auf der Registerkarte Einfügen in der Gruppe Projekt auf Neuer Bericht Neuer Bericht, um den Bereich Neuen Bericht erstellen zu öffnen.
  4. Ändern Sie im Bereich Neuen Bericht erstellen den Namen des Feldes Berichtsname zu Total Sales Q2. Weitere Informationen zu den Einstellungen auf dieser Seite des Bereichs finden Sie unter Festlegen der Datenquelle.
  5. Klicken Sie unter der Überschrift Datenquelle auf die Schaltfläche "Durchsuchen" Durchsuchen, um zur Tabelle Q2_SalesData in der File-Geodatabase zu navigieren, die Sie zuvor gespeichert haben. Klicken Sie auf OK.
  6. Klicken Sie auf Weiter, um mit den Optionen unter Daten filtern fortzufahren. Weitere Informationen zu den Einstellungen auf dieser Seite des Bereichs finden Sie unter Filtern von Berichtsdaten.
  7. Erweitern Sie auf der Seite Daten filtern das Menü Zeilen, und wählen Sie Nach Ausdruck filtern aus.
  8. Klicken Sie unter Ausdruck auf die Schaltfläche Neuer Ausdruck Hinzufügen.

    Der Abfrage-Manager wird angezeigt. Er enthält eine neue Klausel.

  9. Legen Sie in der neuen Klausel für den Ausdruck Where Region is equal to 'Imperial County' fest, und klicken Sie auf die Schaltfläche "Überprüfen" Analysieren.
  10. Deaktivieren Sie unter der Überschrift Felder die Felder OID und Region, um sie aus dem endgültigen Bericht auszuschließen.
  11. Ziehen Sie May_TotalSales zwischen Apr_TotalSales und Jun_TotalSales.
  12. Klicken Sie auf Weiter, um mit den Optionen unter Daten organisieren fortzufahren. Weitere Informationen zu den Einstellungen auf dieser Seite des Bereichs finden Sie unter Sortieren von Berichtsdaten.
  13. Öffnen Sie auf der Seite Daten organisieren unter der Überschrift Gruppierung und Sortierung in der Spalte Gruppierung das Dropdown-Menü (Element hinzufügen), und wählen Sie SubRegion aus. Für die Gruppensortierung ist standardmäßig Aufsteigend festgelegt.
  14. Öffnen Sie in der Spalte Sortierung das Dropdown-Menü (Element hinzufügen), und wählen Sie RepName aus. Ändern Sie die Sortierrichtung zu Absteigend, sodass die Namen aller Vertriebsbeauftragten innerhalb jeder Gruppe von Z bis A aufgeführt werden.
  15. Definieren Sie unter der Überschrift Summenstatistik die folgenden Feld-Statistik-Kombinationen:

    RepName

    Count

    Apr_TotalSales

    Summe

    May_TotalSales

    Summe

    Jun_TotalSales

    Summe

  16. Klicken Sie auf Weiter, um mit den Optionen unter Bericht gestalten fortzufahren. Weitere Informationen zu den Einstellungen auf dieser Seite des Bereichs finden Sie unter Gestalten des Berichts.
  17. Klicken Sie auf der Seite Bericht gestalten unter der Überschrift Anzeige auf das Dropdown-Menü Vorlage, und vergewissern Sie sich, dass die Vorlage Attributliste mit Gruppierung ausgewählt ist.
  18. Klicken Sie auf das Dropdown-Menü Styling, und wählen Sie das Styling-Design Kühle Farbtöne aus.
  19. Klicken Sie auf das Dropdown-Menü Ränder, und wählen Sie die Option Schmal aus.

    Die Maße für den aktuellen Rand werden unter dem Dropdown-Menü Ränder angezeigt. Randbereiche sind in der Berichtsansicht abgeschnitten. Sie sind jedoch sichtbar, wenn der Bericht exportiert wird.

  20. Klicken Sie auf Fertig stellen, um den Bericht mit der aktuellen Konfiguration zu erstellen.

Der Bericht wird dem Projekt hinzugefügt und geöffnet.

Exportieren des Berichts als PDF-Datei

Im nächsten Schritt wird der Bericht exportiert und freigegeben. Ein Bericht kann als PDF-Datei oder als Berichtsdatei freigegeben werden. In diesem Szenario hat Ihr Vorgesetzter eine PDF-Datei angefordert.

  1. Stellen Sie sicher, dass die Berichtsansicht aktiviert ist. Klicken Sie auf der Registerkarte Freigeben in der Gruppe Export auf PDF PDF.
  2. Navigieren Sie im Dialogfeld Bericht exportieren zum Speicherort für die PDF-Datei.
  3. Aktualisieren oder akzeptieren Sie den Dateinamen.
  4. Aktivieren Sie die Option Schriftarten einbetten, damit der exportierte Bericht auch auf Computern korrekt angezeigt werden kann, auf denen die im Bericht verwendete Schriftart nicht installiert ist.
  5. Klicken Sie auf Speichern.

    Nach Beenden des Exports wird die PDF in Ihrem Standard-PDF-Viewer geöffnet. Sie kann nun für Ihren Vorgesetzten freigegeben werden.

Ändern des vorhandenen Berichts in der Berichtsansicht

Ihr Vorgesetzter hat sich den PDF-Bericht angesehen und mit einigen Änderungen zurückgeschickt. Sie nehmen nun über das Menüband Bericht zum Ändern des Berichts die folgenden Aktualisierungen vor: Sie heben die SubRegion hervor, beziehen das Feld Region ein und sortieren die Namen der Vertriebsbeauftragten in alphabetischer Reihenfolge.

  1. Öffnen Sie bei Bedarf den zuvor erstellten Bericht "Total Sales Q2". Ebenso wie andere Projektelemente werden Berichte im Bereich Katalog und in der Katalogansicht in einer entsprechenden Kategorie aufgeführt.
  2. Klicken Sie im Bereich Inhalt auf den Abschnitt Gruppenkopf: SubRegion, um diesen Abschnitt zu aktivieren.
  3. Klicken Sie in der Ansicht auf das Element {SubRegion}, um es auszuwählen.

    Klicken Sie im Bereich Inhalt mit der rechten Maustaste auf das Element Gruppenkopf: Feldwerttext, und klicken Sie auf die Schaltfläche Auf ausgewählte Elemente zoomen , wenn Sie Schwierigkeiten haben, das Element anzuzeigen.

  4. Ändern Sie auf der Registerkarte Format in der Gruppe Textsymbol unter Text den Wert für Schriftschnitt des Textsymbols zu Fett und die Textfarbe zu einem dunklen Blauton.
  5. Erweitern Sie im Bereich Inhalt den Pfeil neben Gruppenfuß: SubRegion. Um alle Textelemente gleichzeitig auszuwählen, klicken Sie auf das erste Textelement in der Liste, und halten Sie die Umschalttaste gedrückt, während Sie auf das letzte Element in der Liste klicken. Alle Textelemente im Bereich Inhalt und in der Berichtsansicht sind ausgewählt.
  6. Ändern Sie auf der Registerkarte Format in der Gruppe Textsymbol die Textfarbe zu einem Mittelblau.
  7. Klicken Sie im Bereich Inhalt oder in der Berichtsansicht auf den Abschnitt Details des Berichts, um ihn zu aktivieren.
  8. Klicken Sie auf der Registerkarte Einfügen in der Gruppe Daten auf die Schaltfläche Feld Felder.
  9. Legen Sie im Dialogfeld Feldwert einfügen für Feld die Option Region fest, und klicken Sie auf OK.
  10. Klicken Sie in der Berichtsansicht auf den Abschnitt Details, in dem das Feld angezeigt werden soll. Alternativ können Sie das Feld platzieren, indem Sie innerhalb des aktivierten Abschnitts einen Rahmen aufziehen.
  11. Klicken Sie im Bereich Inhalt mit der rechten Maustaste auf den Berichtstitel (Total Sales Q2) und dann auf Eigenschaften.
  12. Klicken Sie auf die Registerkarte Gruppierung und Sortierung.
  13. Ändern Sie Sortierrichtung neben RepName zu Aufsteigend.
  14. Klicken Sie auf OK, um die Änderung zu übernehmen.
  15. Klicken Sie bei aktiver Berichtsansicht auf der Registerkarte Freigeben in der Gruppe Exportieren auf PDF PDF, um eine neue PDF zu erstellen, in der die Aktualisierungen enthalten sind.
  16. Navigieren Sie im Dialogfeld Bericht exportieren zum Speicherort für die PDF-Datei.
  17. Aktualisieren oder übernehmen Sie den Dateinamen, und aktivieren Sie die Option Schriftarten einbetten.
  18. Klicken Sie auf Speichern.

    Sie werden aufgefordert zu bestätigen, dass Sie die vorhandene PDF-Datei überschreiben möchten. Geöffnete PDF-Dateien können nicht überschrieben werden.

Der aktualisierte Bericht kann nun für Ihren Vorgesetzten und die Stakeholder freigegeben und für die Entscheidung herangezogen werden, ob der Vertrieb von Orangensaft in Imperial County fortgesetzt werden soll.

Zusammenfassung

In diesem Lernprogramm haben Sie im Bereich Neuen Bericht erstellen einen Bericht aus einer Tabelle in einer File-Geodatabase erstellt. Dazu haben Sie die Gruppierung, Sortierung und Summenstatistik definiert, eine Vorlage und ein Styling-Design ausgewählt und die exportierte Seite eingerichtet. Sie haben die Eigenschaften von Elementen – u. a. die Schriftart und Farbe für den Text sowie die Gruppierung und Sortierung – in einem vorhandenen Bericht aktualisiert und ein neues Feld hinzugefügt. Und schließlich haben Sie einen Bericht zum einen als neue PDF-Datei exportiert und zum anderen eine bereits vorhandene PDF-Datei überschrieben.

Verwandte Themen