Skip To Content

SAP HANA database requirements for ArcGIS 10.7.x and ArcGIS Pro 2.4

Visit Esri Support for information on the Esri Supported Environment Policy.

Supported database versions

The following SAP HANA versions and service pack releases are supported for use with ArcGIS:

SAP HANA 1.0 SPS09 - SPS12

SAP HANA 2.0 SPS02 and SPS03

Supported operating systems

DatabaseSupported Operating Systems

SAP HANA 1.0 SPS09 - SPS12

SAP HANA 2.0 SPS02 and SPS03

SAP HANA is available either in the cloud or as a pre-configured system on Linux. Contact SAP for the available configurations.

Database requirements/limitations

  • Branch versioning is supported in SAP HANA 2 SPS02.
  • When using SAP HANA 1.0 SPS09 - SPS12, ODBC connections must set parameter SPATIALTYPES=1
  • Geodatabase functionality is only supported in SAP HANA 2.0 SPS02.
    Note:

    You cannot create or connect to geodatabases in SAP HANA from ArcMap, ArcCatalog, ArcGlobe, or ArcScene.

Software required to connect to a DBMS

Your client machine (for example, the one running ArcGIS Pro or ArcMap) will need to have the appropriate client files installed for the RDBMS you are using. These client files are available from their respective RDBMS vendors, but some are also available on My Esri as a convenience. RDBMS client files available from My Esri are IBM Db2 and Microsoft SQL Server. Client files for Dameng, IBM Informix, IBM Netezza, Oracle, SAP HANA, and Teradata are not available on My Esri and must be obtained from the RDBMS vendors. See Database clients for more information.