Skip To Content

Rubbersheet features

In the Modify Features pane, Transform Transform includes linear and natural neighbor interpolation methods for rubber sheeting features. You can transform features that are visible and editable by selecting them, or transform all features on specified layers.

Two-point displacement links define the origin and target location of the features you are transforming. To prevent specific vertices from moving, you can add anchor points and snap them to features, and draw area polygons to further limit the vertices that are transformed.

After transforming features, displacement links are automatically deleted and the target points are converted to anchor points.

Rubber sheeting is commonly used after a transformation to further refine the alignment accuracy of the transformed features.

For steps to transform features using Affine or Similarity transformation methods, see Transform features.

  1. On the Edit tab, in the Snapping group, enable your snapping preferences.
    Tip:

    You can press and hold the spacebar to temporarily turn off snapping as you create anchor points, and draw displacement links or rubber sheet area polygons.

  2. On the Edit tab in the Features group, click Modify Modify Features.

    The Modify Features pane appears.

  3. Expand Alignment and click Transform Transform.

    The tool opens in the pane.

  4. Select the features you want to transform using one of the following methods:
    • Click the Selected feature tab, and use Active Select Active Select to select the feature you want to transform.
      Note:

      To refine your selection, right-click a feature in the pane and use the commands on the context menu.

      Selection context menu

    • Click the Layer tab and choose the layer on which the features reside. This method transforms all features on the selected layer.
  5. Click the Transformation Method drop-down arrow and choose an interpolation method.
    • Rubbersheet (Linear)—Is slightly faster and produces good results when you have many links spread uniformly across the transformation area. This method does not take into account the natural neighborhood.
    • Rubbersheet (Natural Neighbor)—Is slower but more accurate when your displacement links are scattered across the transformation area. This method is similar to the inverse distance weighting interpolation method.
  6. Draw a suitable number of two-point displacement links that define the origin and target location for the features you are transforming. There is no limit to the number of links you can draw.
    1. Click Add new links Add New Link.

      The segment construction toolbar appears at the bottom of the map.

      Segment construction toolbar
    2. Snap and click the origin point to an edge or a vertex on the feature you are transforming.
    3. Snap and click the endpoint to the new target location.
    Tip:

    You can save time from drawing links by clicking Load links from file Browse and loading predefined links contained in a link file created with ArcMap. Link files are TAB delimited ASCII text files containing two pairs of x,y coordinate values per row for each link.

    You can load four-column or five-column link files. A four-column link file contains a pair of source and destination coordinate values. A five-column link file contains an ID column (string or numeric) that precedes the columns containing the coordinate values.

    Example contents for a five-column link file.

    3	1032507.603691	1865947.186470	1032507.207115	1865926.170407
    
    2	1032508.350801	1865986.785187	1032509.079486	1866025.405116
    
    1	1032388.666424	1865961.179459	1032361.009572	1865981.280533

  7. Add anchor points to locations you want to hold in place and prevent from moving when the features are transformed.
    1. Click Add anchor points Anchor Point

      The point construction toolbar appears at the bottom of the map.

      Point construction toolbar
    2. Click and snap the anchor pont to an edge or a vertex on the feature you want to constrain.
  8. To further limit the areas to be adjusted and filter out specific vertices, draw one or more area polygons around the vertices you want to transform. There is no limit to the number of area polygons you can draw.
    1. Click Add rubbersheet area Rubbersheet Area.

      The segment construction toolbar appears at the bottom of the map.

      Segment construction toolbar
    2. Click and draw a polygon around the vertices you want to transform. All other vertices will not be transformed.
    3. Double-click or click Finish Finish to complete the polygon.
  9. To delete an anchor point, displacement link, or area polygon, do the following:
    • Click Select Select, select the anchor, link, or area polygon, and press the Delete key or right-click and click Delete on the context menu.
    • To delete all anchor points, displacement links, and area polygons, in the pane, click Delete all links Delete.
  10. Click Transform.

    The features transform, the displacement links are deleted, and the target points convert to anchor points.


In this topic