Skip To Content

Connect to a GIS server

A variety of GIS capabilities are available as web services online. Connecting ArcGIS Pro to a GIS server gives you access to maps, editable features, geoprocessing analysis, and other useful services. The steps in this topic show you how to connect to ArcGIS Server, ArcGIS Online servers, and Open Geospatial Consortium, Inc. (OGC), servers.

Add a GIS server directly to the project

You can connect to an ArcGIS Server site to work with its contents in the project. For example, you may already have an ArcGIS Server connection file (.ags) that was created using ArcMap. You can add these connections to a project.

Similarly, you may already have a WCS Server connection file (.wcs), WFS Server connection file (.wfs), WMS Server connection file (.wms), or WMTS Server connection file (.wmts) that was created using ArcCatalog. You can also add these connections to a project.

  1. On the Insert tab, in the Project group, click the Connections drop-down list Add Database and click Add Server GIS Server.
  2. Browse to and click the server connection file on the local or network computer.
  3. Click OK.

    The ArcGIS server ArcGIS server, WCS service WCS server, WFS service WFS server, WMS service WMS server, or WMTS service WMTS server appears in the Catalog pane or the catalog view in the Servers category Server folder.

  4. Browse into the server to start using the items it contains.

For OGC service connections, an item referencing the existing connection is added to the project.

For ArcGIS server connections only, if the existing connection file defines a user-level connection, an item referencing this connection file is added to the project. If the connection file defines a publisher- or administrator-level connection, a new connection file is created in the project's home folder with the same credentials but providing a user-level access to the server. An item referencing the new connection file is added to the project.

Tip:

You can drag a server connection from Windows Explorer to the Catalog pane or the catalog view to add it to a project. You can also drag these items from folder connections in the project to the Servers category to add them directly to the project. Drag the items within the Catalog pane, between the Catalog pane and catalog view, or between two catalog views. When browsing a folder, you can also right-click a server connection and click Add To Project Add To Project.

Create a new ArcGIS Server connection

You can create a new server connection that will be used in the project. When you connect to an ArcGIS Server site, there are different connection levels allowed: user, publisher, or administrator. A connection's level determines the capabilities allowed on the server when that connection is used. ArcGIS Pro only creates user-level connections to the server.

When you connect, you see a list of items you have permission to access as a user. If you provide a user name and password, you may have permission to see additional items only available to specific users.

Connect to an ArcGIS Server site

If you're connecting to a federated server in ArcGIS Enterprise, you must sign in to the Enterprise portal. The server connection will use the portal's credentials to access content on the server. If you provided a user name and password when you first try to establish a connection, they will not be used. If the server is associated with the active portal, a user name and password cannot be provided.

  1. On the Insert tab, in the Project group, click the Connections drop-down list Add Database and click New ArcGIS Server New ArcGIS Server.

    The Add ArcGIS Server User Connection dialog box appears.

  2. Type the URL of the ArcGIS Server site you want to connect to in the Server URL text box. The URL varies depending on the site configuration.
  3. Type your User Name and Password if appropriate.
  4. If you want to save your user name and password information to avoid entering it each time you connect, check the Save Username/Password check box.
  5. Click OK.

An ArcGIS Server connection file (.ags) is created and saved in the project's home folder. An item referencing this connection file is added to the project, and the server connection ArcGIS server appears in the Catalog pane and the catalog view in the Servers category Server folder.

Connect to ArcGIS Online ready-to-use services

You can sign in to an account on ArcGIS Online or ArcGIS Enterprise to access portal items, web maps, hosted feature services, and so on. However, you can also connect to specific ArcGIS Online servers that provide additional services that allow you to analyze your data or use high-quality data curated by Esri.

  1. On the Insert tab, in the Project group, click the Connections drop-down list Add Database and click New ArcGIS Server New ArcGIS Server.

    The Add ArcGIS Server User Connection dialog box appears.

  2. Type the URL of the ArcGIS Online server you want to connect to in the Server URL text box.

    • http://elevation.arcgis.com/arcgis—Calculate viewsheds, elevation profiles, and elevation summaries.
    • http://hydro.arcgis.com/arcgis—Create watersheds and trace point locations downstream.
    • http://traffic.arcgis.com/arcgis—Visualize traffic incidents as well as live and typical traffic conditions.
    • http://logistics.arcgis.com/arcgis—Perform routing, fleet routing, and other analyses on roads and walkways.
    • http://geocode.arcgis.com/arcgis—Convert addresses and place names into longitude and latitude. If you signed in to ArcGIS Pro through ArcGIS Online, the Online World Geocoding Service is added to your project automatically and is available in your project's Locators folder, in the Locate pane, in What's here?, and in relevant geocoding geoprocessing tools. If you're signed in to ArcGIS Pro through your ArcGIS Enterprise portal, you will need to connect to this GIS server to use the World Geocoding Service.

  3. In the User Name and Password text boxes, type valid ArcGIS Online credentials. Check the Save Username/Password check box to save your credentials. If you are already signed in to an ArcGIS Online organization, you can skip this step.

    Caution:

    Some of the services provided on these servers consume credits from your ArcGIS Online account. Visit the ArcGIS Online service credits page to learn more about service credits.

  4. Click OK.

An ArcGIS Server connection file (.ags) is created in the project's home folder. An item referencing this connection file is added to the project, and the server connection ArcGIS server appears in the Catalog pane and the catalog view in the Servers category Server folder.

Create a new OGC web service connection

If a server provides OGC WCS, WFS, WMS, or WMTS services, you can connect to the service and add either the entire service or individual layers from the service to a map.

  1. On the Insert tab, in the Project group, click the Connections drop-down list Add Database and click the appropriate option.
    • New WCS Server New WCS Server
    • New WFS Server New WFS Server
    • New WMS Server New WMS Server
    • New WMTS Server New WMTS Server

    The appropriate OGC server connection dialog box appears.

  2. Type the URL of the server you want to connect to in the Server URL text box.
  3. If you want to communicate with the service using a specific version of the service specification, click the Version drop-down list and select the appropriate version number. Otherwise, the default version for that service will be used.
  4. If you are creating a WFS, WMS, or WMTS connection, click the Custom request parameters heading and specify any custom request parameters that should be used.
  5. Type your User Name and Password if necessary.
  6. If you want to save your user name and password information to avoid entering it each time you connect, check the Save Username/Password check box.
  7. Click OK.

A WCS Server connection file (.wcs), WFS Server connection file (.wfs), WMS Server connection file (.wms), or WMTS Server connection file (.wmts) is created in the project's home folder. An item referencing this connection file is added to the project, and the WCS service WCS server, WFS service WFS server, WMS service WMS server, or WMTS service WMTS server appears in the Catalog pane and the catalog view in the Servers category Server folder.

Favorite a server

If you add the same GIS server to many projects, favorite that server to simplify the process. The project favorites collection is always available. Add a favorite server to projects without having to remember its location or URL. You can add a favorite server to every new project you create. New server connections of all types can be created directly in the project favorites roaming folder. If your user profile supports roaming, these connections will be available on every computer you use.

Tip:

You can drag any server connection from Windows Explorer to the favorites collection in the Catalog pane or the catalog view. You can also drag these items from the Project tab in the Catalog pane to the favorites collection in the catalog view, or drag them between two catalog views. A copy of the connection file will be saved to the project favorites roaming folder.

Copy a server from another project

A GIS server can be copied from one project to another if both projects are open at the same time.

  1. Browse to the collection of servers in your source project.
    • In the Catalog pane, on the Project tab, double-click Servers.
    • In a catalog view, click Servers in the Contents pane.
  2. Select the appropriate servers, for example, Ctrl-Click each server you want to copy.
  3. Copy the servers.
    • In the Catalog pane, right-click the selected maps and click Copy.
    • In the catalog view, on the Home tab, in the Clipboard group, click Copy Copy.
  4. Browse to the collection of servers in your destination project.
  5. Paste the servers.
    • In the Catalog pane, right-click the Servers container and click Paste.
    • In the catalog view, on the Home tab, in the Clipboard group, click Paste Paste.
Tip:

You can also copy the selected servers by dragging them from the source project to the Servers container in the destination project.

Related topics