Skip To Content

Configuración para editar versiones

En el cuadro de diálogo Opciones, en la pestaña Edición, puede establecer cómo se definen y concilian los conflictos de datos versionados al guardar sus ediciones. Puede mostrar el cuadro de diálogo Administrador de conflictos y revisar interactivamente los conflictos u ocultarlo y conciliar los conflictos automáticamente.

Al editar datos que estén registrados como versionados, está modificando una versión aislada de los mismos datos que pueden estar editando otros usuarios. Las ediciones se rastrean en tablas de sistema. Al guardar sus ediciones, los conflictos de versiones se fusionan en la versión de destino basándose en la configuración que se describe en las siguientes secciones.

Para obtener más información sobre el versionado, consulte Descripción general del versionado.

¿Cómo desea que se resuelvan los conflictos?

Puede establecer que los conflictos de versiones se resuelvan a favor de la versión editada o de la versión de destino. Los conflictos de servicios de entidades registrados como versionados en rama solo se pueden resolver a favor de la versión editada.

  1. En la pestaña Editar, en el grupo Administrar ediciones, haga clic en el selector del cuadro de diálogo OpcionesSelector.
  2. En el cuadro de diálogo Opciones, haga clic en Edición.
  3. Expanda Versionado y elija uno de los ajustes siguientes:
    • A favor de la versión de edición: sobrescribe los conflictos en la versión de destino con sus cambios. Esta es la configuración predeterminada.
    • A favor de la versión de destino: conserva los conflictos en la versión de destino y descarta sus cambios.
      Nota:

      Esta configuración no está disponible para servicios de entidades registrados como versionados en rama.

  4. Haga clic en Aceptar.

    La configuración se guarda y el cuadro de diálogo se cierra.

¿Cómo desea definir los conflictos?

Puede definir un conflicto como una discrepancia entre campos de atributos correspondientes o entre la geometría y los atributos de objetos en la fila de una base de datos. Los conflictos de servicios de entidades registrados como versionados en rama solo se pueden definir como geometría y atributos de objetos en la fila de una base de datos.

  1. En la pestaña Editar, en el grupo Administrar ediciones, haga clic en el selector del cuadro de diálogo OpcionesSelector.
  2. En el cuadro de diálogo Opciones, haga clic en la pestaña Edición.
  3. Expanda Versionado y elija uno de los ajustes siguientes:
    • Por atributo (por columna): identifica un conflicto solo cuando hay discrepancias entre atributos. Esta es la configuración predeterminada.
      Nota:

      Esta configuración no está disponible para servicios de entidades registrados como versionados en rama.

    • Por objeto (por fila): identifica un conflicto cuando hay discrepancias entre la geometría y los atributos de objetos en la fila de la base de datos.
  4. Haga clic en Aceptar.

    La configuración se guarda y el cuadro de diálogo se cierra.

¿Cómo desea revisar los conflictos de varios usuarios?

Al guardar sus ediciones, puede mostrar el cuadro de diálogo Administrador de conflictos y revisar interactivamente los conflictos u ocultar el cuadro de diálogo y conciliarlos automáticamente en función de la configuración.

  1. En la pestaña Editar, en el grupo Administrar ediciones, haga clic en el selector del cuadro de diálogo OpcionesSelector.
  2. En el cuadro de diálogo Opciones, haga clic en la pestaña Edición.
  3. Expanda Versionado y elija uno de los ajustes siguientes:
    • Mostrar Administrador de conflictos y dejarme revisar los conflictos: esta es la configuración predeterminada.
    • Guardar automáticamente las ediciones y no mostrar el Administrador de conflictos: los conflictos se concilian en función de los ajustes actuales y se guardan automáticamente en la versión de destino.
  4. Haga clic en Aceptar.

    La configuración se guarda y el cuadro de diálogo se cierra.