Skip To Content

Scènes

Les cartes sont des représentations de la réalité et intègrent des informations permettant de mieux comprendre le monde qui vous entoure. Les cartes peuvent être tridimensionnelles, grâce aux isolignes, à l'ombrage et aux vues de profil, mais elles ne peuvent représenter qu'un nombre limité d'informations verticales.

Lorsque l'axe vertical est un élément important, ArcGIS Pro permet d'incliner la carte 2D vers le haut et d'afficher des relations spatiales dans une scène 3D. Ces fonctions facilitent l'interprétation des données et peuvent vous aider à découvrir de nouvelles perspectives dans le processus.

L'utilisation de la 3D permet d'intégrer des éléments réels à votre contenu en mettant en évidence certaines influences, telles que les ondulations de terrain et l'étendue 3D des entités, comme les arbres, les bâtiments et la géologie souterraine. En outre, la représentation du contenu SIG quantitatif, comme la population, la température ou les occurrences relatives d'un événement, est généralement plus efficace dans une vue 3D.

Modes d'affichage des scènes

Il existe deux modes d’affichage des scènes :

  • Global : s’utilise avec un contenu réel couvrant une vaste étendue où la courbure de la Terre joue un rôle important.
  • Local : s’utilise avec un contenu couvrant une étendue plus restreinte dans un système de coordonnées projetées, ou lorsque la courbure de la Terre n’est pas nécessaire.

Vue globale
Vue globale des trajectoires de vol et d'ouragan
Vue locale
Vue locale des bâtiments dans une zone d’intérêt

Lorsque vous importez un document ArcGlobe ou ArcScene, le fichier .3dd s’ouvre par défaut en mode global et le fichier .sxd s’ouvre en mode local. Une nouvelle scène vide s’ouvre par défaut en mode global. Toutefois, vous pouvez personnaliser les paramètres par défaut pour les nouvelles cartes et scènes.

Pour ouvrir une nouvelle scène, vous avez la possibilité de créer directement une nouvelle scène globale ou locale. Dans l’onglet Insert (Insertion), cliquez sur le menu New Map (Nouvelle carte) et choisissez New Global Scene (Nouvelle scène globale) Nouvelle visualisation de globes ou New Local Scene (Nouvelle scène locale) Nouvelle vue de la scène. Vous pouvez également cliquer avec le bouton droit sur Maps (Cartes) dans la fenêtre Catalog (Catalogue) pour créer une nouvelle scène dans l’un de ces modes.

Pour changer le mode de vue actuel de votre scène, cliquez sur l’onglet View (Vue) et choisissez Global Vue globale 3D ou Local Local. La scène existante est remplacée pour la vue mise à jour. Si toutefois vous souhaitez afficher la même scène dans le mode local et global côte à côte, vous devez ouvrir une seconde vue de la même carte. Pour ce faire, cliquez sur la fenêtre Catalog (Catalogue), sous Maps (Cartes), développez Project (Projet), puis utilisez le menu contextuel de votre scène et choisissez d’afficher la scène en tant que vue globale ou locale nouvelle. La scène d’origine demeure inchangée et une nouvelle scène est ajoutée au projet. Chaque onglet de vue est étiqueté avec son icône respective qui distingue le type de vue. Organisez les vues en faisant glisser un onglet de vue et en choisissant l’emplacement.

Modes de dessin perspective et parallèle

Vous pouvez également dessiner les scènes en mode perspective ou en mode parallèle. Le dessin perspective est le mode de dessin le plus courant en 3D, dans lequel les entités situées au premier plan apparaissent plus grandes que celles situées à distance. Cette approche correspond à notre manière de voir le monde au quotidien et produit une représentation de contenu 3D réaliste. Le dessin parallèle, en revanche, produit un rendu de vue 3D à l’aide d’une projection parallèle, où les entités ayant la même taille physique sont rendues à l’écran de manière identique, quelle que soit leur distance par rapport à la caméra. Le dessin parallèle est utile pour les dessins architecturaux (par exemple, conceptions de construction de bâtiment ou cartes globales de campus) et pour représenter des données statistiques dans une vue 3D (par exemple, des formes extrudées symbolisant des valeurs numériques telles qu’une population ou un revenu).

Toutes les scènes s’ouvrent dans le mode de vue perspective. Vous pouvez basculer entre les modes de vue Perspective Vue perspective et Parallel (Parallèle) Vue isométrique à l’aide du menu déroulant Drawing Mode (Mode de dessin) du groupe Scene (Scène) situé dans l’onglet View (Vue). Les paramètres sont stockés avec des vues ouvertes lors de l’enregistrement du projet.

Créer une scène 3D

L’environnement 2D-3D intégré vous permet d’utiliser vos données, vos cartes et vos scènes ensemble. Vous pouvez ainsi rapidement passer des cartes aux scènes et les lier pour synchroniser l'affichage.

Le contenu drapé 2D apparaît dans la catégorie Couches 2D de la fenêtre Contenu et toutes les couches 3D figurent dans la catégorie Couches 3D. Les couches KML possèdent leur propre catégorie dans les scènes, Couches KML, car une couche KML peut contenir à la fois des nœuds 2D et 3D dans le même fichier.

Convertir une carte en scène

Lorsque vous créez une scène 3D, vous commencez généralement avec une carte 2D existante. Pour convertir une carte existante en scène, utilisez la fenêtre Catalog (Catalogue), développez le nœud Maps (Cartes), cliquez avec le bouton droit sur la carte à convertir, pointez sur Convert (Convertir) et sélectionnez To Global Scene (Vers Scène globale) Convertir ou To Local Scene (Vers Scène locale) vers Scène locale. Si la carte est actuellement ouverte en tant que vue, vous pouvez également cliquer sur l’onglet View (Vue). Dans le groupe View (Vue), cliquez sur Convert (Convertir) pour choisir le mode de scène dans lequel vous voulez effectuer la conversion.

Lorsque vous convertissez une carte en scène, la carte existante demeure inchangée et un nouvel élément de scène est créé dans votre projet. Toutes les couches de la nouvelle scène ont été copiées à partir de la carte et leurs versions mises à jour apparaissent maintenant dans la vue 3D. Pour savoir quels résultats vous pouvez obtenir lors de la conversion de 2D en 3D, reportez-vous à la rubrique Questions fréquentes concernant les cartes dans ArcGIS Pro.

Ajouter une symbologie 3D aux couches 2D

Par défaut, certaines couches s'affichent initialement sous forme de couches 2D dans la scène. Ces couches sont drapées sur la surface du sol de la scène, comme des images aériennes, et ne présentent aucune symbologie 3D. La fenêtre Contenu affiche ces couches dans la catégorie Couches 2D.

Pour appliquer une symbologie 3D à une couche (génération d'emprises ou affichage de lignes sous forme de tubes, par exemple), faites glisser la couche vers le groupe Couches 3D de la fenêtre Contenu.

Pour plus d'informations, reportez-vous à la rubrique Extruder des entités en symbologie 3D.

Lorsque vous affichez d'abord une couche en 3D, il est important de définir les propriétés d'altitude pour que les entités apparaissent à la hauteur voulue dans la vue. Les principales options sont les suivantes : Au sol, Par rapport à une surface ou A une hauteur absolue. Les paramètres d'altitude sont disponibles dans l'onglet Altitude de la boîte de dialogue Propriétés de la couche.

Lier des cartes et des scènes

Vous pouvez afficher simultanément des représentations 2D et 3D de vos données en ancrant une vue cartographique à côté d'une scène. Pour obtenir une meilleure intégration, liez la navigation des vues en activant l’option Link Views (Lier des vues) de l’onglet View (Vue).

Notez qu'une carte et une scène sont des éléments distincts dans le projet, même si elles font référence aux mêmes données source. Vous pouvez donc modifier la visibilité d'une couche dans une carte ou une scène sans pour autant changer sa visibilité dans une autre vue. En revanche, les mises à jour apportées aux entités sont répercutées dans toutes les vues de ces données.

Propriétés d'éclairage

Lorsque vous créez des scènes, vous pouvez également définir des propriétés d'éclairage, en indiquant notamment l'heure du jour, les ombres éventuellement projetées par le soleil ou encore la quantité de lumière ambiante utilisée. En mode global, vous pouvez également simuler la diffusion atmosphérique.

Pour accéder aux propriétés d'éclairage des cartes et des scènes, cliquez avec le bouton droit sur la scène dans la fenêtre Contenu, sélectionnez Propriétés puis cliquez sur l'onglet Eclairage.

Surfaces d’altitude

Vous pouvez également définir dans les scènes une ou plusieurs surfaces sur lesquelles placer d'autre contenu. Chaque scène a une surface d'altitude par défaut intitulée Sol. Vous pouvez définir autant de surfaces que nécessaire, par exemple Géologie 1, Géologie 2, Ozone, etc. Chaque surface peut avoir plusieurs sources de données la décrivant, y compris des rasters, des TIN et des services d'altitude. Vous pouvez même créer des surfaces thématiques à partir des résultats analytiques, comme la gravité des crimes ou la température de la surface de la mer, puis draper d'autres couches sur elles.

Vous pouvez configurer des surfaces d’altitude pour une scène, par exemple créer des surfaces, les mettre à jour et les supprimer, mais également contrôler la navigation au-dessus et au-dessous du sol. Pour ajouter une source d’altitude à la surface au sol, utilisez le menu Add Data (Ajouter des données) Ajouter des données dans l’onglet Map (Carte), sélectionnez Elevation Source (Source d’altitude) Ajouter une source d’altitude et accédez aux données d’altitude souhaitées. Cette opération ajoute la source d’altitude au sol et la rend visible dans la fenêtre Contents (Contenu). Vous pouvez également utiliser le menu contextuel du groupe Elevation Surfaces (Surfaces d’altitude) dans la fenêtre Contents (Contenu) pour ajouter une surface personnalisée et configurer sa source. Tous les paramètres d’apparence ou de comportement concernant les surfaces d’altitude, tels que la navigation souterraine, se situent dans l’onglet Appearance (Apparence) de la couche de surface sélectionnée.

Analyse 3D interactive

Il est possible d’analyser les scènes pour obtenir des résultats de visibilité. Les outils d’analyse exploratoire 3D génèrent des objets temporaires dans une scène et offrent un moyen direct d’obtenir une réponse immédiate aux questions d’analyse 3D. Vous pouvez effectuer des calculs concernant la ligne de visée, le champ de vision et le dôme de vision. L’outil Slice (Coupe) découpe visuellement l’affichage pour dévoiler le contenu masqué. Tous les objets prennent en charge les ajustements interactifs, ce qui permet d’obtenir un retour immédiat pour les résultats d’analyse. Les résultats d’analyse peuvent être convertis en entités afin de les réutiliser dans le cadre de votre processus.

Rubriques connexes