Skip To Content

Ajouter des cartes et des scènes à un projet

Vous pouvez créer des cartes dans ArcGIS Pro ou les importer à partir d'autres applications ArcGIS Desktop. Vous pouvez également importer des fichiers cartographiques et de mise en page ArcGIS Pro créés dans d'autres paquetages de projet et de carte. Les cartes peuvent utiliser des données provenant de sources locales, en ligne ou d’entreprise.

Créer une carte ou une scène

ArcGIS Pro propose plusieurs types de cartes. Il peut s'agir de cartes pour afficher des données bidimensionnelles, de scènes pour afficher des données tridimensionnelles ou de cartes pour créer des fonds de cartes personnalisés.

  1. Sous l'onglet Insertion, dans le groupe Projet, cliquez sur le menu déroulant Nouvelle carte.
  2. Cliquez sur Nouvelle carte Nouvelle carte, Nouvelle scène Nouvelle vue de la scène ou Nouveau fond de carte Nouveau fond de carte.
  3. La nouvelle carte s'ouvre et est ajoutée au projet.
Astuce:

Vous pouvez également cliquer avec le bouton droit sur l'espace vide au bas de la fenêtre Catalogue pour créer des cartes, des scènes ou des fonds de carte.

Importer une carte ou un paquetage de carte

Vous pouvez importer dans votre projet des documents créés dans ArcMap (.mxd), ArcGlobe (.3dd) ou ArcScene (.sxd). Les paquetages de carte, ainsi que les fichiers cartographiques et de mise en page ArcGIS Pro (.mapx et .pagx) peuvent également être importés. Les paquetages et les fichiers disponibles sur le portail actif sont d’abord téléchargés. Le fichier cartographique, de document ou de paquetage est ouvert et une copie de chaque carte et mise en page est ajoutée au projet. Les paquetages de carte sont décompressés dans le dossier <Documents utilisateur>\ArcGIS\Packages.

Remarque :

Vous pouvez ajouter à un projet des fichiers cartographiques et de mise en page (.mapx et .pagx), ainsi que des paquetages de cartes (.mpkx) créés avec n'importe quelle version d’ArcGIS Pro 1.x. Vous ne pouvez toutefois pas ajouter à un projet des fichiers de mise en page et cartographiques qui utilisent ArcGIS Pro 2.x via ArcGIS Pro 1.x. Lorsqu’un fichier cartographique créé avec ArcGIS Pro 2.3 est ajouté à un projet avec la version 2.0, la carte est ajoutée mais est rétrogradée de manière appropriée pour la version antérieure d’ArcGIS Pro. Un paquetage de carte créé avec ArcGIS Pro 2.x contient à la fois les versions 1.x et 2.x de la carte, de telle sorte que le paquetage puisse être ajouté à n’importe quel projet. La carte correspondant à la version d’ArcGIS Pro que vous utilisez est ajoutée.

Lorsque vous importez un document ArcMap, au moins une carte et une mise en page sont ajoutées au projet. Le format des blocs de données et de la mise en page d'origine est converti au format de carte et de mise en page ArcGIS Pro avant l'ajout des éléments au projet. Le bloc de données ou la mise en page du document d'origine est ouvert dans une vue.

Les documents ArcGlobe et ArcScene sont importés dans ArcGIS Pro sous forme de scènes. Par défaut, les documents ArcGlobe s'ouvrent en mode d'affichage global et les documents ArcScene s'ouvrent en mode d'affichage local. Vous pouvez basculer entre ces deux modes à partir de l'onglet Vue du ruban.

Si la carte ArcMap importée n’inclut pas les références des styles, les styles ne sont pas importés dans le projet. Vous devez importer les styles ArcMap séparément si vous souhaitez les référencer dans le projet.

  1. Sous l'onglet Insertion, dans le groupe Projet, cliquez sur Importer une carteImporter une carte.
  2. Recherchez les cartes que vous souhaitez importer, soit dans votre projet, soit en ligne.
  3. Cliquez sur une ou plusieurs cartes pour les ajouter au projet.
  4. Cliquez sur  OK.

    Une fois l’importation terminée, cliquez sur le bouton de notification Notifications. La fenêtre Notifications contient une notification pour chaque carte importée. Survolez une notification et cliquez sur View Results (Afficher les résultats) pour afficher un rapport qui répertorie toutes les erreurs et tous les avertissements rencontrés, ainsi que les messages d’information concernant le processus d’importation.

    Toutes les notifications d’importation disparaissent à la fermeture d’un projet ; elles ne réapparaissent pas dans la fenêtre Notifications lorsque le projet s’ouvre. Toutefois, ces rapports sont enregistrés en tant que fichiers XML dans un sous-dossier ImportLogs du dossier d'accueil du projet. Accédez à ce dossier dans la vue du catalogue, affichez le panneau Details (Détails) et cliquez sur ces fichiers pour afficher les rapports.

Astuce:

Vous pouvez faire glisser une carte ou un paquetage de carte à partir de l’Explorateur Windows et le déposer dans la fenêtre Catalog (Catalogue) ou dans la vue du catalogue pour l’importer dans un projet.

La description ou les métadonnées complètes de la carte d'origine sont importées dans le projet avec la carte. Chaque élément importé dispose d'une copie des métadonnées d'origine comme point de départ.

Certains formats de données disponibles dans d'autres applications ArcGIS Desktop ne sont pas pris en charge dans ArcGIS Pro. Les couches qui référencent ces formats dans la carte d'origine risquent de ne pas s'afficher correctement une fois importées. Convertissez ces jeux de données dans un format pris en charge à l'aide des outils de géotraitement de conversion des données. Ensuite, les couches importées peuvent être connectées aux jeux de données convertis.

Il existe des différences d'affichage entre les applications ArcGIS Desktop et ArcGIS Pro en raison des améliorations du moteur d'affichage.

Les cartes importées ne sont pas connectées aux fichiers dont elles sont issues. Les modifications qui seront apportées à la carte d’origine n’apparaîtront pas automatiquement dans le projet.

Copier une carte à partir d’un autre projet

Vous pouvez copier des cartes depuis un projet vers un autre si les deux projets sont ouverts en même temps.

  1. Accédez à la collection de cartes de votre projet source.
    • Dans la fenêtre Catalog (Catalogue), sur l’onglet Project (Projet), développez Maps (Cartes).
    • Dans une vue du catalogue, cliquez sur Maps (Cartes) dans la fenêtre Contents (Contenu).
  2. Sélectionnez les cartes appropriées, par exemple à l’aide de la combinaison Ctrl-Clic sur chaque carte à copier.
  3. Copiez les cartes.
    • Dans la fenêtre Catalog (Catalogue), cliquez avec le bouton droit sur les cartes sélectionnées et sélectionnez Copy (Copier).
    • Dans une vue du catalogue, sur l’onglet Home (Accueil), dans le groupe Clipboard (Presse-papiers), cliquez sur Copy (Copier) Copier.
  4. Accédez à la collection de cartes de votre projet de destination.
  5. Collez les cartes.
    • Dans la fenêtre Catalog (Catalogue), cliquez avec le bouton droit sur le container Maps (Cartes) et sélectionnez Paste (Coller).
    • Dans une vue du catalogue, sur l’onglet Home (Accueil), dans le groupe Clipboard (Presse-papiers), cliquez sur Paste (Coller) Coller.
Astuce:

Vous pouvez également copier les cartes sélectionnées en les faisant glisser depuis le projet source et en les déposant sur le container Maps (Cartes) dans le projet de destination.

Ajouter une carte ou une scène Web à partir d’un portail

Vous pouvez partager dans votre organisation les cartes et les scènes créées dans votre projet en les publiant sur votre portail en tant que cartes ou scènes Web. Vous pouvez ensuite ajouter une carte ou une scène Web à votre projet à partir du portail actif.

La carte de votre projet est associée à la carte Web d'origine. Si la carte Web est mise à jour sur le portail, une notification apparait dans ArcGIS Pro indiquant que vous pouvez mettre à jour la carte dans votre projet afin de la faire correspondre. Si vous souhaitez continuer à utiliser la version de la carte que vous possédez déjà, fermez la notification. Procédez de la même manière pour ajouter et mettre à jour des scènes Web.

Ajouter une carte ou une scène Web au projet

Vous pouvez ajouter une carte ou une scène Web à votre projet à partir du portail actif. La carte ou la scène de votre projet est associée à la carte ou la scène Web d'origine.

  1. Dans la fenêtre Catalogue, cliquez sur l'onglet Portail ou dans la vue Catalogue de la fenêtre Contenu, cliquez sur Portail.
  2. Accédez à la carte ou la scène Web que vous souhaitez utiliser ou recherchez-la dans les collections Mon contenu, Groupes ou L'intégralité du portail.
  3. Cliquez avec le bouton droit sur l’élément et sélectionnez Add And Open (Ajouter et ouvrir) Ajouter.

    La carte ou la scène Web d'origine est convertie au format de carte ArcGIS Pro avant d'être ajoutée au projet. La carte ou la scène s'ouvre dans une vue. Dans la fenêtre et dans la vue Catalog (Catalogue), le lien bleu Lierfigurant sur son icône indique qu’elle est liée à la carte ou la scène Web du portail.

Astuce:

Les cartes et les scènes Web sont également disponibles lorsque vous cliquez sur Import Map (Importer une carte) Importer une carte sur l’onglet Insert (Insérer) du ruban.

Mettre à jour une carte ou une scène

Lorsqu’une carte ou une scène Web du projet est mise à jour sur le portail actif, une notification apparaît à l’ouverture de la carte pour indiquer que la mise à jour est disponible. Mettez à jour la carte ou la scène dans votre projet avec la version actuelle de la carte ou de la scène Web du portail pour voir les changements dans votre projet. Toutes les modifications que vous avez effectuées sur la version précédente de la carte sont perdues. Si vous souhaitez enregistrer votre version de la carte dans un fichier avant de mettre à jour votre projet, fermez la notification et mettez à jour la carte ou la scène manuellement ultérieurement.

Agir lors d’une notification

  1. Cliquez sur le bouton des notifications Notifications pour ouvrir la fenêtre Notifications.
  2. Survolez une notification indiquant qu’une nouvelle version de votre carte ou de votre scène est disponible.
  3. Pour voir les modifications apportées, cliquez sur le bouton Bouton More (Plus) dans l’angle inférieur de la notification et sélectionnez Open Portal Item (Ouvrir l’élément du portail).

    La page décrivant l’élément dans le portail actif s’ouvre dans un navigateur.

  4. Cliquez sur Update Map (Mettre à jour la carte) ou sur Update Scene (Mettre à jour la scène).

    La version actuelle de l'élément stocké dans votre projet est supprimée. La carte ou la scène Web mise à jour est convertie au format de carte ArcGIS Pro avant d’être ajoutée au projet.

Mettre à jour manuellement

  1. Accédez à ou recherchez la carte ou la scène liée dans la fenêtre Catalog (Catalogue) ou dans la vue du catalogue.
  2. Cliquez avec le bouton droit sur la carte ou la scène liée, puis sélectionnez Update (Mettre à jour) Mettre à jour.

Rubriques connexes