Skip To Content

Fenêtre Projet, vue du projet et boîte de dialogue Parcourir

Lorsque vous créez ou ouvrez un projet, la fenêtre Catalogue est l'une des premières à apparaître. La vue du catalogue est ouverte et active lorsque vous créez un projet en utilisant le modèle de projet vierge Catalog (Catalogue) fourni avec ArcGIS Pro. La fenêtre Catalog (Catalogue) et la vue du catalogue vous permettent d’accéder à tous les éléments associés à un projet spécifique à un seul endroit, qu’ils soient disponibles sur un ordinateur local ou en réseau, dans ArcGIS Online ou dans un portail ArcGIS Enterprise.

Dans la fenêtre Catalogue et la vue du catalogue, vous pouvez effectuer les opérations suivantes :

  • Découvrir du contenu SIG sur des réseaux locaux ou le portail de votre organisation.
  • Explorer et rechercher des couches à ajouter à une carte ou à analyser avec un outil.
  • Etablir une connexion à des bases de données et des serveurs.
  • Dossiers, bases de données et connexions serveur favoris fréquemment utilisés.
  • Créer et importer des cartes, des scènes, des mises en page, des tâches et d’autres éléments.
  • Afficher un aperçu des données d’un élément et créer une miniature.
  • Décrire votre projet et ses éléments.
  • Gérer les éléments d’un projet, d’une géodatabase, d’une boîtes à outils, d’un dossier ou d’un style.

Lorsque vous construisez votre projet en ajoutant des cartes, des scènes, des mises en page, des connexions à des dossiers, des géodatabases, etc., ces éléments apparaissent dans l’onglet Project (Projet) de la fenêtre Catalog (Catalogue) et dans la collection Project (Projet) de la vue du catalogue, classés par type.

La fenêtre Catalog (Catalogue) et la vue du catalogue permettent d’effectuer des tâches différentes. Vous pouvez ouvrir simultanément la fenêtre et la vue, mais elles fonctionnent indépendamment. Vous pouvez passer d’une tâche à une autre sans perdre le travail commencé dans l’une ou l’autre. Vous pouvez, par exemple, modifier des symboles d'un style personnalisé dans la vue du catalogue et interrompre cette tâche pour ajouter des couches à une carte via la fenêtre Catalogue.

Remarque :

La première fois que vous accédez à un emplacement, la liste du contenu contient les éléments présents. Si son contenu est modifié en dehors d'ArcGIS Pro ou par quelqu’un d’autre, vous devez actualiser le contenu de l’emplacement pour voir ce changement. Par exemple, appuyez sur F5 pour mettre à jour la liste.

Fenêtre Catalogue

La partie supérieure de la fenêtre Catalog (Catalogue) comporte des onglets permettant d’accéder aux collections d’éléments.

Utilisez la fenêtre du catalogue pour accéder aux éléments et faire glisser des données sur une carte ou un paramètre d’outil.

L’onglet Project (Projet) permet d’accéder à la collection d’éléments de votre projet. Il est sélectionné par défaut. L’onglet Portal (Portail) permet d’accéder aux collections de contenu en ligne disponibles sur le portail actif que vous êtes autorisé à utiliser. L’onglet Favoris vous permet de collecter les dossiers, bases de données et connexions serveur fréquemment utilisés et de les ajouter à votre projet. L’onglet History (Historique) permet d’accéder à l’historique de géotraitement et des fonctions raster du projet.

Dans la fenêtre Catalogue, vous pouvez effectuer les opérations suivantes :

  • Répertoriez les éléments de plusieurs conteneurs simultanément.
  • Recherchez des éléments en saisissant des mots-clés dans la zone Rechercher, puis appuyez sur la touche Entrée.
  • Survolez un élément pour faire apparaître une fenêtre contextuelle indiquant son emplacement, son titre, une miniature, des balises et la date de modification, si les fenêtres contextuelles sont activées et si ces informations sont disponibles.
  • Utilisez la combinaison Ctrl+clic ou Maj+clic pour sélectionner plusieurs éléments et les ajouter simultanément à une carte, par exemple.

La fenêtre Catalogue s'ancre dans l'application ArcGIS Pro et permet d'accéder aux éléments de votre projet et du portail actif pendant que vous travaillez. Lorsque vous explorez ou recherchez du contenu, vous pouvez faire glisser des couches sur des cartes, des jeux de données sur des outils, des outils sur des modèles, etc.

Rouvrir la fenêtre Catalogue

La fenêtre Catalogue est habituellement disponible lorsque vous créez ou ouvrez un projet. Une fois fermée, vous pouvez rouvrir cette fenêtre en procédant comme suit :

  1. Cliquez sur l’onglet View (Afficher) du ruban.
  2. Dans le groupe Windows (Fenêtres), cliquez sur Catalog Pane (Fenêtre Catalogue) Fenêtre Catalogue.

Copier le chemin d’accès à un élément

Si la vue active est la vue du catalogue ou la vue cartographique, le bouton Copy Path (Copier le chemin d’accès) est disponible sur le ruban.

  1. Dans la fenêtre Catalog (Catalogue), sélectionnez les éléments dont vous souhaitez connaître le chemin.

    Sélectionnez des éléments auxquels le projet fait référence, les éléments accessibles via une connexion aux dossiers, les éléments du portail ou les éléments favoris.

  2. Cliquez sur le bouton Copy Path (Copier le chemin d’accès) Copier le chemin d’accès sur le ruban, dans le groupe Clipboard (Presse-papiers).
    • Si la vue du catalogue est active, cliquez sur l’onglet Catalog (Catalogue) du ruban.
    • Si la vue cartographique est active, cliquez sur l’onglet Map (Carte) du ruban.

Masquer et afficher la fenêtre contextuelle

La fenêtre Catalog (Catalogue) présente une fenêtre contextuelle par défaut lorsque vous survolez un élément avec le pointeur. Masquez la fenêtre contextuelle si vous connaissez vos données et trouvez qu’elle masque la vue.

  1. Ouvrez la vue du catalogue.
  2. Cliquez sur l’onglet View (Afficher) du ruban.
  3. Dans le groupe Options, décochez Show Pop-ups (Afficher les fenêtres contextuelles).
  4. Dans la fenêtre Catalog (Catalogue), cliquez sur le bouton Menu Menu et cochez l’option Show Pop-ups (Afficher les fenêtres contextuelles) pour rétablir l’affichage des fenêtres contextuelles.

Afficher des informations supplémentaires dans la fenêtre Catalogue et la boîte de dialogue de navigation

Certains éléments affichent plus d’informations que d’autres dans la fenêtre contextuelle de la fenêtre Catalog (Catalogue) et la fenêtre des détails de la boîte de dialogue de navigation. Tous les éléments peuvent indiquer leur titre, leur type et leur emplacement. Les éléments de portail peuvent également indiquer leur propriétaire. La plupart des éléments peuvent aussi préciser une date de modification.

Lorsque vous utilisez une collection d’éléments nouveaux ou mal connus, des informations complémentaires peuvent être utiles. Si vous décidez de voir plus de détails et parcourez les éléments en local ou sur le réseau, la fenêtre contextuelle de la fenêtre Catalog (Catalogue) affiche la miniature et les balises des éléments. Lorsque vous parcourez les éléments du portail, la fenêtre des détails de la boîte de dialogue de navigation affiche un résumé des éléments. Après avoir activé l’option pour afficher davantage d’informations et parcourir les emplacements locaux ou sur le réseau dans la vue du catalogue, les informations complémentaires sont disponibles dans la fenêtre contextuelle et la fenêtre des détails.

  1. Ouvrez la vue du catalogue.
  2. Sur l’onglet View (Vue), dans le groupe Options, cochez l’option More Details (Plus de détails).
  3. Accédez au dossier dans la vue du catalogue.
  4. Dans la fenêtre Catalog (Catalogue), accédez au même dossier et survolez l’élément pour afficher sa fenêtre contextuelle.

Pour les éléments locaux et situés sur le réseau, les informations supplémentaires doivent être extraites des métadonnées des éléments, si elles existent, ce qui ralentit l’accès. L’accès aux éléments du portail n’est pas affecté.

Vue du catalogue

Les collections d’éléments Project (Projet), Portal (Portail) et Favorites (Favoris) sont disponibles dans la vue du catalogue, ainsi que dans la fenêtre Catalog (Catalogue). Lorsque la vue du catalogue est active, passez des catégories aux collections des éléments et réciproquement, dans la fenêtre Contents (Contenu).

Les éléments d’une collection ou d’une catégorie s’affichent dans la vue du catalogue. Le type d’affichage en colonnes est adapté à la gestion des éléments. Le nom, le type et la date de modification de l’élément sont indiqués, ainsi que le propriétaire s’il s’agit d’un élément de portail. Vous pouvez trier le contenu selon n’importe quelle colonne.

La vue du catalogue présente les propriétés de l’élément dans les colonnes et affiche un aperçu des données.

Le type d’affichage des tuiles dans la vue du catalogue permet d’explorer les éléments d’une bibliothèque. Cette méthode est utile si vous ne savez pas quel élément utiliser, et surtout si vous accédez au portail actif pour la première fois, ou si vous utilisez rarement ArcGIS Pro. Vous pouvez voir immédiatement le nom d’un élément, son type, la miniature et la date correspondantes, si ces informations sont disponibles.

La vue du catalogue présente les propriétés des éléments et les miniatures dans des tuiles et métadonnées des éléments pour vous aider à explorer les éléments mal connus.

Des informations supplémentaires sont disponibles dans le volet des détails. L’onglet Metadata (Métadonnées) affiche les métadonnées de la plupart des éléments. Pour les jeux de données spatiales et les cartes, l’onglet Geography (Géographie) permet de visualiser les données. Pour les jeux de données tabulaires, l’onglet Table permet de visualiser les données. Pour un style, vous pouvez afficher l’aperçu des symboles, les barres d’échelle, les flèches d’orientation vers le nord et d’autres éléments de style qu’il contient. Vous pouvez également modifier les propriétés d’un élément de style.

Dans la vue du catalogue, vous pouvez effectuer les opérations suivantes :

  • Cliquer avec le bouton droit sur l’espace inoccupé entourant la liste de contenus pour accéder au menu contextuel de l’emplacement actuel.
  • Cliquez sur le bouton Show/hide details panel (Afficher/masquer le volet de détails) Afficher/masquer le volet de détails dans l’angle supérieur droit pour masquer et afficher le volet de détails.
  • Utilisez le menu Categories (Catégories) pour accéder aux collections de Living Atlas.
  • Utilisez le bouton de bascule Bouton de bascule du type d’affichage dans l’angle inférieur de la vue pour passer du type d’affichage en tuiles au type d’affichage en colonnes et inversement.
  • Cliquez, par exemple, sur Folders (Dossiers) ou sur My Content (Mon contenu), puis cliquez dans la zone Search (Rechercher). Spécifiez le nom de l’élément que vous souhaitez trouver et appuyez sur Entrée. Cliquez sur l'élément à utiliser dans la liste des résultats de recherche.

Cliquez sur vos éléments dans la vue du catalogue. Les boutons de l’onglet Catalog (Catalogue) sur le ruban s’actualisent dynamiquement pour illustrer ce que vous pouvez faire dans l’emplacement actuel ou avec les éléments sélectionnés. Certaines catégories d’éléments de projet peuvent également afficher un onglet contextuel comportant des options supplémentaires destinées à gérer les éléments.

Développez les catégories et les collections des éléments dans la fenêtre Contents (Contenu) pour dresser la liste des éléments contenant eux-mêmes d’autres éléments. Cliquez sur un élément dans la fenêtre Contents (Contenu) ou double-cliquez sur un élément dans la liste de contenus de la vue du catalogue pour répertorier son contenu dans la vue du catalogue. La vue du catalogue affiche un seul niveau de la hiérarchie d’une collection à la fois. Les options supplémentaires suivantes sont disponibles dans la vue du catalogue pour parcourir les collections d’éléments :

  • La barre Emplacement du haut indique votre emplacement actuel. Cliquez sur la barre pour copier le chemin de l’emplacement.
  • Cliquez sur une section du chemin de votre emplacement actuel dans la barre Emplacement pour accéder à cet emplacement.
  • Cliquez sur une flèche de la liste déroulante dans la barre Location (Emplacement), puis sur un emplacement dans le menu pour parcourir cet emplacement.
  • Collez ou saisissez un chemin d'accès à un autre emplacement dans la barre Emplacement et appuyez sur Entrée pour accéder à cet emplacement. Une connexion aux dossiers est ajoutée au projet si l’emplacement n’est pas déjà disponible dans votre projet.
  • Cliquez sur Up (Haut) Haut pour remonter d’un niveau dans la hiérarchie de la collection actuelle.
  • Cliquez sur Back (Précédent) Retour pour revenir au dernier emplacement.
  • Cliquez sur Forward (Avant) Avant pour revenir à un emplacement précédent.
Remarque :

La fenêtre Catalog (Catalogue) n’interagit pas directement avec la vue du catalogue. En d’autres termes, l’exploration, la recherche et la sélection d’éléments dans la fenêtre Catalog (Catalogue) n’a aucun effet sur l’emplacement ou l’élément sélectionné dans la vue du catalogue. Toutefois, si vous ajoutez ou supprimez des éléments du projet, tels qu’une connexion aux dossiers, dans la fenêtre Catalog (Catalogue), la liste de contenu dans la vue du catalogue s’actualise en conséquence.

Ouvrir une vue du catalogue

Dans le ruban, vous pouvez ouvrir plusieurs vues du catalogue et les utiliser pour comparer le contenu de bases de données ou de dossiers, comparer les métadonnées de deux éléments, copier des éléments de style d’un style vers un autre, etc.

  1. Cliquez sur l’onglet View (Afficher) du ruban.
  2. Dans le groupe Windows (Fenêtres), cliquez sur Catalog View (Vue du catalogue) Vue Catalogue.

Une nouvelle vue du catalogue s’ouvre. Les vues du catalogue existantes et la fenêtre Catalog (Catalogue) restent ouvertes, le cas échéant, et permettent toujours d’accéder aux éléments dans leur emplacement actuel.

Passage de la fenêtre Catalogue à la vue Catalogue et inversement

Lorsque vous passez à une tâche qui exige la vue du catalogue ou qui s’accomplit plus facilement dans la vue du catalogue, la fenêtre Catalog (Catalogue) peut devenir gênante.

  1. Dans la fenêtre Catalog (Catalogue), cliquez sur le bouton Menu Menu.
  2. Cliquez sur Switch to View (Activer la vue) Expansion.

La fenêtre Catalogue se ferme et la vue du catalogue s'ouvre.

Astuce:

Si vous avez besoin d’une place plus importante dans la vue du catalogue, vous pouvez par exemple la détacher et la positionner sur un autre écran. Vous pouvez également utiliser Auto Hide (Masquer automatiquement) pour masquer temporairement la fenêtre Catalog (Catalogue) si vous laissez la vue du catalogue ancrée dans l’application ArcGIS Pro. Vous avez également la possibilité de fermer entièrement la fenêtre Catalog (Catalogue).

Trier la liste de contenus

Lorsque vous accédez au contenu d’un dossier dans la fenêtre Catalog (Catalogue) et la vue du catalogue, les éléments sont organisés par défaut selon les groupes suivants : dossiers, bases de données, boîtes d’outils, jeux de données spatiaux DAO, serveurs SIG, jeux de données spatiaux et cartes, tables et d’autres fichiers. Chaque groupe comporte des éléments classés alphabétiquement dans l’ordre croissant.

Vous pouvez modifier la façon dont les éléments sont triés. Différentes propriétés permettent de trier les différentes collections d’éléments. Pour les éléments conservés sur un disque local ou réseau, les éléments peuvent être triés par nom et type ; une date de modification est disponible pour certains éléments. Lorsque vous gérez le contenu d’un style donné, les éléments de style peuvent être triés par nom, par catégorie et par clé. Vous pouvez rétablir la présentation par défaut de la liste de contenus à tout moment.

  1. Sous l’onglet Catalog (Catalogue), dans le groupe Organize (Organiser), cliquez sur la flèche de liste déroulante Sort (Trier).
  2. Cliquez sur l’une des propriétés disponibles de l’élément pour trier les éléments dans votre emplacement actuel telles que Date.

    La liste de contenus est triée à l’aide des valeurs dans la colonne spécifiée. Les éléments sont classés par ordre alphabétique croissant pour toutes les propriétés hormis la date. Si Date est sélectionnée, les éléments sont classés par date dans l’ordre décroissant, c’est-à-dire de l’élément le plus récent au plus ancien.

  3. Pour inverser l’ordre de tri, cliquez sur la flèche de la liste déroulante Sort (Trier) et cliquez à nouveau sur la propriété.
  4. Pour rétablir l’ordre dans lequel les éléments se trouvaient initialement, cliquez sur la flèche de la liste déroulante Sort (Trier) et sur Default Sort (Tri par défaut).
Astuce:

Lorsque vous utilisez le type d’affichage des colonnes, cliquez sur un en-tête de colonne pour trier la liste de contenus par cette information. Cliquez une nouvelle fois sur l’en-tête pour inverser l’ordre dans lequel les éléments sont triés par les valeurs de cette colonne.

Modifier le type d’affichage

La vue du catalogue utilise par défaut le type d’affichage en colonnes afin de faciliter la recherche et la gestion des éléments familiers. Si vous utilisez des données que vous ne connaissez pas ou si vous gérez le contenu d’un style, modifiez la vue du catalogue pour passer au type d’affichage en tuiles.

  1. Sur l’onglet View (Vue), dans le groupe Options, cliquez sur Display Type (Type d’affichage) puis sur Tiles (Tuiles) pour voir les propriétés des éléments sur les tuiles.
  2. Cliquez sur Columns (Colonnes) sur le bouton de bascule Bouton de bascule du type d’affichage dans l’angle inférieur de la vue du catalogue pour afficher les propriétés des éléments dans des colonnes.

Masquer et afficher le volet des détails

Le volet des détails est ouvert par défaut dans la vue du catalogue. Masquez le volet des détails pour afficher davantage de tuiles ou élargir les colonnes. Affichez le volet des détails pour en savoir plus sur un élément spécifique et afficher un aperçu de ses données.

  1. Sur l’onglet View (Vue), dans le groupe Options, désélectionnez la case Show Details (Afficher les détails) pour masquer le volet des détails.
  2. Dans la vue du catalogue, cliquez sur le bouton Show/hide details panel (Afficher/masquer le volet de détails) Afficher/masquer le volet de détails situé à droite de la zone de texte de recherche pour afficher le volet des détails.

Boîte de dialogue Parcourir

La boîte de dialogue Parcourir vous permet de sélectionner un élément de votre projet, un élément du portail ou un élément externe à votre projet en vue de l'utiliser pour une tâche spécifique. Lorsque vous cliquez sur le bouton Add Data (Ajouter des données) de l’onglet Map (Carte) dans le ruban, la boîte de dialogue de navigation apparaît avec le titre Add Data (Ajouter des données).

La boîte de dialogue de navigation permet d’explorer les éléments comme vous le faites avec la vue du catalogue. Les liens rapides donnent accès aux catégories et collections d’éléments disponibles, mais ne permettent pas de développer ces dernières pour afficher la liste de leur contenu. Les propriétés des éléments s’affichent dans des colonnes qui permettent de trier la liste de contenu. Une brève portion des métadonnées de l’élément sélectionné est disponible dans le volet des détails, avec l’emplacement et le propriétaire de l’élément, si l’élément sélectionné est accessible via le portail actif.

La boîte de dialogue de navigation peut afficher une brève portion des métadonnées d’un élément, notamment une miniature, dans le volet des détails.

Bien que les collections d’éléments Project (Projet) et Portal (Portail) demeurent accessibles, la collection Favorites (Favoris) n’est pas disponible dans la boîte de dialogue de navigation. Ajoutez les éléments favoris dont vous avez besoin au projet. Vous pouvez parcourir le portail actif et les emplacements inclus dans le projet actuel, à l’exception des connexions aux dossiers qui accèdent à la racine d’un disque.

La boîte de dialogue de navigation inclut une collection Computer (Ordinateur) qui permet d’accéder aux éléments et de les sélectionner à partir d’emplacements de l’ordinateur local ou du réseau qui ne figurent pas actuellement dans votre projet. Cette fonctionnalité permet d’ajouter une géodatabase fichier existante à votre projet ou d’importer le contenu d’un document ArcMap, par exemple. La recherche n’est pas disponible lorsque vous explorez l’ordinateur.

Vous accédez à la boîte de dialogue de la même manière qu’à la vue du catalogue, en cliquant sur les liens rapides, en double-cliquant sur les containers et en utilisant la barre Location (Emplacement) située en haut. Vous pouvez également effectuer les actions suivantes :

  • Cliquez sur la barre Emplacement ou dans la zone de texte Nom pour coller ou saisir le chemin d'accès à un nouvel emplacement, et appuyez sur Entrée. La boîte de dialogue accède à cet emplacement. Si l’emplacement n’est pas accessible à partir des lecteurs locaux ou réseau mappés de l’ordinateur, l’accès à l’emplacement réseau est effectué et les éléments qu’il contient sont répertoriés ; l’emplacement n’est pas ajouté au projet en tant que connexion de dossier.
  • Collez un chemin d’accès complet à un élément, y compris le nom de l’élément, dans la zone de texte Name (Nom) pour sélectionner immédiatement cet élément. Par exemple, collez un chemin d'accès complet à une table, y compris son nom, pour l'ajouter à la carte actuelle.
  • Lorsque les liens rapides Groups (Groupes) ou All Portal (L’intégralité du portail) sont sélectionnés, cliquez sur le bouton Search My Organization (Parcourir mon organisation) Parcourir mon organisation dans l’angle supérieur de la boîte de dialogue afin de n’inclure que les éléments du portail actif qui sont fournis par votre organisation dans les résultats de recherche.

Lorsque des éléments apparaissent dans la boîte de dialogue Parcourir, ils sont filtrés en fonction de leur utilité dans l'exécution de la tâche en cours. Par exemple, lorsque vous ajoutez des données à une carte, seuls ceux qui peuvent être ajoutés à une carte apparaissent. Lorsque vous importez des éléments dans un projet, seuls ceux qui peuvent être importés apparaissent. Seules les collections et catégories d’éléments qui sont pertinentes pour l’opération actuelle vous sont proposées.

Dans certains cas, la boîte de dialogue de navigation vous permet d’affiner davantage la liste de contenu en choisissant un filtre plus spécifique. Par exemple, si vous souhaitez ajouter un type spécifique d’élément à une carte, vous pouvez sélectionner un filtre qui répertorie uniquement ce type d’élément.

La boîte de dialogue de navigation présente les propriétés des éléments dans des colonnes qui peuvent servir à trier la liste et peuvent filtrer les éléments par type.

La boîte de dialogue de navigation sert parfois à accéder à un type spécifique de fichier qui n’est sinon pas disponible dans ArcGIS Pro. Par exemple, de nombreux outils de géotraitement importent des données depuis ou exportent des données dans des formats de données externes. Ces outils peuvent accepter n’importe quel type de fichier en entrée dans un paramètre, par exemple, en autorisant les fichiers de type *.*. Dans ce cas, la boîte de dialogue de navigation peut répertorier toutes les collections et catégories d’éléments disponibles et afficher tous les types d’éléments et de fichiers même si le titre de la boîte de dialogue et le filtre indiquent que vous devez sélectionner un type spécifique de fichier. Vous pouvez ainsi sélectionner des fichiers avec n’importe quelle extension contenant des données dans le format spécifié.

Des fonctionnalités limitées sont disponibles pour gérer vos éléments dans la boîte de dialogue de navigation.

Rubriques connexes