Skip To Content

Georeferencing CAD data

The tools needed to georeference a CAD dataset in ArcGIS Pro are located on the CAD Layer tab. These interactive tools can help you reposition the data as well as register control points to specific geographic coordinates.

To display the tab, click the CAD Layer tab, which appears when a CAD feature layer is selected in the Contents pane. Next, click Georeference Georeference in the Alignment group.

CAD Tools tab

The following sections are organized as a guide in the order of a typical georeferencing workflow. The methods you ultimately use and the order in which you perform them can vary depending on your data.

Choose a georeferencing layer

All commands and tools on the CAD Layer tab act on the CAD feature layer highlighted in the Contents pane. Georeferencing a single CAD feature layer applies that transformation to the entire dataset. Once you have georeferenced a CAD feature layer, you can then add the other feature classes of that dataset to the map, and they will be constrained by the same control points.

Note:

The CAD Layer tab is not visible with a CAD group layer selected. To display the tab, select a child feature layer within the CAD group layer.

CAD feature layer selected in the Contents pane.

Assign a spatial reference

If your CAD dataset does not have a coordinate system defined, you can apply one using the Define Projection tool Define Projection in the Alignment group under CAD Layer on the Tools tab. Assigning a spatial reference is a best practice for producing an accurate transformation.

Move the dataset to the current view

If the CAD drawing's origin coordinate (0,0,0) is significantly different than that of the map projection in your data frame, the CAD dataset may be added outside your data extent. When this happens, zoom to the destination area and click Fit To Display Fit to Display in the Prepare group under under CAD Layer on the Tools tab. This shifts and scales the dataset to fit the current view regardless of where it is located.

Rotate, move, or scale the dataset

In most cases, positioning your dataset before adding control points can help you complete your task more easily. The Rotate Rotate, Move Move, and Scale tools Scale allow you to manipulate the dataset without using control points. These buttons are in Prepare group under CAD Layer on the Tools tab.

Add control points

Adding control points is the best practice for conducting a precise georeference. Control points allow you to snap specific CAD features in your dataset to corresponding features in your control data.

To start adding control points, click Add Control Points Add Control Points on the Adjust group under CAD Layer on the Tools tab. To update the map display based on the control points created, click Apply Apply.

In the Control Point Table, you can modify the numeric values of your control points as you create them. To open the Control Point Table, click Control Point Table Open Control Point Table in the Review group under CAD Layer on the Tools tab.

Saving the transformation

After adding control points manually, or loading them from a world file, you have the following three ways of saving the transformation and georeferencing the dataset—all commands are available from the ribbon:

  • The Save command saves the control points to a world (.wld) file in the CAD workspace and applies the transformation.
  • The Save To Workspace command saves a universal world file (esri_cad.wld) to the CAD workspace.
  • The Save as New command opens the Save as dialog box, allowing you to save a world file or universal world file outside of the CAD workspace.