Skip To Content

Introduction to modifying features

In the Modify Features pane Modify Features, editing tools modify existing features. The My Tools tab contains the same customizable list of tools that displays in the Tools gallery on the ribbon. The All Tools tab contains all editing tools that are available to your project.

For a full list of editing tools, see Modify Features tool reference.

You can filter and search for tools that perform a specific edit by typing a matching text string contained in the tool name or functional group. You can show the tools in alphabetical order or grouped by function, and as large or small icons.

Editing tools can be one of the following types:

  • Interactive tools use the pointer to select and edit features. Most tools are interactive.
  • Execution tools run like geoprocessing tools. You can specify parameters and click the button at the bottom of the pane to execute your edits.

For a basic workflow to create and modify features, see Get started editing.

Selection tools

Selection tools that appear in the pane with an active editing tool include additional functionality that can streamline your workflow. Using them to select features is the best practice. They inherit their selection methods from the active selection tool on the Edit tab.

To learn more about selecting features, see Select features for editing.

Topological edits

When you enable map topology, the Features and Edges tabs appear for tools that move, reshape, or edit vertices. You can modify finished features or modify individual edges. Clicking a tab finishes the current edit and switches the editing mode.

Map topology models segments as edges, and point features, endpoints of lines, and intersections as nodes. Edges and nodes denote how features are attached to one another. When you edit topological edges, they appear as a highlighted overlay that correlates directly to the visible features you are editing.

To learn more, see Introduction to editing topology.

Related topics