Skip To Content

Add styles to a project

Styles are collections of reusable items such as symbols and other assets that appear on maps, scenes, and layouts. A project can contain many styles. You add styles from the Catalog pane or a Catalog view.

Add a system style to the project

System styles are styles authored by Esri that are included with ArcGIS Pro. New projects include connections to ArcGIS 2D, ArcGIS 3D, ArcGIS Colors, and ColorBrewer Schemes (RGB) system styles. You add and remove system styles from the System Styles dialog box.

  1. On the Insert tab, in the Style group, click Add and click Add System Style Add System Style.
    The System Styles dialog box appears. System styles are grouped by theme in the list on the left.
  2. Use the check boxes to manage the list of project styles shown on the right.
  3. Click OK to confirm the current list of project styles.
Tip:

You can also add system styles to the project from the Catalog pane. Right-click the Styles folder Styles Folder, click Add and click Add System Style.

Legacy:

Many older styles have been retired and are not included in ArcGIS Pro as system styles, but you can still access them. Many have been converted to ArcGIS Pro *.stylx format and placed on ArcGIS Online at https://esri-styles.maps.arcgis.com/home/index.html. In the Catalog pane, under the Portal tab, click All Portal All Portal and search for stylx to find all available style files.

Or, if you have ArcMap installed, you can import any of the styles included in that install to the ArcGIS Pro format. On the Insert tab, in the Styles group, click Import Import Style File and browse to [install drive]:\Program Files (x86)\ArcGIS\Desktop<version#>\Styles. Choose a style Style file and click OK. An ArcGIS Pro *.stylx version of the style is created in the project home folder and added to your project.

Add a custom style to the project

In addition to the system styles provided by ArcGIS Pro, you can add other styles—created by you or someone else—provided they are located on an accessible local or network drive, or on ArcGIS Online. You can browse to a style from the Styles folder in the Catalog pane or access them directly from the project folders. Styles have a *.stylx file extension. Styles from previous releases of ArcGIS Desktop have *.style extensions. These files must be imported to use in a project.

Note:

Style files (.stylx) created using ArcGIS Pro 2.0 cannot be opened by previous versions of ArcGIS Pro.

  1. On the Insert tab, in the Style group, click the Add Styles Add Style drop-down arrow and click Add Style Add Style.
  2. Browse to a style Style file (*.stylx) (*.stylx file), and click OK to add the style to the project.
Tip:

You can also add custom styles to the project from the Catalog pane. Right-click the Styles folder Styles Folder, click Add and click Add Style Add Style. Or, in the Catalog pane, under the Project tab, browse through the project's folder connections Folder Connection to locate a style Style file (*.stylx) (*.stylx file). Right-click the style and click Add Style Add Style.

Add styles from ArcGIS Online

You can browse to or search for styles on ArcGIS Online from within ArcGIS Pro. These may be styles created by Esri for specific industries in specific languages, or styles created by you, your organization, or someone else. Only ArcGIS Pro styles (*.stylx files) are stored on ArcGIS Online. ArcGIS Desktop styles (*.style files) are not valid ArcGIS Online items. Styles added to a project from ArcGIS Online become a project item to that project but are stored in your user profile at [drive]:\Users\[your_name]\Documents\ArcGIS\OnlineStyles.

  1. In the Catalog pane, under the Portal tab, click one of the Portal icons to choose what realm to search from—within your content My Content, your groups Groups, or from all of Portal All Portal.
  2. If necessary, type a search term into the field at the top of the pane.
  3. Right-click a style Style file (*.stylx) and click Add Style Add Style.
Tip:

Search for stylx to find all available style files.

Upgrading styles

Styles created in older versions of ArcGIS Pro may reference an older symbol model and may have limited compatibility with the current version of ArcGIS Pro.

When you add an out-of-date style, you are notified and given an option to upgrade the style. If you do not upgrade the style, you can add it to your project and apply symbols and style items from it to your maps, but the style itself will be read-only. If you choose to upgrade it, a copy of it will be made in the same location as the original style, and the new editable version will be added to the project. You can upgrade an out-of-date style after it has been added to a project. Right-click the style in the Catalog pane or a Catalog view and click Upgrade Upgrade.

Unsupported styles

If the status indicates that a style is not supported, it is because the style was created in or upgraded by a newer version of ArcGIS Pro, or the style is somehow corrupt. Check the path where the style is located; a copy of the style for the correct version may have been generated previously.

Import a style into the project

Styles used in ArcMap, ArcGlobe, and ArcScene cannot be used directly in ArcGIS Pro because they are structured differently. However, you can import a style into ArcGIS Pro, which makes an ArcGIS Pro version of it and adds it to your project.

Caution:
Ensure that any fonts associated with the style are installed in the fonts directory on your computer before importing.

  1. On the Insert tab, in the Style group, click Import Import Style File.
  2. Browse to a style Style file (*.style file) and click OK to create a *.stylx file and add it to the project.
Tip:

You can also import styles from the Catalog pane. Under the Project tab, right-click the Styles folder Styles Folder and click Import Import. Or, browse through the project's folder connections Folder Connection to locate a style Style file (*.style file). Right-click the style and click Import Import.

Create a new style in the project

You can create new, empty styles at any time. Use the Catalog view to copy style items from other project styles into it, or create new style items directly.

  1. On the Insert tab, in the Style group, click New Style New System Style.
    • Click New Style to create a new custom ArcGIS Pro style.
    • Click New Mobile Style to create a mobile style suited for use with maps that will be shared in mobile apps.
  2. Browse to a folder to store the new style. Type a name for the new style and click Save.

Related topics