Skip To Content

Get started editing

ArcGIS Pro automatically starts an edit session when you modify existing data or create new data in a map or scene. Saving or discarding your edits automatically stops the edit session. You can edit any data source that is granted view and edit privileges.

Editing is performed with tools on the ribbon, on the editing toolbar, and in panes. Commands on the editing context menu appear for specific tools and enable them to perform a variety of related edits.

The following sections introduce a basic workflow you can use to get started editing features in a map. For detailed steps to use a specific tool, browse the table of contents or search the help using a keyword or phrase.

Open the project

Open the project containing the map and features you want to edit. If you don't have an existing project, you can create a new project and use the default geodatabase that appears with the same name as the project in the Catalog Pane.

  1. Start ArcGIS Pro and sign in if necessary.
  2. On the start page, do one of the following:
    • Open a recent project Catalog View.
    • Click Open another project Browse and browse to the project.
    • Create a new project using a project template Project Template.
    Note:

    When you open a project on a Portal All Portal connection, the project package (.ppkx) is downloaded and unpacked in the <User Documents>\ArcGIS\OnlineProjects folder. After you close the project, the unpacked project file (.aprx) appears in the recent projects list.

  3. On the View tab, in the Windows group, click the Catalog drop-down arrow, and click Catalog Pane Catalog Pane.

    The Catalog pane appears.

    Catalog pane

  4. Expand Maps , and do one of the following:
    • Right-click the map, and click Open Map View.
    • On the Insert tab, in the Project group, click New Map New Map.

    The map opens.

Add data to the map

When you drag a feature class onto an active map, a feature template with default settings is automatically created.

  1. In the Catalog pane, expand Databases Database Folder.
  2. Expand the database containing your data and drag the feature class onto the map.

    The layer is added to the active map, and a feature template with default settings is automatically created for each new layer.

Create a new feature class

If you don't have existing feature data, you can right-click the default geodatabase and create a new feature class.

  1. Right-click the default database, click New, and click Feature Class Polygon feature class.

    The Geoprocessing pane appears.

    Create Feature Class

  2. Type the feature class name.
  3. Click the Geometry Type drop-down arrow and choose a geometry type.
  4. Specify a coordinate system using one of the following methods:
    • Click the Coordinate System drop-down arrow and choose the coordinate system that is specified for the map or a layer in the map.
    • Click Select coordinate system Coordinate System and select a coordinate system.
  5. Click Run Run.

    The feature class is created, the layer is added to the active map, and a feature template with default settings is automatically created.

Document your data

To document your data, update the item's metadata tag and summary fields with information that briefly describes its purpose and content. For example, type a concise reason why you created the project, or what kind of data a feature class captures.

Note:

Metadata is data that describes other data. It is used to document and structure data so that it is discoverable and more easily searched. Accurate metadata can help other users assess the quality and appropriateness of using your data for their data compilation or analysis needs.

To learn more, see Best practices for editing metadata.

  1. In the Catalog pane, right-click the feature class and click View Metadata Document Metadata.

    The Catalog view opens and the Home tab appears on the ribbon.

  2. On the Home tab, in the Metadata group, click Edit Edit.

    The Metadata view opens.

  3. In the Metadata view, type one or more keywords in the Tags text box.

    When you hover over the feature class in the Catalog pane, tags appear with the pop-up information.

  4. In the Summary (purpose) text box, type information that explains why you created the data.
  5. On the Metadata tab, in the Manage Metadata group, click Save Save Edits.
  6. Close the Metadata view and the Catalog view.

Add attribute fields

When you create a new feature class, it contains only system fields that define the object and its shape. Using tools on the Data tab, you can add, delete, or modify attributes fields for the data you want to record with each feature.

To learn more about fields, see An overview of fields .

  1. On the View tab, in the Windows group, click Contents Contents.

    The Contents pane appears.

    Contents pane

  2. Click the new feature layer.

    The Feature Layer contextual tab set appears on the ribbon containing Appearance, Labeling, and Data tabs.

  3. On the Data tab, in the Design group, click Fields.

    The Fields view opens, and the Fields tab appears on the ribbon.

  4. On the Fields tab, in the Changes group, click New Field.

    A new field is added to the feature table.

  5. Double-click the Field Name field and type a name.
  6. Double-click the Data Type field, choose a data type, and do the same for the other property fields that are relevant to your data type.
  7. On the Fields tab, in the Changes group, click Save Save Edits.
  8. Close the Fields view.

Symbolize the layer

Symbolizing a feature layer is the process of configuring a layer's properties to draw point, line or polygon features as specific symbols; for example, to identify what the features represent, or communicate qualitative or quantitative differences based on attribute values.

To learn more, see Symbolize feature layers .

  1. In the Contents pane, right-click the layer and click Symbology Symbology.

    The Symbology pane appears.

  2. Click the Symbology drop-down arrow, choose a type that is appropriate for your data, and configure its properties. You can symbolize features in different ways depending on the type of data it contains.

    The feature template symbol that appears in the Create Features pane updates automatically.

Confirm layer editability

There are no buttons to start or stop an edit session. A good practice is to confirm layer editability in the Editing Status dialog box before you start editing. In the Contents pane you can disable editing for layers you need to protect against unwanted edits.

  1. On the Edit tab, click Status Editing Status.

    The Editing Status dialog box appears.

  2. Review the editing permissions for the layers in your workspace, note the layers that you can edit, and click Close.
  3. In the Contents pane, click the List By Editing tab List By Editing and uncheck the layer you do not want edited.

Create features

In the Create Features pane, feature templates create features on specific layers. A feature layer's data source defines the two-dimensional (2D) or three-dimensional (3D) features a template creates.

To learn more, see Introduction to creating 2D and 3D features.

  1. On the Edit tab in the Features group, click Create Create Features.

    The Create Features pane appears.

    Create Features

    Note:

    Warning icons Warning and message notifications alert you when a template creates nonvisible features or when existing templates do not appear in the pane. To learn more, see Feature template messages.

  2. In the pane, click a feature template.
  3. Next to the tool palette, click the forward arrow Forward.

    The tool palette and the feature attribute table for the active template appear in the pane.

    Active Template
  4. Type the attribute values you want to apply to the new feature in the feature attribute table.
    Tip:

    To save the attribute values with the template and reuse them the next time you use the template, click the menu button Menu, and click Properties Properties.

  5. Click the map and create the feature.
    • You can use the default tool that automatically runs, or click another tool on the tool palette.
    • If you are creating a 3D feature, you can enter z-values using the tools on the Edit tab, in the Elevation group.
  6. To finish the feature, right-click and click Finish Finish, or press the F2 key.
  7. On the Edit tab, in the Manage Edits group, click Save Save Edits.

    The Save Edits dialog box appears.

    Save Edits

  8. Click Yes to save your edits to the geodatabase.

Modify a feature

When you modify a feature, you can select features with tools on the Edit tab before clicking an editing tool, or click an editing tool, and use the selection tool that appears in the Modify Features pane.

All editing tools that modify features open in the pane. They can be one of the following types:

  • Interactive tools use the pointer to select and edit features.
  • Execution tools run like geoprocessing tools. You can specify parameters and click the button at the bottom of the pane to execute your edits.

  1. On the Edit tab, in the Features group, click Modify Modify Features.

    The Modify Features pane appears.

    Modify Features

  2. Expand a tool category and click a tool.

    The tool opens in the pane.

  3. In the pane, click Select Active Select and select the feature or features you want to modify.

    The selected features are listed in the pane.

    Note:

    Tools that contain the Active Select tool Active Select finish your edits when you select another feature and immediately edit the new selection. This enables you to perform edits on several features successively in quick order.

  4. Edit the feature following the steps prescribed by the specific tool.
  5. To finish the feature, right-click and click Finish Finish, or press the F2 key.
  6. On the Edit tab, in the Manage Edits group, click Save Save Edits.

    The Save Edits dialog box appears.

    Save Edits
  7. Click Yes to save your edits to the geodatabase.